[Trac-bugs] [PC-BSD Trac] #1101: Upgrade to 10 > system damaged/graphic card not detected correctly

PC-BSD trac at pcbsd.org
Wed Apr 30 05:26:26 PDT 2014


#1101: Upgrade to 10 > system damaged/graphic card not detected correctly
-----------------------------------+-------------------------
 Reporter:  q/pa                   |      Owner:
     Type:  System Defect          |     Status:  new
 Priority:  critical               |  Milestone:
Component:  PC-BSD Updater         |    Version:  9.2-RELEASE
 Keywords:  upgrade, xorg, nvidia  |
-----------------------------------+-------------------------
 - Upgrade would not work from GUI, upgraded via CLI
 - After many hours (there was a loop uninstalling/reinstalling many PBIs)
 I was prompted to reboot.
 - After reboot, there was some GRUB error (to quick to read more than
 error) and I ended in the CLI.
 - startx results in an error saying there were no screens detected, though
 the nvidia metapkg was installed.
 - All my documents and fstab settings seem to have survived. Wifi is
 working, too.
 - After running 'grub-mkconfig -o /boot/grub/grub.cfg' I could access GRUB
 again.
 - Booting with the display wizard results in setting for the intel driver.
 But I never changed anything. The nvidia card was detected in 9.2 and
 working without problems.
 - Going back to the snapshot I took before the upgrade is showing me the
 same display problems as described above.
 - reinstalling the nvidia meta pkg and using a copy of my old xorg.conf
 file did not help either
 - mouse (touchpad) is painfully slow and the buttons work only
 erratically. The synaptics pad worked great in the old installation and I
 did disable moused in rc.conf and the entries for synaptics and nvidia in
 loader.conf are unchanged, too.

 What did go wrong? It seems to be some kind of xorg problem. Should I
 deinstall/reinstall the X pkg?

--
Ticket URL: <http://trac.pcbsd.org/ticket/1101>
PC-BSD <http://trac.pcbsd.org>
PC-BSD Project Management


More information about the Trac-bugs mailing list