[Trac-bugs] [PC-BSD Trac] #710: Automatic pkg upgrade fails: xscreensaver conflict with xscreensaver-gnome

PC-BSD trac at pcbsd.org
Tue Mar 5 17:33:40 PST 2013


#710: Automatic pkg upgrade fails: xscreensaver conflict with xscreensaver-gnome
--------------------------+----------------------------
 Reporter:  mjollnirpaul  |       Type:  System Defect
   Status:  new           |   Priority:  critical
Milestone:                |  Component:  PC-BSD Updater
  Version:  9.1-RELEASE   |   Keywords:  pgk, security
--------------------------+----------------------------
 and afterwards the meta-pkg list shown in the system-manager is empty.
 What now?

 I do not installed GNOME, only KDE.  Why do I need this pkg?

 System: PCBSD-9.1-RELEASE from /staging, 2013-02-26

 IMHO this is of priority:critical because failing to upgrade pkgs affects
 the security of the system.  I.e. I can not update pkgs although security
 fixes are available:
 $ pkg audit
 linux-f10-flashplugin-11.2r202.270 is vulnerable:
 linux-flashplugin -- multiple vulnerabilities
 sudo-1.8.6.p5 is vulnerable:
 sudo -- Potential bypass of tty_tickets constraints
 sudo-1.8.6.p5 is vulnerable:
 sudo -- Authentication bypass when clock is reset

 I do not know whether this is a bug of pkg or results from your assembly
 of meta-pkgs.  Frankly, it'll take at least two decades until we can
 overcome the dependency hell ;)

-- 
Ticket URL: <http://trac.pcbsd.org/ticket/710>
PC-BSD <http://trac.pcbsd.org>
PC-BSD Project Management


More information about the Trac-bugs mailing list