[Trac-bugs] [PC-BSD Trac] #255: Duplicate Sound Devices Detected...Sound Not Working

PC-BSD trac at pcbsd.org
Mon Feb 22 11:25:34 PST 2010


#255: Duplicate Sound Devices Detected...Sound Not Working
--------------------------------------+-------------------------------------
 Reporter:  fitzlt                    |       Owner:         
     Type:  System Defect             |      Status:  new    
 Priority:  major                     |   Milestone:  8.0    
Component:  System Configuration      |     Version:  8.0-RC2
 Keywords:  Sound, Multimedia, Audio  |  
--------------------------------------+-------------------------------------
Changes (by fitzlt):

 * cc: anyedge@… (added)


Comment:

 I apologize for the late response, I responded to the email I received on
 this ticket--it never even occurred to me to respond here until I got a
 delivery error on the email(I'm kind of new to bug reporting).

 When I "cat /dev/sndstat", I get this:

  root at pcbsd-2939# cat /dev/sndstat
  FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
  Installed devices:
  pcm0: <HDA Realtek ALC268 PCM #0 Analog> at cad 0 nid 1 on hdac0 kld
  snd_hda [MPSAFE] (1p:4v/1r:4v channels duplex default)
  pcm1: <HDA NVidia MCP78 HDMI PCM #0 Digital> at cad 3 nid 1 on hdac0
  kld snd_hda [MPSAFE] (1p:2v/0r:0v channels simplex)

 My computer is a Sager NP2096 laptop.  It has an onboard Realtek
 ALC268 with a separate nVidia GeForce 9600M GT video card.

 I went into /etc/sysctl.conf and hw.snd.default_unit was set to 1 and
 commented out.  First I removed the comment and rebooted.

 I played with the volume settings and any changes to volume affected
 the duplicate mixers as well(normally they are set individually).
 Still no sound.

 I then changed hw.snd.default_unit to 0 and rebooted.  Mixers were
 back to individual settings, but still no sound.

 Please let me know if there is anything else I can do.  Thank you for your
 help.

-- 
Ticket URL: <https://trac.pcbsd.org/ticket/255#comment:3>
PC-BSD <http://trac.pcbsd.org>
PC-BSD Project Management


More information about the Trac-bugs mailing list