[Trac-bugs] [PC-BSD Trac] #224: No audio output after PC-BSD 8.0 Install

PC-BSD trac at pcbsd.org
Tue Feb 2 13:12:36 PST 2010


#224: No audio output after PC-BSD 8.0 Install
----------------------------------+-----------------------------------------
 Reporter:  wmichaelb             |       Owner:  kris    
     Type:  defect                |      Status:  new     
 Priority:  major                 |   Milestone:          
Component:  System Configuration  |     Version:  8.0-BETA
 Keywords:                        |  
----------------------------------+-----------------------------------------

Comment(by wmichaelb):

 Kris: thanks for getting back, still no sound.

 I backed up both files first. My rc.conf file now looks like this:

 background_dhclient="YES"
 hostname="pcbsd"
 compat5x_enable="YES"
 sshd_enable="YES"
 usbd_enable="YES"
 devd_enable="YES"
 devfs_system_ruleset="devfsrules_common"
 ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib
 /usr/local/lib/compat/pkg"

 # Enable console mouse
 moused_type="auto"
 moused_enable="YES"

 # Enable the pcbsd startup / shutdown scripts
 pcbsdinit_enable="YES"

 #Enable samba server
 samba_enable="YES"
 winbindd_enable="YES"

 # Disable LPD
 lpd_enable="NO"

 # Enable CUPS
 cupsd_enable="YES"
 linux_enable="YES"

 # FSCK Enhancements
 fsck_y_enable="YES"
 background_fsck="NO"

 # tmpmfs Flags
 tmpmfs="YES"
 tmpsize="800m"
 tmpmfs_flags="-S"
 clear_tmp="YES"

 # Denyhosts Startup
 denyhosts_enable="YES"

 # powerd: adaptive speed while on AC power, adaptive while on battery
 power
 # WARNING: May cause crashes with nvidia driver
 #powerd_enable="YES"
 #powerd_flags="-a adaptive -b adaptive" # set CPU frequency

 # enable HAL / DBUS
 dbus_enable="YES"
 polkitd_enable="YES"
 hald_enable="YES"

 # Enables support for HPLIP
 hpiod_enable="NO"

 # Enable the firewall
 pf_rules="/etc/pf.conf"
 pf_enable="YES"
 pf_flags=""

 # Enable ipfw and open it by default since we have PF
 firewall_enable="YES"
 firewall_type="open"

 # Enable sound-support
 # snddetect_enable="YES"
 mixer_enable="YES"

 # Enable avahi_daemon
 avahi_daemon_enable="YES"

 # Run the port jail
 portjail_enable="YES"

 # Added for sound support in the portjail, access to /dev/random,
 /dev/null, etc.
 jail_pcbsd_devfs_enable="YES"

 # Start the swapmonitor
 swapmonitor_enable="YES"

 # Enable IPV6 support
 ipv6_enable="YES"

 warden_enable="YES"
 ntpd_enable="YES"
 # Auto-Enabled NICs from pc-sysinstallbackground_dhclient="YES"
 hostname="pcbsd"
 compat5x_enable="YES"
 sshd_enable="YES"
 usbd_enable="YES"
 devd_enable="YES"
 devfs_system_ruleset="devfsrules_common"
 ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib
 /usr/local/lib/compat/pkg"

 # Enable console mouse
 moused_type="auto"
 moused_enable="YES"

 # Enable the pcbsd startup / shutdown scripts
 pcbsdinit_enable="YES"

 #Enable samba server
 samba_enable="YES"
 winbindd_enable="YES"

 # Disable LPD
 lpd_enable="NO"

 # Enable CUPS
 cupsd_enable="YES"
 linux_enable="YES"

 # FSCK Enhancements
 fsck_y_enable="YES"
 background_fsck="NO"

 # tmpmfs Flags
 tmpmfs="YES"
 tmpsize="800m"
 tmpmfs_flags="-S"
 clear_tmp="YES"

 # Denyhosts Startup
 denyhosts_enable="YES"

 # powerd: adaptive speed while on AC power, adaptive while on battery
 power
 # WARNING: May cause crashes with nvidia driver
 #powerd_enable="YES"
 #powerd_flags="-a adaptive -b adaptive" # set CPU frequency

 # enable HAL / DBUS
 dbus_enable="YES"
 polkitd_enable="YES"
 hald_enable="YES"

 # Enables support for HPLIP
 hpiod_enable="NO"

 # Enable the firewall
 pf_rules="/etc/pf.conf"
 pf_enable="YES"
 pf_flags=""

 # Enable ipfw and open it by default since we have PF
 firewall_enable="YES"
 firewall_type="open"

 # Enable sound-support
 # snddetect_enable="YES"
 mixer_enable="YES"

 # Enable avahi_daemon
 avahi_daemon_enable="YES"

 # Run the port jail
 portjail_enable="YES"

 # Added for sound support in the portjail, access to /dev/random,
 /dev/null, etc.
 jail_pcbsd_devfs_enable="YES"

 # Start the swapmonitor
 swapmonitor_enable="YES"

 # Enable IPV6 support
 ipv6_enable="YES"

 warden_enable="YES"
 ntpd_enable="YES"
 # Auto-Enabled NICs from pc-sysinstall
 ifconfig_dc0="DHCP"
 ifconfig_fxp0="DHCP"
 hostname="pcbsd-5502"
 hpssd_enable="YES"

 warden_enable="YES"

 ifconfig_dc0="DHCP"
 ifconfig_fxp0="DHCP"
 hostname="pcbsd-5502"
 hpssd_enable="YES"

 warden_enable="YES"

 and my loader.conf file looks like this:

 # Kernel Options
 kern.ipc.shmseg=1024
 kern.ipc.shmmni=1024

 # Enable the splash screen
 vesa_load="YES"
 splash_pcx_load="YES"
 bitmap_load="YES"
 bitmap_name="/boot/loading-screen.pcx"

 # Load Wireless Support
 if_ipw_load="YES"
 if_iwi_load="YES"
 if_wpi_load="YES"
 legal.intel_ipw.license_ack=1
 legal.intel_iwi.license_ack=1
 legal.intel_wpi.license_ack=1

 # Load mmc card-reader support
 mmc_load="YES"
 mmcsd_load="YES"
 sdhci_load="YES"

 # Load support for scd
 scd_load="YES"

 # Load sound-support
 sound_load="YES"
 # snd_uaudio_load="YES"
 snd_hda_load="YES"

 # Load geom support
 geom_journal_load="YES"
 geom_uzip_load="YES"
 geom_mirror_load="YES"
 geom_eli_load="YES"

 # Load File-System Support
 libiconv_load="YES"
 libmchain_load="YES"
 cd9660_iconv_load="YES"
 msdosfs_iconv_load="YES"
 ntfs_load="YES"
 ntfs_iconv_load="YES"
 udf_load="YES"
 udf_iconv_load="YES"
 zfs_load="YES"
 sem_load="YES"
 nvidia_load="YES"
 kqemu_load="YES"
 aio_load="YES"
 hw.ata.atapi_dma="0"
 beastie_disable="NO"
 autoboot_delay="4"

 Finally, the mplayer window says this:

 #224 (No audio output after PC-BSD 8.0 Install) ??? PC-BSD.desktop
 Applications
 Documents
 Downloads
 Images
 Music
 PC-BSD.desktop
 Videos
 guide.desktop
 last.fm.desktop
 softmanager.desktop
 [mikeb1 at pcbsd-5502]/home/mikeb1/Desktop(32)% cd /home/mikeb1/Desktop/Music
 [mikeb1 at pcbsd-5502]/home/mikeb1/Desktop/Music(33)% ls
 01 Lay the Shovel Down.wma Norwegian_Wood.mp3
 [mikeb1 at pcbsd-5502]/home/mikeb1/Desktop/Music(34)% mplayer
 /home/mikeb1/Desktop/Music/Norwegian_Wood.mp3
 MPlayer 1.0rc2-4.2.1 (C) 2000-2007 MPlayer Team
 CPU: Intel(R) Pentium(R) 4 CPU 3.06GHz (Family: 15, Model: 2, Stepping: 9)
 CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
 Compiled with runtime CPU detection.

 Playing /home/mikeb1/Desktop/Music/Norwegian_Wood.mp3.
 Audio file file format detected.
 Clip info:
  Title: Norwegian Wood (This Bird Has
  Artist: Buddy Rich
  Album: Big Swing Face
  Year: 1967
  Comment: Amazon.com Song ID: 20205921
  Track: 1
  Genre: Jazz
 ==========================================================================
 Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
 AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
 Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
 ==========================================================================
 [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or
 directory
 AO: [null] 44100Hz 2ch s16le (2 bytes per sample)
 Video: no video
 Starting playback...
 Audio output truncated at end.7:20.0)  1.1%
 A: 222.9 (03:42.9) of 440.0 (07:20.0)  1.1%

 Exiting... (End of file)

 I'm no programmer, but I notice two things. Please note the first line of
 the mplayer window:

 #224 (No audio output after PC-BSD 8.0 Install) ??? PC-BSD.desktop

 and then a bit further down, after the data on the mp3 file, I notice
 this:

 [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or
 directory

 I will stop here to restore the original files and try again.

-- 
Ticket URL: <https://trac.pcbsd.org/ticket/224#comment:7>
PC-BSD <http://trac.pcbsd.org>
PC-BSD Project Management


More information about the Trac-bugs mailing list