<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 03/12/2014 16:36, Curt Dox wrote:<br>
    </div>
    <blockquote
cite="mid:CAHRv5yg7x3xJd-4-kB=F7HEa3F_Eh6SKOaitifR6Qpj0-F8kpg@mail.gmail.com"
      type="cite">
      <div dir="ltr"><br>
        <div class="gmail_extra"><br>
          <br>
          <div class="gmail_quote">On Wed, Mar 12, 2014 at 7:07 AM, Kris
            Moore <span dir="ltr"><<a moz-do-not-send="true"
                href="mailto:kris@pcbsd.org" target="_blank">kris@pcbsd.org</a>></span>
            wrote:<br>
            <blockquote class="gmail_quote" style="margin:0 0 0
              .8ex;border-left:1px #ccc solid;padding-left:1ex">
              <div bgcolor="#FFFFFF" text="#000000">
                <div><br>
                  Try installing src-qt4/libpcbsd first. Should fix all
                  those undefined ref errors. <br>
                  <div>
                    <div class="h5"> <br>
                      On 03/12/2014 07:20, Tigersharke wrote:<br>
                    </div>
                  </div>
                </div>
                <blockquote type="cite">
                  <div>
                    <div class="h5">
                      <div dir="ltr">I have had some difficulties and
                        somewhat "odd" behavior from KDE4 on my FreeBSD
                        box, so its entirely possible that there may be
                        various breakage related to KDE on other
                        systems.
                        <div><br>
                        </div>
                        <div> On a slightly different topic, I recently
                          updated the sysutils/pcbsd-utils on my system
                          but sysutils/pcbsd-utils fails:</div>
                        <div><br>
                        </div>
                        <div>
                          <blockquote class="gmail_quote"
                            style="margin:0px 0px 0px
0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">c++

                            -Wl,-O1 -pthread
                            -Wl,-rpath,/usr/local/lib/qt4 -o
                            pc-softwaremanager main.o  mainUI.o
                             pbiBackend.o  pbiDBAccess.o
                             processManager.o  configDialog.o
                             moc_mainUI.o  moc_smallItemWidget.o
                             moc_largeItemWidget.o  moc_pbiBackend.o
                             moc_processManager.o  moc_configDialog.o
                             qrc_SoftwareManager.o  
                             -L/usr/local/lib/qt4 -L/usr/local/lib
                            -L../libpcbsd
                            -lQtSolutions_SingleApplication-head
                            -lpcbsd-utils -lQtSvg -L/usr/local/lib/qt4
                            -L/usr/local/lib -lQtGui -lQtCore<br>
                            processManager.o: In function
                            `ProcessManager::ProcessManager()':<br>
                            processManager.cpp:(.text+0xa7): undefined
                            reference to
                            `DLProcess::DLProcess(QObject*)'<br>
                            processManager.cpp:(.text+0xcb): undefined
                            reference to `DLProcess::setDLType(QString)'<br>
                            processManager.cpp:(.text+0x14b): undefined
                            reference to
                            `DLProcess::DLProcess(QObject*)'<br>
                            processManager.cpp:(.text+0x19a): undefined
                            reference to
                            `DLProcess::DLProcess(QObject*)'<br>
                            processManager.cpp:(.text+0x1be): undefined
                            reference to `DLProcess::setDLType(QString)'<br>
                            processManager.cpp:(.text+0x23e): undefined
                            reference to
                            `DLProcess::DLProcess(QObject*)'<br>
                            processManager.cpp:(.text+0x28d): undefined
                            reference to
                            `DLProcess::DLProcess(QObject*)'<br>
                            c++: error: linker command failed with exit
                            code 1 (use -v to see invocation)<br>
                            *** Error code 1<br>
                            Stop.<br>
                            make[3]: stopped in
                            /usr/ports/sysutils/pcbsd-utils-qt4/work/src-qt4/pc-softwaremanager<br>
                            *** Error code 1<br>
                            Stop.<br>
                            make[2]: stopped in
                            /usr/ports/sysutils/pcbsd-utils-qt4/work/src-qt4<br>
                            *** Error code 1<br>
                            Stop.<br>
                            make[1]: stopped in
                            /usr/ports/sysutils/pcbsd-utils-qt4<br>
                            *** Error code 1<br>
                            Stop.<br>
                            make: stopped in
                            /usr/ports/sysutils/pcbsd-utils-qt4<br>
                          </blockquote>
                        </div>
                        <div><br>
                        </div>
                        <div class="gmail_extra"> </div>
                      </div>
                    </div>
                  </div>
                </blockquote>
              </div>
            </blockquote>
          </div>
          <br>
        </div>
        <div class="gmail_extra">That solved the problem, but would that
          mean that something is 'out of order' in the makefile?  I
          didn't do anything strange, though I have both the cli and gui
          tools installed on this FreeBSD 10/stable box.</div>
      </div>
    </blockquote>
    <br>
    Yea, it sounds like pc-softwaremanager needs something fixed in the
    Makefile.. I'll take a look at it. Thanks for the heads up!<br>
    <br>
    <br>
    <pre class="moz-signature" cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
  </body>
</html>