<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Thu, Jan 9, 2014 at 12:15 PM, Kris Moore <span dir="ltr"><<a href="mailto:kris@pcbsd.org" target="_blank">kris@pcbsd.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

  
    
  
  <div text="#000000" bgcolor="#FFFFFF"><div><div class="h5">
    <div>On 01/08/2014 19:54, Bridger
      Dyson-Smith wrote:<br>
    </div>
    </div></div><blockquote type="cite"><div><div class="h5">
      <p dir="ltr">Hi all, </p>
      <p dir="ltr">I'm getting some odd behavior with USB mice (I've
        tested a few different makes/models) with two different versions
        of PCBSD on two different laptops.</p>
      <p dir="ltr">Note: this oddness does not effect the built-in
        trackpad/button functionality, only the external mouse.</p>
      <p dir="ltr">Hardware:<br>
        ThinkPad X61, 9.2-RELEASE-p8 Mon Sep 23 16:26:45 UTC 2013 (LXDE)<br>
        ThinkPad T430s 10.0-RELEASE-p2 Mon Dec 30 23:53:14 UTC 2013
        (LXDE)</p>
      <p dir="ltr">Mice: two different Microsoft 3-Button Mouse with
        IntelliEye and a Dell something-or-other optical mouse with 3
        buttons.</p>
      <p dir="ltr">Odd behavior:<br>
        Mouse button 1 (left click) isn't recognized at all, and some of
        the left click behavior seems to be incorporated into button 2
        (the middle wheel, which also seems to be button 4/5). </p>
      <p dir="ltr">I've looked through the xorg-gui stuff, but I'm not
        really sure which file(s) I should modify, if any. Any
        suggestions for getting these external mice to cooperate? </p>
      <p dir="ltr">Thanks for your time & trouble,<br>
        Bridger</p>
      <br>
      <fieldset></fieldset>
      <br>
      </div></div><pre>_______________________________________________
Testing mailing list
<a href="mailto:Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a>
</pre>
    </blockquote>
    <br>
    That is odd. You may need to add a custom /etc/X11/xorg.conf file
    and do some magic to the InputDevice section:<br>
    <br>
    Section "InputDevice"<br>
        Identifier     "Mouse0"<br>
        Driver         "mouse"<br>
        Option         "Protocol" "auto"<br>
        Option         "Device" "/dev/sysmouse"<br>
        Option         "Buttons" "6"<br>
        Option         "ZAxisMapping" "4 5"<br>
        Option         "Emulate3Buttons"<br>
    EndSection<br>
    <br>
    Of course, some of the USB stuff is auto-detected, and you may be
    able to make changes in your respective WM as well, so in KDE you
    would look at system-settings -> input devices -> mouse. <br><span class="HOEnZb"><font color="#888888">
    <br>
    <br>
    <pre cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
  </font></span></div>

<br>_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></blockquote></div></div><div class="gmail_extra"><br></div><div class="gmail_extra">I can do that, or can I just continue to modify the /usr/local/share/pcbsd/xorg-gui/conf/xorg.conf.basic? If that gets nuked by system updates I'll use the /etc/X11 approach as I've already added some fonts to the file.</div>
<div class="gmail_extra"><br></div><div class="gmail_extra">Thanks for your help!</div></div>