<html><body><div style="color:#000; background-color:#fff; font-family:HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;font-size:10pt">Hi,<br><br>I'm running a jail in 9.2 and installed PHP53 (my app requires that version) along with PHP53-extensions.<br><br>I wanted to additionally install pecl-APC but if I try to install by ports or the pkgng package manager it wants to install PHP54 as a dependency which I don't want.<br><br>Before pkgng I could just use pkg_add thusly: # pkg_add pecl-APC-3.1.13.tbz from a file I saved in that directory.<br><br>Now if I try that it bombs because it can't find required packages like PHP 5.3.27 even though it's installed, presumably because pkgng uses a different database that pkg_add can't use.<br><br>There doesn't seem to be a way to use pkgng to install a package from a local file, only a repository.<br><br>So I tried to install PEAR which for some reason isn't bundled with FreeBSD PHP
 port/package.  It should.<br><br>Pear also would not install because pgkng wanted to install PHP54, etc.  So I got PEAR from the PEAR website and installed it directly.<br><br>Then I went to install APC with: # pecl install apc<br><br>That caused a slew of PHP errors and finally bombed saying it couldn't find the XML extension even though it's installed.<br><br>Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/Command.php on line 259<br>XML Extension not found<br><br>So because of pkgng we can't use PEAR to install anything anymore?<br><br>I almost like the Wardens package manager but it can be quite tedious to find things and so I often just resort to: # pkg info to see what's installed.<br><br>Seems the package manager could be improved by allowing installation from a local file and giving the option of ignoring dependencies.  In the case of APC I don't think there are any specific required versions of PHP,
 etc., so I don't know where the package manager got them from but here's what happened when I used pkg_add:<br><br># pkg_add pecl-APC-3.1.14_1.tbz<br>pkg_add: could not find package expat-2.1.0 !<br>pkg_add: could not find package openssl-1.0.1_8 !<br>pkg_add: could not find package cyrus-sasl-2.1.26_2 !<br>pkg_add: could not find package openldap-sasl-client-2.4.35 !<br>pkg_add: could not find package perl-5.14.4 !<br>pkg_add: could not find package pkgconf-0.9.2_1 !<br>pkg_add: could not find package pcre-8.33 !<br>pkg_add: could not find package gdbm-1.10 !<br>pkg_add: could not find package db46-4.6.21.4 !<br>pkg_add: could not find package libiconv-1.14_1 !<br>pkg_add: could not find package libxml2-2.8.0_2 !<br>pkg_add: could not find package apr-1.4.8.1.5.2 !<br>pkg_add: could not find package apache22-2.2.25 !<br>pkg_add: could not find package php53-5.3.27 !<br><br>It couldn't find them because pkg_add can't use the pkgng DB, but why all the
 specific versions listed as prerequisites in the first place?<br><br>... Jeff<br><div><br></div></div></body></html>