<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On 31 July 2013 11:47, Mike Barnard <span dir="ltr"><<a href="mailto:mike.barnardq@gmail.com" target="_blank">mike.barnardq@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">hi,<br>
<br>
I updated my pcbsd this morning, GMT+3, and rebooted.<br>
<br>
I cannot seem to get past single user mode, it ends up complaining<br>
about not being able to find /bin/sh.</blockquote><div><br><br></div><div>It turns out that more than just sh is missing. A quick check shows that these files are missing from the /bin directory<br><br>chio<br>cmp<br>cp<br>
csh<br>cut<br>df<br>du<br>ed<br>ls<br>pax<br>ps<br>rcp<br>red<br>rmail<br>sh<br>sleep<br>tcsh<br><br></div><div>I restored these by booting from the installation media, Choose option 5 to boot into Emergency Console. After it brings the PCBSD Utility screen -> Utilities -> Shell<br>
<br></div><div>I plugged in my portable disk and mounted it on /mnt and copied the files in /bin over to my portable disk. I rebooted my PCBSD installation, chose single usermode, entered /usr/local/bin/bash for my shell (since sh was not possible)<br>
<br></div><div>I remounted / as read write (mount -o rw tank0/ROOT/default /) and first moved cp over to /bin, then used cp -i to not overwrite existing files.<br><br></div><div>At least I can now log into my PC. Will attempt this update again and post if anything goes wrong.<br>
<br></div><div>PS: While booting, I get a screen that shows me<br><br></div><div>geom_journal.ko missing<br></div><div>geom_mirror.ko missing<br></div><div>geom_eli.ko missing<br></div></div></div></div>