<div dir="ltr"><div><div>Hi Mike,<br><br></div>I got the same after the safety updates on the new 9.2 stable, but it seems that you found out more :-) It is a bit of a pity that it happened but I hope that Kris can fix that.<br>
<br></div>Best regards,<br>Hans<br></div><div class="gmail_extra"><br><br><div class="gmail_quote">2013/7/31 Mike Barnard <span dir="ltr"><<a href="mailto:mike.barnardq@gmail.com" target="_blank">mike.barnardq@gmail.com</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">hi,<br>
<br>
I updated my pcbsd this morning, GMT+3, and rebooted.<br>
<br>
I cannot seem to get past single user mode, it ends up complaining<br>
about not being able to find /bin/sh.<br>
<br>
all boot attempts die with<br>
<br>
init: can't exec /bin/sh for /etc/rc: no such file or directory.<br>
enter full pathname of shell or return for /bin/sh:<br>
<br>
when I press enter I get<br>
<br>
init: can't exec /bin/sh for single user: no such file or directory<br>
(repeated twice)<br>
<br>
and takes me back to enter full pathname.....<br>
<br>
when I enter the path for bash, I get in. I checked for sh and indeed,<br>
its not there. I cannot even mount a disk from which I can copy over<br>
the sh file.<br>
<br>
any ideas on how to progress forward on this.<br>
<br>
ps: it dumps an error about geom and zfs while it boots up, I'll need<br>
to get a hot of that too and send it through.<br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Mike<br>
<br>
Of course, you might discount this possibility, but remember that one in a<br>
million chances happen 99% of the time.<br>
------------------------------------------------------------<br>
_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
</font></span></blockquote></div><br></div>