<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 06/11/2013 10:16, Jeff wrote:<br>
    </div>
    <blockquote
      cite="mid:1370960193.34473.YahooMailNeo@web142303.mail.bf1.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff; font-family:arial,
        helvetica, sans-serif;font-size:10pt">
        <div>I run PCBSD 9.1 and have a Warden jail setup.<br>
          <br>
          In that jail which has it's own local IP, 192.168.1.12, I have
          an Apache server.<br>
          <br>
          Normally when I connect the computer to a single router that
          is connected to a modem, I set "nameserver 192.168.1.1", i.e.
          the router LAN IP / gateway, in etc/resolv.conf on the jail
          and have no problems.<br>
          <br>
          Now I have added a 2nd router daisy chained from the primary
          router, running a subnet (primary router has IP: 192.168.1.1
          and secondary router: 192.168.2.1).<br>
          <br>
          The computer running the jail is plugged into the secondary
          router.<br>
          <br>
          The problem is, the jail can't contact the internet. I can SSH
          into the jail from the host but it takes a very long time to
          connect, like 15 seconds or so.<br>
          <br>
          I can't ping out of the jail either, even as root I get: ping:
          socket: Operation not permitted.<br>
          <br>
          Disabling the firewall has no effect.<br>
          <br>
          The server responds to any connection from any computer
          connected to the 2nd router but it's slow.<br>
          <br>
          I've tried different IP addresses for "nameserver" but nothing
          works. The resolv.conf file on the PCBSD host just lists the
          ISPs DNS servers. Even changing the 2nd router's IP to
          192.168.1.1 and the primary router to 192.168.2.1 has no
          effect. I thought maybe the jails needed to be on the same
          subnet.<br>
          <br>
          I have no problems using the internet from the host, just the
          jails.<br>
          <br>
          Any ideas why this happens and how to get around it? I've had
          this problem for years with different versions of FreeBSD.<br>
          <br>
          I thought that jails just used the host's internet setup.</div>
        <div style="color: rgb(0, 0, 0); font-size: 13.3333px;
          font-family: arial,helvetica,sans-serif; background-color:
          transparent; font-style: normal;"><br>
        </div>
        <div style="color: rgb(0, 0, 0); font-size: 13.3333px;
          font-family: arial,helvetica,sans-serif; background-color:
          transparent; font-style: normal;">I posted this first on the
          PCBSD forum but got no response.  I also posted on the FreeBSD
          networking forum and got this, which is a bit over my head:</div>
        <br>
      </div>
    </blockquote>
    <br>
    That is a bit more complex. Pinging is off in a jails by default,
    but you can enable them with this:<br>
    <br>
    #  warden set flags <myjailip> allow.raw_sockets=true<br>
    <br>
    Then restart the jail.<br>
    <br>
    Next, I'm guessing the delay in the jail responding to queries is
    because of some failing reverse DNS lookups. You can try to fix this
    by enabling BIND on the system / jail by setting:<br>
    <br>
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-1">
    named_enable="YES" in /etc/rc.conf of the jail or host, then use the
    local IP as DNS server. <br>
    <br>
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-1">
    <a
      href="http://www.freebsd.org/doc/en/books/handbook/network-dns.html">http://www.freebsd.org/doc/en/books/handbook/network-dns.html</a><br>
    <pre class="moz-signature" cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
  </body>
</html>