<div dir="ltr">Hi all, <div><br></div><div style>I wanted to report a couple of oddities, post `pkg upgrade -fy`. I ran pkg upgrade in an attempt to fix the Control Panel > Printing dialog errors I've been getting [1].</div>
<div style><br></div><div style>pkg upgrade ran without a hitch, but...</div><div style>1) After rebooting, I noticed that a) GNOME was the default DE (I'm only using LXDE), and b) all of the DE entries in the list box were doubled. Both of these were *not* persistent as they went away after logging out & back in. I didn't think to grab a screen shot.</div>
<div style>2) I'm getting the same errors, post-pkg upgrade, with the Printer dialog.</div><div style>3) I tried to install a pkg (mtpfs) for some testing and got the following error when pkg attempts to upgrade itself [2].</div>
<div style><br></div><div style>Overall, RR is pretty solid and having the pkgNG infrastructure is nothing short of super awesome. Thanks a bunch for all the time & hard work you all are putting into it.</div><div style>
<br></div><div style>Bridger<br></div><div style><br></div><div style>[1] Error from .xsession-errors:</div><div style><div>Qt conversation started.</div><div>Qt conversation finished.</div><div><br></div><div>** (process:81825): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'</div>
<div><br></div><div>** (process:81825): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'</div><div><br></div><div>** (process:81825): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'</div>
<div><br></div><div>(system-config-printer.py:81825): IBUS-WARNING **: The owner of /usr/home/bridger/.config/ibus/bus is not root!</div><div>GLib (gthread-posix.c): Unexpected error from C library during 'pthread_mutex_unlock': Operation not permitted.  Aborting.</div>
<div><br></div><div style>[2] Error from pkg install:</div><div style><div># pkg install mtpfs</div><div>Updating repository catalogue</div><div>Repository catalogue is up-to-date, no need to fetch fresh copy</div><div>New version of pkg detected; it needs to be installed first.</div>
<div>After this upgrade it is recommended that you do a full upgrade using: 'pkg upgrade'</div><div><br></div><div>The following packages will be installed:</div><div><br></div><div><span class="" style="white-space:pre">       </span>Upgrading pkg: 1.0.9_2 -> 1.0.11</div>
<div><br></div><div>The installation will require 7 kB more space</div><div><br></div><div>1 MB to be downloaded</div><div><br></div><div>Proceed with installing packages [y/N]: y</div><div>pkg: <a href="http://mirrors.nycbug.org/pub/PC-BSD/packages/9.1-RELEASE/amd64/All/pkg-1.0.11.txz">http://mirrors.nycbug.org/pub/PC-BSD/packages/9.1-RELEASE/amd64/All/pkg-1.0.11.txz</a>: Not Found</div>
<div><br></div></div><div style><br></div></div></div>