<div dir="ltr">All, <div>please excuse the noise from yesterday. I backed up ~ and started over with a clean slate. Things are progressing a little smoother this time. </div><div>Apologies, </div><div style>Bridger</div></div>
<div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Apr 10, 2013 at 11:27 AM, Bridger Dyson-Smith <span dir="ltr"><<a href="mailto:bdysonsmith@gmail.com" target="_blank">bdysonsmith@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">I tried to run the following in LXDE while lxpanel was having a fit:<div><br></div><div><div>> lxpanel --profile LXDE</div>
<div>GLib (gthread-posix.c): Unexpected error from C library during 'pthread_mutex_unlock': Operation not permitted.  Aborting.</div>
<div>zsh: abort      lxpanel --profile LXDE</div></div><div><br></div><div>As always, let me know if there's any additional information I can provide.</div><span class="HOEnZb"><font color="#888888"><div><br>Bridger </div>
</font></span></div><div class="HOEnZb"><div class="h5"><div class="gmail_extra">
<br><br><div class="gmail_quote">On Wed, Apr 10, 2013 at 9:51 AM, Bridger Dyson-Smith <span dir="ltr"><<a href="mailto:bdysonsmith@gmail.com" target="_blank">bdysonsmith@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div dir="ltr">The System Manager > /tmp/.pc-metapkgmanager.log error looked something like:<div>Pending Meta-Package changes: 1</div><div>ERROR: Failed downloading: /pub/PC-BSD/packages/9.1-RELEASE/amd64/All/pcbsd-meta-nvidia-21982.txz</div>


<div><br></div><div>Also, apologies if this should have gone to the Support list.</div><div>Thanks,<br>Bridger</div></div><div><div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Apr 10, 2013 at 9:29 AM, Bridger Dyson-Smith <span dir="ltr"><<a href="mailto:bdysonsmith@gmail.com" target="_blank">bdysonsmith@gmail.com</a>></span> wrote:<br>


<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Hi all, <div><br></div><div>Yesterday, I did the following trying to install the Nvidia metapackage:</div>


<div>1) Used the Control Panel > System Manager > System Packages but this update would fail (I've neglected to save the error message in /tmp/.pc-updatemanagerlog).</div>
<div><br></div><div>So instead I </div><div>2) Modified /usr/local/etc/pkg.conf</div><div>#packagesite: <a href="http://getmirror.pcbsd.org/packages/9.1-RELEASE/amd64" target="_blank">http://getmirror.pcbsd.org/packages/9.1-RELEASE/amd64</a></div>



<div>packagesite: <a href="http://mirrors.nycbug.org/pub/PC-BSD/packages/9.1-RELEASE/amd64" target="_blank">http://mirrors.nycbug.org/pub/PC-BSD/packages/9.1-RELEASE/amd64</a></div><div><br></div><div>3) ran # pkg install pcbsd-meta-nvidia-21982</div>



<div><br></div><div>4) pkgs seem to have installed fine, but...</div><div><br></div><div>After rebooting, selecting the Nvidia driver via the Display Wizard, lxpanel was very unhappy. After trying to switch back to the vesa driver, I'm experiencing the same lxpanel flickering. I've posted a short video to Youtube (<a href="http://youtu.be/FbypT6cv1vI" target="_blank">http://youtu.be/FbypT6cv1vI</a>). My dmesg looks something like: </div>



<div>...</div><div>...</div><div><div>pid 23415 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23419 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23423 (lxpanel), uid 1001: exited on signal 6</div>
<div>pid 23427 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23431 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23435 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23462 (lxpanel), uid 1001: exited on signal 6</div>



<div>pid 23466 (lxpanel), uid 1001: exited on signal 6</div><div>pid 23470 (lxpanel), uid 1001: exited on signal 6</div><div>WARNING pid 23888 (python2.7): ioctl sign-extension ioctl ffffffff80087467</div><div>WARNING pid 23903 (python2.7): ioctl sign-extension ioctl ffffffff80087467</div>



<div><br></div><div>I can get by with Openbox for now, but getting back to LXDE would be nice. :) I'm guessing this is probably a pkg conflict of some sort. Maybe? Let me know if there's any additional information I can provide & I'll send it along.</div>



<div><br></div><div>Thanks very much!</div><span><font color="#888888"><div>Bridger</div></font></span></div></div>
</blockquote></div><br></div>
</div></div></blockquote></div><br></div>
</div></div></blockquote></div><br></div>