<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <div class="moz-cite-prefix">On 09/04/2012 12:16, Dewey Hylton
      wrote:<br>
    </div>
    <blockquote
      cite="mid:1765504339.242516.1346775389433.JavaMail.root@mail"
      type="cite">
      <blockquote type="cite">
        <pre wrap="">From: "Kris Moore" <a class="moz-txt-link-rfc2396E" href="mailto:kris@pcbsd.org"><kris@pcbsd.org></a>
To: <a class="moz-txt-link-abbreviated" href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>
Sent: Tuesday, September 4, 2012 12:11:12 PM
Subject: Re: [PC-BSD Testing] apache22 missing prerequisite

On 09/04/2012 12:02, Dewey Hylton wrote:
</pre>
        <blockquote type="cite">
          <pre wrap="">

----- Original Message -----
</pre>
          <blockquote type="cite">
            <pre wrap="">From: "Kris Moore" <a class="moz-txt-link-rfc2396E" href="mailto:kris@pcbsd.org"><kris@pcbsd.org></a>
To: <a class="moz-txt-link-abbreviated" href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>
Sent: Tuesday, September 4, 2012 11:44:08 AM
Subject: Re: [PC-BSD Testing] apache22 missing prerequisite

On 09/02/2012 23:50, Dewey Hylton wrote:
</pre>
            <blockquote type="cite">
              <pre wrap="">9.1-RC1 amd64
running via warden traditional jail.
installed apache, mysql, and php via warden metapackages list.
enabling and starting apache via warden service manager produces
the following output:

Performing sanity check on apache22 configuration:
Shared object "libpcre.so.1" not found, required by "httpd"
Starting apache22.
Shared object "libpcre.so.1" not found, required by "httpd"
/usr/local/etc/rc.d/apache22: WARNING: failed to start apache22
_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
</pre>
            </blockquote>
            <pre wrap="">Can you post pkg_info from within jail? Looks like something
failed
to
fetch / install...

--
Kris Moore
PC-BSD Software
iXsystems

_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>

</pre>
          </blockquote>
          <pre wrap="">Started shell session on 127.0.0.2. Type exit when finished.
# pkg_info
apache-2.2.22_6     Version 2.2.x of Apache web server with prefork
MPM.
apr-ipv6-devrandom-gdbm-db42-1.4.5.1.3.12_1 Apache Portability
Library
db42-4.2.52_5       The Berkeley DB package, revision 4.2
#
_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
</pre>
        </blockquote>
        <pre wrap="">
Ok, you really are missing some things.

If you go back into the warden, and uncheck apache, hit apply, then
re-check it and apply again to install, does it fix the issue? If
not,
send me the file /tmp/.pc-metapkgmanager.log from the host system, so
I
can see what failed.

--
Kris Moore
PC-BSD Software
iXsystems

_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>

</pre>
      </blockquote>
      <pre wrap="">
same issue. the log file is attached (let me know if i need to just paste
it into a message, i'm not sure if this list allows attachments yet.

</pre>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
</pre>
    </blockquote>
    <br>
    Ok, I found and fixed the bug. Do this:<br>
    <br>
    % svn co svn://svn.pcbsd.org/pcbsd/current/src-sh/pc-metapkgmanager
    pc-metapkgmanager<br>
    % cd pc-metapkgmanager<br>
    % sudo make install<br>
    <br>
    Then do the removal / add of Apache again. Does it work now?<br>
    <br>
    <pre class="moz-signature" cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
  </body>
</html>