<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    On 03/02/2012 15:42, Ronald Georgia wrote:
    <blockquote
      cite="mid:1330720938.81416.YahooMailNeo@web161302.mail.bf1.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff; font-family:arial,
        helvetica, sans-serif;font-size:12pt">
        <div id="yiv1221402907">
          <div>
            <div style="background-color: rgb(255, 255, 255);
              font-family: arial, helvetica, sans-serif; ">
              <div id="yiv1221402907yui_3_2_0_18_133069538219148"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; "><span></span></div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; ">I am "running"
                PCBSD9.0 amd64 on an HP Compaq 7800p, 4Gig of RAM and a
                wicked big hard drive.</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; "><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; ">I attempted to
                install Eclipse-3.7.0_4 from AppCafe and got the error
                message "An error occurred installing Eclipse. You may
                need to update this PBI manually." (See attached
                file eclipse-appcafe-error.png). I checked the /usr/pbi
                directory and eclipse-amd64 was not created.</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; "><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; ">From the
                command-line I issue the following command:</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">[root@rong1611-s1]
                ~#  pbi_add --rArch amd64 --repo 001 -r -v Eclipse<br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">After
                the install process I got this message:</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">
                <div id="yiv1221402907yui_3_2_0_18_133069538219154">Extraction
                  Finished!</div>
                <div id="yiv1221402907yui_3_2_0_18_133069538219154">/tmp/.PBI.9164/.PBI-header.9164/post-install.sh:
                  cannot create
                  /usr/pbi/eclipse-amd64/eclipse/eclipse.ini: No such
                  file or directory</div>
                <div id="yiv1221402907yui_3_2_0_18_133069538219154">Installed:
                  Eclipse-3.7.0_4</div>
                <div id="yiv1221402907yui_3_2_0_18_133069538219154"><br>
                </div>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">Running
                Eclipse from the menu does not launch the application. I
                checked /usr/pbi/eclipse-amd64/.sbin and found that the
                eclipse script was missing; however the eclipse-devel
                file was there. </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">[root@rong1611-s1]
                /usr/pbi/eclipse-amd64/.sbin# cp eclipse-devel eclipse<br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">Eclipse
                works.</div>
              <div><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"><font
                  size="3">I add the icon to the desktop: </font></div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">[rgeorgia@rong1611-s1]
                ~> pbi_info | grep eclipse</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">eclipse-3.7.0_4-amd64</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">[rgeorgia@rong1611-s1]
                ~> pbi_icon add-desktop eclipse-3.7.0_4-amd64</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">Installed
                PyDev and a host of other plugins without incident. </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"><br>
              </div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154">Warning:
                Using Help -> Check for Updates and selecting the
                available updates and installing them will cause Eclipse
                to not launch. Still working on why that is happening.</div>
              <div id="yiv1221402907yui_3_2_0_18_133069538219154"
                style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; "><br>
              </div>
              <div style="color: rgb(0, 0, 0); font-family: arial,
                helvetica, sans-serif; font-size: 12pt; "><font
                  id="yiv1221402907yui_3_2_0_18_133069538219157"
                  size="3"><span style="font-family: courier, monaco,
                    monospace, sans-serif; "
                    class="yiv1221402907yui_3_2_0_18_133069538219160">r0n
                    ge0rgia</span><br>
                  John 13:23</font></div>
            </div>
          </div>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
</pre>
    </blockquote>
    <br>
    Thanks for the report!<br>
    <br>
    I just fixed the AppCafe issue, it should allow Eclipse to be
    installed now (needed root permissions, but flag was not set). You
    might want to give it 24 hours for the changes to get pushed to the
    mirrors before trying it out.<br>
    <br>
    I also just fixed the desktop/menu entries to point to
    "eclipse-devel" rather than "eclipse". Once the PBI rebuilds, they
    should work fine.<br>
    <br>
    If you come across anything else that needs to be fixed with it, let
    us know!<br>
    <br>
    <pre class="moz-signature" cols="72">-- 
~~ Ken Moore ~~
PC-BSD/iXsystems</pre>
  </body>
</html>