Hello..<br><br>In my attempts to configure a local PBI repository, I have discovered a rather unfriendly bug. I stumbled through the repo creation process, then decided to remove *my* repo, intending to do no other damage.<br>
<ul><li>Upon removing id 002 (my repo) with pbi_deleterepo, AppCafe would no longer start from the system tray.</li><li>Re-adding my repo with pbi_addrepo, allowed AppCafe to start once more, but the default PC-BSD repo remained inaccessible.</li>
<li>Lacking a properly defined repository prevents installed PBI files from being displayed in AppCafe, but pbi_info does list them.</li></ul><br>It may not have been the most brilliant idea to remove all repos but since it seemed that I had no access anyway, I didn't feel that I lost anything more.<br>
<br>Without a repo defined, AppCafe will not load from the system tray, and attempts from commandline result in the following:<br><br><div style="margin-left:40px">[tigersharke@Mutant] > appcafe<br>Locale: "en" <br>
Application starting...<br>Populating list...<br>Reading PBI List<br>RealUser: "tigersharke" <br>Adding Repos... <br>Segmentation fault<br></div><br>Perhaps it would be wise, in such a situation, for there to be an option to obtain the pbi repo information/file for the default repository, or automatically, or maybe even as a function of the update manager should the default repo data become lost.  Even without those possible mechanisms added, the default appcafe repo file ought to exist somewhere on the system as a precaution.<br>
<br>Thanks for your efforts!<br><br><br>PS. How can I recover AppCafe functionality?  How can I define the Official PBI Repository?<br>