<br><br><div class="gmail_quote">2011/11/2 Silvio - Banzai ° <span dir="ltr"><<a href="mailto:silvio.taverna@banzai.it">silvio.taverna@banzai.it</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
On Wed, 02 Nov 2011 16:00:52 +0100, Kris Moore <<a href="mailto:kris@pcbsd.org" target="_blank">kris@pcbsd.org</a>> wrote:<br>
<br>
hi kris, thanx for the response ...<div class="im"><br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
On 11/02/2011 04:48, Silvio - Banzai ° wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
</blockquote></blockquote></div><div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
moreover, on those same systems, even though the suspend action is not<br>
enabled in any of the power profiles, and the selected action for lid<br>
closed is to turn the screen off, upon opening of the lid a system<br>
suspend is triggered none the less, freezing the machine.<br>
</blockquote>
This is in KDE correct? my other systems here don't try to suspend when<br>
I close the screen...<br>
</blockquote>
<br></div>
neither do mine ... the go on suspend upon *reopening* the lid, that's the strangest part of it ...<br></blockquote></div><br>Hi..<br><br>This is just a thought.. Two things:<br><br><ol><li>Any chance that somehow the sensor for open/close is somehow physically "twisted" (not likely)</li>
<li>With the lid open and system running 'normal' can you tell it to suspend? After this, does closing and reopening the lid still do the same backward effect?</li></ol>My thought, as someone unaware of the actual code involved, is that somehow the status got flipped, and it either is not resetting or for whatever reason is now stuck in this inaccurate situation. Ie, suppose a boolean set due to action of the lid is supposed to be true when closed and false when open but by some odd mistake, it is either treated backward after the initial iteration or gets initialized/reset wrong somehow.  And the physical action of the lid only causes the state to flip, as if each action is +1 and the state is understood as even or odd. The software is out of touch with the reality of the hardware.<br>
<br><div style="margin-left: 40px;">Oh is there anything in the BIOS  relating to 'suspend action'?<br><br>Does disabling DPMS or ACPI make a difference?<br><br>And i now realize I have latched onto the backwardness more than the fact of an unwanted "feature".<br>
</div><br>Perhaps my comments may help others figure this out.<br>