<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    On 08/22/2011 09:44, Tigersharke . wrote:
    <blockquote
cite="mid:CAHRv5yhW-OY_xx9Mmu+Vg7bX+faHJYjp8o7Ekmvbv0qRbmwaiQ@mail.gmail.com"
      type="cite"><br>
      <br>
      <div class="gmail_quote">On Sun, Aug 21, 2011 at 5:45 AM,
        Tigersharke . <span dir="ltr"><<a moz-do-not-send="true"
            href="mailto:tigersharke@gmail.com">tigersharke@gmail.com</a>></span>
        wrote:<br>
        <div> </div>
        <blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt
          0.8ex; border-left: 1px solid rgb(204, 204, 204);
          padding-left: 1ex;">
          My system is AMD 64bit, ATI 3100 graphics on the motherboard. 
          PC-BSD v9.0beta1 was installed and then updated to beta1.5
          after reboot (an interesting new experience for me).<br>
          <br>
          <b>This</b> is what is strange:<br>
          <br>
          I added Firefox as a PBI, then discovered it is version 4.0.1,
          so I removed the PBI to build/install the most current version
          by port/pkg.  Whether I put Firefox 6.x onto my system as a
          manually built port (pretty sure thats how I did it) or as a
          FreeBSD package, it should still be on my system somewhere.  <br>
          <br>
        </blockquote>
      </div>
    </blockquote>
    <br>
    When you do an update, programs installed via ports / packages will
    be removed. If you want to preserve them across major system updates
    you should install into the ports jail. <br>
    <br>
    <br>
    <blockquote
cite="mid:CAHRv5yhW-OY_xx9Mmu+Vg7bX+faHJYjp8o7Ekmvbv0qRbmwaiQ@mail.gmail.com"
      type="cite">
      <div class="gmail_quote">
        <blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt
          0.8ex; border-left: 1px solid rgb(204, 204, 204);
          padding-left: 1ex;">Within KDE, I had Firefox running, Quassel
          added via pkg, and wine added via PBI.<br>
          <br>
          In a terminal, I initiated an install of Bioshock with wine
          /media/cd0/setup.exe  which was working fine until the last
          seconds of the install.  I believe it did/tried something
          related to graphics, then what happened was a partial restart
          or something. The screen blanked and I think the KDE session
          was ended. When I got back to the desktop in KDE, the firefox
          icon in the kickstart/kicker/kickoff was gone but the text was
          present. However, <u>Firefox was no longer on my system</u>?
          I did look in /usr/local/bin, but no firefox. This is
          definitely something I need to pay better attention to- of
          course "fun" things like these are a surprise. If I can repeat
          it, I will give more information next time (assuming there is
          any to give).<br>
        </blockquote>
      </div>
      <br>
      I am still unsure exactly how the above result was reached
      (vanishing Firefox).. but have done some additional testing:<br>
      <br>
      With Firefox v6.x installed via ports, a konsole, quassel and
      firefox running, I tried installing Bioshock as before (though I
      typoed the previous email- the correct command is wine start /unix
      /media/cd0/setup.exe) after changing the setting in the gui wine
      configurator to default vista instead of windows 2000. It
      installed very quickly, since it only seemed to verify each file
      that I had not removed (of Bioshock), but then it got to the point
      of downloading the current patches. This seems to be what
      triggered an end of the KDE session that briefly brought me to the
      console and then back to the user login screen. Upon returning to
      the KDE desktop, the only thing to repopulate was a konsole
      session, but both Firefox and Quassel were still present on my
      system, as were the PBIs clementine-player and wine.<br>
      <br>
      <b>Something</b> new I have discovered is that the PBI paths are
      not part of the standard search path. As root, I was eventually
      able to attempt to initiate wine but it resulted in a second a
      search path error as below: <br>
      <br>
      <div style="margin-left: 40px;">>su -m<br>
        Password:<br>
        # wine start /unix /media/cd0/setup.exe<br>
        wine: /home/tigersharke/.wine is not owned by you<br>
        [tigersharke@mutant] ~# exit<br>
        exit<br>
        [tigersharke@mutant] ~> su<br>
        Password:<br>
        # wine start /unix /media/cd0/setup.exe<br>
        wine: Command not found.<br>
        # /usr/pbi/wine-i386/bin/wine start /unix /media/cd0/setup.exe<br>
        /libexec/ld-elf.so.1: Shared object "libwine.so.1" not found,
        required by "wine"<br>
      </div>
      <br>
    </blockquote>
    <br>
    If you plan to run the app as root, take a look at the "pbi_icon"
    command, and as root run:<br>
    <br>
    # pbi_icon add-pathlnk wine-1.3.21-i386<br>
    <br>
    That should give you the "wine" command in your path as root<br>
    <br>
    Otherwise don't use the /usr/pbi/wine-i386/bin/wine command, instead
    use /usr/pbi/wine-i386/.sbin/wine<br>
    <br>
    <br>
    <blockquote
cite="mid:CAHRv5yhW-OY_xx9Mmu+Vg7bX+faHJYjp8o7Ekmvbv0qRbmwaiQ@mail.gmail.com"
      type="cite">Attempting as my ordinary user account does succeed,
      without needing the full path to wine, but imperfectly:<br>
      <br>
      <div style="margin-left: 40px;">>wine start /unix
        /media/cd0/setup.exe<br>
        /libexec/ld-elf.so.1: /usr/pbi/wine-i386/lib/libxml2.so.5:
        unsupported file layout<br>
        /libexec/ld-elf.so.1: /usr/pbi/wine-i386/lib/libglib-2.0.so.0:
        unsupported file layout<br>
        <br>
      </div>
    </blockquote>
    Looking into these here, they look cosmetic, since the app still
    runs though. <br>
    <br>
    <blockquote
cite="mid:CAHRv5yhW-OY_xx9Mmu+Vg7bX+faHJYjp8o7Ekmvbv0qRbmwaiQ@mail.gmail.com"
      type="cite">When I actually try to initiate Bioshock, I'll be back
      here if there are more issues..<br>
      <br>
      <br>
      Thanks!<br>
      <br>
    </blockquote>
    <br>
    <pre class="moz-signature" cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
  </body>
</html>