<br>Hi,<br><br>this is feedback on PCBSD 9.0 BETA1.<br>I have some remarks in small quantity. Many things are absent, but the ones I test were <br>working for the most part.<br>All wishes are writing  from the position of user who see PCBSD as an OS "for all comers".<br>
<br>Comp configuration: CPU P4 650 model; MB ASUS P5GD1Pro with on-board ICH6 sound;<br>NVIDIA 9400 GT; 4GB DDR-SDRAM; HD0 (WinXP/C, WinXP/D, Scientific Linux), HD1 (WinXP/E, PCBSD).<br><br>Installation: 64 bit, ZFS, KDE, NVIDIA, Base-Devil, Base-l118N.<br>
<br>No problems with installation.<br><br>1) First priority: the sound is present!  PCM#0-PCM#3 and default were in up state.<br>However the old message showed up: "The audio playback device HDA Realtek ALC880 PCM#0 <br>
Digita (pcm) does not work. Failed back to default." (All that at the welcome music.)<br><br>2) KDE-menu. The possibility to place link on desktop or taskbar is missing.<br><br>3) Root-terminal does not work: there are PW request and its saving.<br>
Next verbal instruction only is. The terminal itself is absent.<br>The point of this contrivance is obscure for me. How now: "if root PW is cached"?<br><br>Generally, if you'll install that unsafe thing, as a console with saved root access, <br>
then the physical presence check is required at least.<br>For example, " Press key "a" " with random key. Otherwise you'll run into remote access to<br>that console. And you would not think so that BSD is a well-protected OS a priori.<br>
Apple Mak OS thought so, but stopped it 3 years ago.<br><br>Dolphin with root access (without saving!) was a good thing.<br><br>4) After ADSL configuration (by GUI) my ADSL did not work.<br>The cause: it was saved default string "set device /dev/msk0" in ppp.conf.<br>
After its manual replacement by "set device PPPoE:msk0:ukrtelecom"<br>everything became OK.<br><br>5) PPPoE does not work after lagg enabled. This case is said in Handbook,<br>and there is guideline: "...uncheck this box and remove any references to 'lagg'<br>
in your /etc/rc.conf file." The 2nd part of guideline is unacceptable.<br>It is quite impossible: to edit config files manually. GUI only!<br><br>6) Some more about Internet. You have a box about comp visibility,<br>
which set ppp_nat. I'd suggest 3 foolproof options instead of this:<br> - single comp;<br> - ordinary comp in local net;<br> - router in local net.<br>Then it is necessary to perform appropriate configuration.<br>For example of single comp:<br>
ppp_nat="NO"<br>sshd_enable="NO" (and to close SSH port)<br>net.inet.tcp.blackhole=1<br>net.inet.udp.blackhole=1<br>net.inet.icmp.drop_redirect=1<br>net.inet.ip.redirect=0<br>net.inet.ip.forwarding=0<br>
<br>7) It seems you are exclusive company, who offer the screensaver 'blank screen'<br>with a possibility its color change. So, please, do the next step and <br>let user know that for TFT LCD bright white is a part load mode (not black!)<br>
Long-term its use is able to cure some damages of LCD-layer (diffuse spots, etc).<br><br>8) Apparently ntfs-3g is absent in BETA1. Nevertheless I write about bug in <br>8.2 version which are very unsafe if ZFS.<br><br>The situation: I mount one of Windows disks by Dolphin; move some files thereto;<br>
unmount this disk by Dolphin as well. After reboot and start Windows, these files<br>may be absent.<br><br>I think, the cause is that ZFS keep few little transactions in cache.<br>Dolphin contrives to unmount the disk in secret. After that ZFS cannot flush <br>
the cache: it has nowhere to put.<br>Forced cache flush before unmount by Dolphin may be a solution.<br><br><br>Best regards<br>Serghey<br><br>