<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html; charset=ISO-8859-1"
 http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Well, for any of you who've not played with the KPorts PBI yet, it's a
bit shaky and buggy. It also doesn't support anything past 7-CURRENT
out of the box but I managed to *coax* it to use 8.2-CURRENT by
manually changing stuff in the config under Settings > Configure
KPorts. I did encounter a major issue after setting things up though.
For me, after running "Update Vulnerability Db", it more or less
crashes either on startup or after trying to run Configure KPorts. It's
also not liking it when you run Update Port-Directory as it throw the
error: <b>Command 'cvsup -l -g -L 1/home/Art/kports/ports-supfile
&& echo kports_success' not found</b>. After that, you can view
the log detail and it states:  <b>kdesu: WARNING: Daemon not safe (not
sgid), not using it. cvsup: not found</b>.<br>
<br>
As I said, after running "Update Vulnerability Db, for me, it often
crashes either on startup or after running Configure KPorts, I am
seeing the following when it crashes:<br>
<br>
<b>Crash on startup</b>:<br>
<br>
[New Thread 309835c0 (LWP 100213)]<br>
[New Thread 29a01140 (LWP 100304)]<br>
[Switching to Thread 309835c0 (LWP 100213)]<br>
[KCrash handler]<br>
#6  0x2969366b in thr_kill () from /lib/libc.so.7<br>
#7  0x29642916 in pthread_kill () from /lib/libthr.so.3<br>
#8  0x29640393 in raise () from /lib/libthr.so.3<br>
#9  0x297366ca in abort () from /lib/libc.so.7<br>
#10 0x29586a10 in __gnu_cxx::__verbose_terminate_handler ()<br>
   from /usr/lib/libstdc++.so.6<br>
#11 0x2958b21a in std::set_unexpected () from /usr/lib/libstdc++.so.6<br>
#12 0x2958b262 in std::terminate () from /usr/lib/libstdc++.so.6<br>
#13 0x2958b15a in __cxa_throw () from /usr/lib/libstdc++.so.6<br>
#14 0x295dfcfe in operator new () from /usr/lib/libstdc++.so.6<br>
#15 0x29198001 in QString::QString () from
/Programs/kports/lib//libqt-mt.so.3<br>
#16 0x2919f166 in QString::mid () from
/Programs/kports/lib//libqt-mt.so.3<br>
#17 0x291ac71c in QStringList::split ()<br>
   from /Programs/kports/lib//libqt-mt.so.3<br>
#18 0x2919fd2b in QString::section () from
/Programs/kports/lib//libqt-mt.so.3<br>
#19 0x08085654 in QBsdPortGlobal::findAllAvailableBin ()<br>
#20 0x080784f8 in T_function::run ()<br>
#21 0x28e6bade in QThreadInstance::start ()<br>
   from /Programs/kports/lib//libqt-mt.so.3<br>
#22 0x2963c73f in pthread_getprio () from /lib/libthr.so.3<br>
#23 0x00000000 in ?? ()<br>
<br>
<br>
<b>Crash Details</b>:<br>
<br>
Output logged from stdout<br>
=========================<br>
<br>
<br>
<br>
Output logged from stderr<br>
=========================<br>
<br>
firstrun<br>
ASSERT: "i <= nodes" in /Programs/kports/include/qvaluelist.h (373)<br>
ASSERT: "i <= nodes" in /Programs/kports/include/qvaluelist.h (373)<br>
ASSERT: "i <= nodes" in /Programs/kports/include/qvaluelist.h (373)<br>
ASSERT: "i <= nodes" in /Programs/kports/include/qvaluelist.h (373)<br>
terminate called after throwing an instance of 'St9bad_alloc'<br>
  what():  std::bad_alloc<br>
KCrash: Application 'kports' crashing...<br>
Locale: "en" <br>
<br>
<br>
<br>
I'm guessing that because the PBI is based on version 0.6.1 and the
last version out there is 0.8.2, there's a lot of bugs and missing
support between the two version. Oh well, just my 2 cents.<br>
<br>
Arthur<br>
</body>
</html>