<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7651.59">
<TITLE>ZFS pools and the installer</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/plain format -->

<P><FONT SIZE=2>Hello, I'm new to PC BSD.&nbsp; have worked with OpenSolaris and FreeBSD.&nbsp; My problem:<BR>
<BR>
First off I'm using the PC BSD 8.1 installer.<BR>
<BR>
I've booted the PC with the dvd, zfs/osol kernel modules did load.&nbsp; There are 3 drives in this box.&nbsp; I've destroyed all the partitions on them, installed the GPT labels, and put in a freebsd-boot, freebsd-swap, and freebsd-zfs slice in each.&nbsp; Using the 3 freebsd-zfs slices, I've created a single raidz called &quot;rpool&quot;.<BR>
<BR>
Reboot the PC again.<BR>
<BR>
PC-BSD boots up, appears to recognize everything.&nbsp; In the X client, I can use an xterm and get information via zpool list and zfs list which make sense according to my setup.<BR>
<BR>
However, the Disk Setup portion of SysInstaller doesn't appear to see this rpool.&nbsp; What it sees are the three slices on each of the drives, and seemingly won't let me setup a zpool using existing partitions.&nbsp; now, i've tried to just use the gui for this, but it is not particularly helpful, and i cannot get it to let me make an rpool.<BR>
<BR>
So, now my question:<BR>
<BR>
is this being worked on in the Testing Version?&nbsp; Can I try it out?<BR>
<BR>
<BR>
thanks,<BR>
<BR>
Jack Downes<BR>
Health Information Technology, KRMC<BR>
<BR>
</FONT>
</P>

</BODY>
</HTML>