Hi Ian,<div><br></div><div>When manually mounting using the mount command, it seems both the device path and the mount path need to be free of spaces.</div><div><br></div><div>How do I change the mount parameters for HAL so that I can specify paths without spaces?</div>

<div><br></div><div>-Bill<br><br><div class="gmail_quote">On Fri, Aug 13, 2010 at 8:52 PM, Ian Robinson <span dir="ltr">&lt;<a href="mailto:fitchkendall@gmail.com">fitchkendall@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div class="gmail_quote">On Thu, Aug 12, 2010 at 3:00 PM, <span dir="ltr">Bill Sun wrote:</span><br><br>
I did some more digging around and found a file name &quot;.hal-mtab&quot; in /media.<br>
It looks like this file records the mount parameters used by HAL.<br>
<br>
Here&#39;s an entry of one of my mount attempts via Dolphin:<br>
<br>
# /dev/ntfs/FreeAgent Drive    1001    0    ntfs   nosuid,-u=1001,-C=UTF-8    /media/FreeAgent Drive-3<br>
<br>
Notice that there are spaces between the paths.  Could this be causing the<br>
mount issues?<br>
<br>
I tried using the paths above manually in a mount command:<br>
<br>
# mount -t ntfs /dev/ntfs/FreeAgent Drive /media/FreeAgent Drive-3<br>
<br>
But this gives me:<br>
<br>
ntfs-3g: You must specify exactly one device and exactly one mount point.<br>
<br>
I even tried using quotes around the paths and even &quot;\&quot; to escape the space,<br>
but I still get the same error.<br>
<br>
However, when I used paths with no spaces:<br>
<br>
mount -t ntfs /dev/da0s1 /media/FreeAgent<br>
<br>
This works.<br>
<br>
-Bill<br>======================================<br><br>Bill -- <br><br>You may have nailed the problem.  Perhaps you could rename the FreeAgent Drive-3 to a name with a single word to confirm.<br><br><br>Here are some other examples of mount parameters that are working on my systems:<br>


<br><br>(1) Contents of /media/.hal-mtab For an 8Gb USB Flash Drive (Fat32) named &quot;KINGSTON&quot;<br><br>/dev/msdosfs/KINGSTON    1001    0    msdosfs    nosuid,-u=1001,-L=en_US.UTF-8,large,-m=644,-M=755    /media/KINGSTON<br>


<br><br>(2) Contents of /media/.hal-mtab for a 73 Gb internal mounted SCSI (NTFS) named &quot;Windows&quot; (this is, by choice, not included in my fstab).<br><br>/dev/ntfs/Windows    1001    0    ntfs    nosuid,-u=1001,-C=UTF-8    /media/Windows<br>


<br><br><br><br><br>Long-time beta-testing contributor A. Yerenkow also discussed HAL and .hal-mtab issues relating to PCBSD 8.0 at<b> </b>this link:<b><br><br></b><a href="http://lists.pcbsd.org/pipermail/testing/2009-April/002190.html" target="_blank">http://lists.pcbsd.org/pipermail/testing/2009-April/002190.html</a><br>


<br><br>Ian Robinson<br>Salem, Ohio<br></div>
<br>_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></blockquote></div><br></div>