I did some more digging around and found a file name &quot;.hal-mtab&quot; in /media.  It looks like this file records the mount parameters used by HAL.<br><br>Here&#39;s an entry of one of my mount attempts via Dolphin:<br>

<br># /dev/ntfs/FreeAgent Drive    1001    0    ntfs    nosuid,-u=1001,-C=UTF-8    /media/FreeAgent Drive-3<br><br>Notice that there are spaces between the paths.  Could this be causing the mount issues?<br><br>I tried using the paths above manually in a mount command:<br>

<br># mount -t ntfs /dev/ntfs/FreeAgent Drive /media/FreeAgent Drive-3<br><br>But this gives me:<br><br>ntfs-3g: You must specify exactly one device and exactly one mount point.<br><br>I even tried using quotes around the paths and even &quot;\&quot; to escape the space, but I still get the same error.<br>

<br>However, when I used paths with no spaces:<br><br>mount -t ntfs /dev/da0s1 /media/FreeAgent<br><br>This works.<br><br>-Bill<br><br><div class="gmail_quote">On Tue, Jul 27, 2010 at 11:01 AM, Arthur Koziol <span dir="ltr">&lt;<a href="mailto:A-Koziol@neiu.edu">A-Koziol@neiu.edu</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">


  

<div bgcolor="#ffffff" text="#000000">
Bill,<br>
<br>
I&#39;d remembered seeing the option to auto mount removable media when
attached in System Settings &gt; Advanced tab &gt; Removable Devices
but I just tried it on a removable NTFS formatted USB HD I had and it
didn&#39;t work. I even tried the check boxes for &quot;Mount on Attach&quot; but it
was a no go. I can here the drive get accessed when I hit it with
Dolphin but it ultimately doesn&#39;t mount. I&#39;m sure if it was FAT32 it
would have worked fine. Kris, can that auto-mount feature be leveraged
by NTFS-3G somehow? <br>
<br>
Arthur<div><div></div><div class="h5"><br>
<br>
<blockquote type="cite">Thanks for replying, Ian.<br>
  <br>
I have a USB thumb drive that is formatted in FAT32, and that worked
without any problems in Dolphin.  I can see the contents without using
sudolphin or the terminal.<br>
  <br>
My USB NTFS drive, however, while it has directories created in /media
for each mount attempt, is marked unmounted in Dolphin, and listing the
mount points in the terminal shows that they are empty.  Konqueror also
shows the directories as empty.<br>
  <br>
My internal SATA NTFS drive shows the same behavior as the USB NTFS
drive.<br>
  <br>
So this looks like Dolphin is having problems mounting the NTFS drive
in the first place.  Manually mounting the NTFS drives using ntfs-3g
from the terminal works, and the drives become accessible from Dolphin.<br>
  <br>
Does anyone know where to configure Dolphin&#39;s mounting options?<br>
  <br>
-Bill<br>
  <br>
  <div class="gmail_quote">On Mon, Jul 26, 2010 at 10:44 AM, Ian
Robinson <span dir="ltr">&lt;<a href="mailto:fitchkendall@gmail.com" target="_blank">fitchkendall@gmail.com</a>&gt;</span>
wrote:<br>
  <blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Bill
Sun wrote:<br>
    <br>
I&#39;m still not able to mount ntfs drives in dolphin in 8.1 Release.  I
didn&#39;t<br>
get any error messages as well.<br>
    <br>
The only other thing that I noticed is that it will create directories
in<br>
/media, one for each mount attempt.  So, for example, I&#39;m trying to
mount my<br>
FreeAgent drive, I&#39;ll get &quot;FreeAgent Drive&quot;, &quot;FreeAgent Drive-1&quot;,
&quot;FreeAgent<br>
Drive-2&quot;, and so on.<br>
    <br>
Is there anyone else trying to mount ntfs drives in dolphin?  Are you<br>
successful?  If so, did you have to do some special configuration?<br>
    <br>
========================================================<br>
    <br>
Bill --<br>
    <br>
I&#39;m running PCBSD 8.1-RELEASE.<br>
    <br>
I plugged in my FreeAgent 500 USB drive (which I had previously
converted to FAT32 &amp; named the volume as &quot;AGENT500&quot;)<br>
    <br>
Here is what I find:<br>
    <br>
1.  Dolphin recognized the drive and mounted it at /media/AGENT500<br>
    <br>
2.  Dolphin did NOT show the contents.<br>
    <br>
3.  KDiskFree (Start &gt; Applications &gt; System &gt; View Disk
Usage) correctly shows the mountpoint and drive statistics<br>
    <br>
4.  Although Dolphin won&#39;t show any files, Terminal lets you cd over to
the mount point and list the files.<br>
    <br>
5.  Dolphin lets me un-mount the disk via a right-click on the name of
the USB drive in &quot;Places&quot; <br>
    <br>
6.  If I create a mount point (/mnt/whatever), then I can successfully
mount the drive in terminal with <br>
    <br>
#  mount -t msdosfs -o large /dev/da2s1 /mnt/whatever<br>
or with<br>
# mount_msdosfs -o large /dev/da2s1 /mnt/whatever<br>
    <br>
7.  Dolphin will show the mountpoint but will not see or list the files<br>
    <br>
8.  Terminal lets you cd over to the mountpoint and list the files.<br>
    <br>
Two more very important points:<br>
    <br>
9.  Konqueror lets you see all the files.<br>
    <br>
10. Dolphin Admin (sudolphin) lets you see all the files.<br>
    <br>
Try Konqueror and Dolphin Admin to see if you get the same behavior and
reach the conclusion like I do that &quot;regular&quot; Dolphin has a bug.<br>
    <font color="#888888"><br>
Ian Robinson<br>
Salem, Ohio<br>
    </font><br>
_______________________________________________<br>
Testing mailing list<br>
    <a href="mailto:Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a><br>
    <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
    <br>
  </blockquote>
  </div>
  <br>
  <pre><fieldset></fieldset>
_______________________________________________
Testing mailing list
<a href="mailto:Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a>
  </pre>
</blockquote>
<br>
<br>
</div></div><font color="#888888"><pre cols="72">-- 
[ NEIU - Student Computing Services Specialist ]
[ 5500 N. St. Louis Ave., Room B107 ]
[ Chicago, IL 60625 ]
[ Ph: 773-442-4356 ]
[ <a href="http://www.neiu.edu/%7Escs" target="_blank">http://www.neiu.edu/~scs</a> ]

[/]This message (including any attachments) contains confidential information intended for a specific individual and purpose, and is protected by law. If you are not the intended recipient, you must delete this message. Any disclosure, copying, harvesting, dissemination, opting-in or the taking of any action based on it, is strictly prohibited by law.[/]</pre>


</font></div>

<br>_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></blockquote></div><br>