<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;"><br>Ok, so the NTFS drive is fixed now but the 1TB drive still is reporting the wrong size.<br>How to fix this?<br><br><br>--- On <b>Sat, 5/8/10, Jeff <i><dejamuse@yahoo.com></i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Jeff <dejamuse@yahoo.com><br>Subject: Re: [PC-BSD Testing] 1TB external usb drive shows smaller size in Dolphin<br>To: "PC-BSD Testing list" <testing@lists.pcbsd.org><br>Date: Saturday, May 8, 2010, 1:35 PM<br><br><div id="yiv1988005623"><table border="0" cellpadding="0" cellspacing="0"><tbody><tr><td style="font: inherit;" valign="top">Hmm, that file dump shows both drives and it appears the correct size data for the 1TB drive (volume.size = 1000,202,241,024)<br><br>and lists the file system type as NTFS for the 320GB drive (volume.size =
 320,062,063,104) (volume.fstype = 'ntfs').<br><br>See attached condensed file dump.<br><br>Could the system crash have corrupted the NTFS drive? It still works OK on Windoze.<br><br>--- On <b>Sat, 5/8/10, Kris Moore <i><kris@pcbsd.org></i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Kris Moore <kris@pcbsd.org><br>Subject: Re: [PC-BSD Testing] 1TB external usb drive shows smaller size in Dolphin<br>To: "PC-BSD Testing list" <testing@lists.pcbsd.org><br>Date: Saturday, May 8, 2010, 8:50 AM<br><br><div class="plainMail"><br><br>"Jeff" <<a rel="nofollow">dejamuse@yahoo.com</a>> wrote:<br><br>>dmesg reports da0 as:<br>><br>>da0: <WD My Book 1028> Fixed Direct Access SCSI-4 device    <br>>da0: 40.000MB/s
 transfers                                                                               <br>>da0: 953869MB (1953525168 512 byte sectors: 255H 63S/T 121601C) <br>><br>>Dolphin doesn't interpret that data correctly.<br>><br>>--- On Fri, 5/7/10, Jeff <<a rel="nofollow">dejamuse@yahoo.com</a>> wrote:<br>><br>>From: Jeff <<a rel="nofollow">dejamuse@yahoo.com</a>><br>>Subject: Re: [PC-BSD Testing] 1TB external usb drive shows smaller size in Dolphin<br>>To: "PC-BSD Testing list" <<a
 rel="nofollow">testing@lists.pcbsd.org</a>><br>>Date: Friday, May 7, 2010, 8:56 PM<br>><br>>DiskFree gets it partly right - see attached image.<br>><br>>/dev/ad70s1a is a spare internal drive (500MB) - correct data.<br>>/dev/da0s1 is a Western Digital external USB 1TB drive - wrong data.<br>>/dev/fuse0 is a Western Digital external USB 300MB drive - correct data.<br>>/dev/label/rootfs0 looks like the main drive root partition (500 MB drive).<br>>Nothing for /dev/ad6s1a which is the main drive - only its
 partitions.<br>><br>>But the real problem is da0s1 because I can't put any more than about 2GB on the drive because it reports that it's full.  <br>><br>>Anyway around this?  I'll ask over at FBSD too.<br>><br>><br>><br>>--- On Fri, 5/7/10, Brodey Dover <<a rel="nofollow">doverosx@gmail.com</a>> wrote:<br>><br>>From: Brodey Dover<br>> <<a rel="nofollow">doverosx@gmail.com</a>><br>>Subject: Re: [PC-BSD Testing] 1TB external usb drive shows smaller size in Dolphin<br>>To: "PC-BSD Testing list" <<a rel="nofollow">testing@lists.pcbsd.org</a>><br>>Date: Friday, May 7, 2010, 6:03 PM<br>><br>>Yep, I uncovered that tidbit in the other thread... I think Kris is onto something when specifying the
 right FS.<br>><br>>On Fri, May 7, 2010 at 11:17 AM, Kris Moore <<a rel="nofollow">kris@pcbsd.org</a>> wrote:<br>><br>><br>><br>><br>>  <br>><br>><br>>On 05/07/2010 19:08, Jeff wrote:<br>><br>>  <br>>    <br>>      <br>>        Maybe dmesg gives a clue.  Windoze reported this as an<br>>NTFS drive:<br>><br>>        <br>><br>>uhub8: <vendor 0x1058 product 0x0500, class 9/0, rev 2.00/0.07, addr<br>>2> on usbus3<br>><br>>uhub8: 4 ports with 2 removable, self powered<br>><br>>ugen3.3: <Western Digital> at usbus3<br>><br>>umass1: <Western Digital External HDD, class 0/0, rev 2.00/1.12,<br>>addr 3> on usbus3<br>><br>>umass1:  SCSI over Bulk-Only; quirks = 0x008c<br>><br>>umass1:3:1:-1: Attached to
 scbus3<br>><br>>umass2: <Western Digital External HDD, class 0/0, rev 2.00/1.12,<br>>addr 3> on usbus3<br>><br>>umass2:  SCSI over Bulk-Only; quirks = 0x008c<br>><br>>umass2: could not setup required transfers, USB_ERR_NO_PIPE<br>><br>>device_attach: umass2 attach returned 6<br>><br>>da1 at umass-sim1 bus 1 target 0 lun 0<br>><br>>da1: <WD 3200JB External 0112> Fixed Direct Access SCSI-0 device<br>><br>>da1: 40.000MB/s transfers<br>><br>>da1: 305245MB (625142448 512 byte sectors: 255H 63S/T 38913C)<br>><br>>fuse4bsd: version 0.3.9-pre1, FUSE ABI 7.8<br>><br>>mountmsdosfs(): bad FAT32 filesystem<br>><br>>mountmsdosfs(): bad FAT32 filesystem<br>><br>>WARNING: /media/disk was not properly dismounted<br>><br>>mountmsdosfs(): bad FAT32 filesystem<br>><br>>mountmsdosfs(): bad FAT32 filesystem<br>><br>>mountmsdosfs(): bad FAT32
 filesystem<br>><br>>        <br>><br>>        <br>><br>>        <br>>      <br>>    <br>>  <br>><br>>Well, that makes sense why mount_msdosfs wouldn't work :P<br>><br>><br>><br>>What about mount_ntfs <device> /mnt?<br>><br>><br>><br>><br>><br>><br>><br>>-- <br>>Kris Moore<br>>PC-BSD Software<br>>iXsystems<br>><br>><br>><br>>_______________________________________________<br>><br>>Testing mailing list<br>><br>><a rel="nofollow">Testing@lists.pcbsd.org</a><br>><br>><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>><br>><br>><br>><br>><br>>-----Inline Attachment
 Follows-----<br>><br>>_______________________________________________<br>>Testing mailing list<br>><a rel="nofollow">Testing@lists.pcbsd.org</a><br>><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>><br>><br>><br>><br>><br>><br>><br>><br>><br>>      <br>>-----Inline Attachment Follows-----<br>><br>>_______________________________________________<br>>Testing mailing list<br>><a rel="nofollow">Testing@lists.pcbsd.org</a><br>><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>><br>><br>><br>>_______________________________________________<br>>Testing mailing
 list<br>><a rel="nofollow">Testing@lists.pcbsd.org</a><br>><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br><br><br>Can you locate the device in the output of "lshal"? What size does it indicate there?  I'm guessing that's where the error is occurring.  <br><br><br><br>-- <br>Kris Moore <br>PC-BSD / iXsystems </div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a rel="nofollow">Testing@lists.pcbsd.org</a><br><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></div></blockquote></td></tr></tbody></table><br>

      </div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a ymailto="mailto:Testing@lists.pcbsd.org" href="/mc/compose?to=Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br><a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></div></blockquote></td></tr></table><br>