<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;">Ugh. Whilst hovering the mouse over some .jpg files on this drive in Dolphin and looking at the preview images, the mouse froze and keyboard lights went out.&nbsp; The system was hung and eventually I had to recycle the power.<br><br>After reboot, trying again to mount:<br><br># mount -o large -t ntfs /dev/da1s1 /media/Backup<br>NTFS signature is missing.<br>Failed to mount '/dev/da1s1': Invalid argument<br>The device '/dev/da1s1' doesn't seem to have a valid NTFS.<br>Maybe the wrong device is used? Or the whole disk instead of a<br>partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?<br>#<br><br>Drive still works fine in Windoze.<br><br>Cripes, now what?<br><br>...Jeff<br><br>--- On <b>Fri, 5/7/10, Jeff <i>&lt;dejamuse@yahoo.com&gt;</i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left:
 5px;"><br>From: Jeff &lt;dejamuse@yahoo.com&gt;<br>Subject: Re: [PC-BSD Testing] Mounting USB Hard Drives<br>To: "PC-BSD Testing list" &lt;testing@lists.pcbsd.org&gt;<br>Date: Friday, May 7, 2010, 8:25 PM<br><br><div id="yiv955357322"><table border="0" cellpadding="0" cellspacing="0"><tbody><tr><td style="font: inherit;" valign="top">That didn't work but this did:<br><br># mount -o large -t ntfs /dev/da1s1 /media/Backup<br>The disk contains an unclean file system (0, 0).<br>The file system wasn't safely closed on Windows. Fixing.<br>#<br><br>Dolphin couldn't handle this on its own, why?<br><br>Dolphin reports this 300GB (100GB of data) drive as 1/3 full but 3.1 TiB out of 4.7 TiB - complete gibberish.&nbsp; I have yet to see Dolphin or any file manager I use correctly assess drive size, except for my internal hard drives.<br><br>--- On <b>Fri, 5/7/10, Brodey Dover <i>&lt;doverosx@gmail.com&gt;</i></b> wrote:<br><blockquote style="border-left: 2px solid
 rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Brodey Dover &lt;doverosx@gmail.com&gt;<br>Subject: Re: [PC-BSD Testing] Mounting USB Hard Drives<br>To: "PC-BSD Testing list" &lt;testing@lists.pcbsd.org&gt;<br>Date: Friday,
 May 7, 2010, 6:01 PM<br><br><div id="yiv368472811">Right setting mount -t msdosfs WILL NOT work with NTFS... If you have PC-BSD we should have fuse.ko loaded but try with this instead...<div><br></div><div>mount -t ntfs-3g</div><div><div><br><div class="gmail_quote">On Fri, May 7, 2010 at 2:42 PM, Jeff <span dir="ltr">&lt;<a rel="nofollow">dejamuse@yahoo.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><table border="0" cellpadding="0" cellspacing="0"><tbody><tr><td style="font: inherit;" valign="top"><div>This drive is a WD combo, 300GB, NTFS.<br>
<br>It works fine under Windoze.<br><br>This gives an error (invalid argument): mount -o large -t msdosfs /dev/da1 /media/Backup<br><br>Ditto with: mount -o large -t msdosfs /dev/da1s1 /media/Backup<br><br>Both da1 and da1s1 are shown in the dev list (perms = 640), but camcontrol shows it as da1.<br>
<br>The drive is recognized when plugged in and the little USB stick symbol shows up in Dolphin but when you click on it nothing happens.<br><br><br>--- On <b>Thu, 5/6/10, Mike Bybee <i>&lt;<a rel="nofollow">mbybee@dometrilogy.com</a>&gt;</i></b> wrote:<br>
<blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Mike Bybee &lt;<a rel="nofollow">mbybee@dometrilogy.com</a>&gt;<br>Subject: Re: [PC-BSD Testing] Mounting USB Hard Drives<div class="im">
<br>To: "PC-BSD Testing list"
 &lt;<a rel="nofollow">testing@lists.pcbsd.org</a>&gt;<br></div>Date: Thursday, May 6, 2010, 5:57 PM<br><br><div><br><br><div class="gmail_quote">On Thu, May 6, 2010 at 2:33 PM, Ian Robinson <span dir="ltr">&lt;<a rel="nofollow">fitchkendall@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br><br><div class="gmail_quote"><div class="im">On Thu, May 6, 2010 at 3:00 PM, Jeff wrote:<br><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div>
Another drive I have was formatted for Windoze.? Way back in PCBSD 7 or possibly earlier, I was able to read this drive and retrieve some old Windoze files.? I cannot mount this drive anymore using various combinations of: mount_msdosfs -o large /dev/da0s1 /media/Backup<br>



<br>
Or: mount -o large -t msdosfs /dev/da0s1 /media/Backup<br>
<br>
camcontrol devlist reports this drive as da0.</div></blockquote></div><div><br>1.&nbsp; Sometimes a USB device will not mount with the /dev/da0s1 argument but will mount with /dev/da0 <br></div></div><br>2.&nbsp; The FreeBSD handbook (@ <a rel="nofollow" target="_blank" href="http://www.freebsd.org/doc/en/books/handbook/usb-disks.html">http://www.freebsd.org/doc/en/books/handbook/usb-disks.html</a>&nbsp; ) adds a couple of "extras" which may be worth reviewing:<br>


<pre><br>======= Begin Quote from FreeBSD Handbook ================</pre>
<p>"To make this device mountable as a normal user, certain steps have to be taken. First,
the devices that are created when a USB storage device is connected need to be accessible
by the user. A solution is to make all users of these devices a member of the <tt>operator</tt> group. This is done with <a rel="nofollow" target="_blank" href="http://www.freebsd.org/cgi/man.cgi?query=pw&amp;sektion=8"><span><span>pw</span>(8)</span></a>. Second, when
the devices are created, the <tt>operator</tt> group should be able to
read and write them. This is accomplished by adding these lines to <tt>/etc/devfs.rules</tt>:</p>

<pre>[localrules=5]<br>add path 'da*' mode 0660 group operator<br></pre>

<div>
<blockquote>
<p><b>Note:</b> If there already are SCSI disks in the system, it must be done a bit
different. E.g., if the system already contains disks <tt>da0</tt>
through <tt>da2</tt> attached to the system, change the second line as
follows:</p>

<pre>add path 'da[3-9]*' mode 0660 group operator<br></pre>

<p>This will exclude the already existing disks from belonging to the <tt>operator</tt> group.</p>
</blockquote>
</div>

<p>You also have to enable your <a rel="nofollow" target="_blank" href="http://www.freebsd.org/cgi/man.cgi?query=devfs.rules&amp;sektion=5"><span><span>devfs.rules</span>(5)</span></a> ruleset
in your <tt>/etc/rc.conf</tt> file:</p>

<pre>devfs_system_ruleset="localrules"<br></pre>

<p>Next, the kernel has to be configured to allow regular users to mount file systems.
The easiest way is to add the following line to <tt>/etc/sysctl.conf</tt>:</p>

<pre>vfs.usermount=1<br></pre>

<p>Note that this only takes effect after the next reboot. Alternatively, one can also
use <a rel="nofollow" target="_blank" href="http://www.freebsd.org/cgi/man.cgi?query=sysctl&amp;sektion=8"><span><span>sysctl</span>(8)</span></a> to set this
variable.</p>

<p>The final step is to create a directory where the file system is to be mounted. This
directory needs to be owned by the user that is to mount the file system. One way to do
that is for <tt>root</tt> to create a subdirectory owned by that user as
<tt>/mnt/<tt><i>username</i></tt></tt> (replace <tt><i>username</i></tt> by the login name of the actual user and <tt><i>usergroup</i></tt> by the user's primary group):</p>


<pre><samp>#</samp> <kbd>mkdir /mnt/<tt><i>username</i></tt></kbd><br><samp>#</samp> <kbd>chown <tt><i>username</i></tt>:<tt><i>usergroup</i></tt> /mnt/<tt><i>username</i></tt></kbd>"<br><br><br>======= End Quote from FreeBSD Handbook ================<br><br></pre><br>3.&nbsp; The last three Western Digital external USB drives I bought with 500 Gb and larger came formatted NTFS.&nbsp; Are yours formatted Fat32 or NTFS?<br>

<br>4.&nbsp; Even then, NTFS may present mounting issues on 8.0/64 bit installations.&nbsp; See "        [solved]                        <b>Can't mount ntfs usb hard drive"</b> @ 4ttp://<a rel="nofollow" target="_blank" href="http://forums.freebsd.org/showthread.php?t=11968">forums.freebsd.org/showthread.php?t=11968</a><br>


<br>5.&nbsp; There are reports of USB disks hanging during the boot/POST sequence with a recommendation to "disable legacy USB support" in the BIOS.&nbsp; See @ <a rel="nofollow" target="_blank" href="http://forums.freebsd.org/showthread.php?t=11650">http://forums.freebsd.org/showthread.php?t=11650</a><br>

<font color="#888888">
<br>Ian Robinson<br>Salem, Ohio<br><br><br><br><br>
</font><div class="im"><br>_______________________________________________<br>
Testing mailing list<br>
<a rel="nofollow">Testing@lists.pcbsd.org</a><br>
<a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></div></blockquote></div><br>I've had major issues with NTFS USB drives on the new PC-BSD 8 images - especially the higher capacity ones. It's almost critical to make sure you plug them in once you're logged in - I haven't gotten one to work yet if it was plugged in prior to booting.<br>

Also worth noting is that the new extFAT that some of the new thumbdrives come with is nearly impossible to get working (I found it's far easier to just reformat them).<br clear="all"><br>-- <br>Thanks,<br>Mike Bybee<br>


</div><div class="im"><br>-----Inline Attachment Follows-----<br><br><div>_______________________________________________<br>Testing mailing list<br><a rel="nofollow">Testing@lists.pcbsd.org</a><br><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
</div></div></blockquote></div></td></tr></tbody></table><br>







      <br>_______________________________________________<br>
Testing mailing list<br>
<a rel="nofollow">Testing@lists.pcbsd.org</a><br>
<a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></blockquote></div><br></div></div>
</div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a rel="nofollow">Testing@lists.pcbsd.org</a><br><a rel="nofollow" target="_blank" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></div></blockquote></td></tr></tbody></table><br>







      </div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a ymailto="mailto:Testing@lists.pcbsd.org" href="/mc/compose?to=Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br><a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></div></blockquote></td></tr></table><br>