<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html; charset=ISO-8859-1"
 http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
On 05/06/2010 22:34, Brodey Dover wrote:
<blockquote
 cite="mid:r2q283c23cd1005061534h2601816teb67beb1205a0c40@mail.gmail.com"
 type="cite">Although "other" shouldn't need r and w from what I
remember, 666 is the recommended user-level access for device in
FreeBSD. Want to see if adding that w in other helps things along?<br>
  <br>
  <div class="gmail_quote">On Thu, May 6, 2010 at 10:57 AM, Jeff <span
 dir="ltr">&lt;<a moz-do-not-send="true"
 href="mailto:dejamuse@yahoo.com">dejamuse@yahoo.com</a>&gt;</span>
wrote:<br>
  <blockquote class="gmail_quote"
 style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
    <table border="0" cellpadding="0" cellspacing="0">
      <tbody>
        <tr>
          <td
 style="font-family: inherit; font-style: inherit; font-variant: inherit; font-weight: inherit; font-size: inherit; line-height: inherit; font-size-adjust: inherit; font-stretch: inherit; -x-system-font: none;"
 valign="top">I forgot to mention I had changed the perms to crw-rw-r--
but it just does nothing and CUPS reports the job is pending.&nbsp; The file
/dev/ulpt0 BTW, is empty.<br>
          <br>
Printer works fine on Windoze.<br>
          <br>
CUPS error log didn't show anything egregious. <br>
          <br>
CUPS reports printer status: Paused - "Finished page 2..."<br>
          <br>
          <br>
--- On <b>Thu, 5/6/10, Kris Moore <i>&lt;<a moz-do-not-send="true"
 href="mailto:kris@pcbsd.org" target="_blank">kris@pcbsd.org</a>&gt;</i></b>
wrote:<br>
          <blockquote
 style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>
From: Kris Moore &lt;<a moz-do-not-send="true"
 href="mailto:kris@pcbsd.org" target="_blank">kris@pcbsd.org</a>&gt;<br>
Subject: Re: [PC-BSD Testing] Printer won't work<br>
To: <a moz-do-not-send="true" href="mailto:testing@lists.pcbsd.org"
 target="_blank">testing@lists.pcbsd.org</a><br>
Date: Thursday, May 6, 2010, 4:33 AM
            <div>
            <div class="h5"><br>
            <br>
            <div> On 05/06/2010 10:19, Jeff wrote:
            <blockquote type="cite">
              <table border="0" cellpadding="0" cellspacing="0">
                <tbody>
                  <tr>
                    <td
 style="font-family: inherit; font-style: inherit; font-variant: inherit; font-weight: inherit; font-size: inherit; line-height: inherit; font-size-adjust: inherit; font-stretch: inherit; -x-system-font: none;"
 valign="top">I had a Canon i550 working fine in PCBSD 7.1 but it fails
to work in 8.0.<br>
                    <br>
Used the CUPS facility to find this USB printer but it didn't find it.&nbsp;
Manually installed it using the BJC-8200 Gutenprint driver I've used
before.&nbsp; <br>
                    <br>
Then trying to print via OO resulted in CUPS reporting a permission
error: "Unable to open device file: /dev/ulpt0 Permission denied":<br>
                    <br>
Permissions are: crw-r--r--.&nbsp; What does the 'c' mean? User is 'root',
group is 'operator'.<br>
                    <br>
Tried using the PCBSD printer facility and got nowhere. Can't print
test page either.<br>
                    <br>
Any idea how to troubleshoot this?<br>
                    <br>
...Jeff<br>
                    </td>
                  </tr>
                </tbody>
              </table>
              <br>
              <pre><fieldset></fieldset>
_______________________________________________
Testing mailing list
<a moz-do-not-send="true" rel="nofollow"
 href="http://mc/compose?to=Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a>

<a moz-do-not-send="true" rel="nofollow"
 href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a>
  </pre>
            </blockquote>
            <br>
            <br>
The "c" means character device. You can try running "chmod 666"
/dev/utlp0, and check the perms again, should be writable now. <br>
            <br>
If that works, we'll need to check /etc/devfs.rules, utlp0 is already
supposed to be setperm "666", but it may be failing :(<br>
            <br>
            <pre>-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
            </div>
            <br>
            </div>
            </div>
-----Inline Attachment Follows-----
            <div class="im"><br>
            <br>
            <div>_______________________________________________<br>
Testing mailing list<br>
            <a moz-do-not-send="true"
 href="http://mc/compose?to=Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a><br>
            <a moz-do-not-send="true"
 href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
            </div>
            </div>
          </blockquote>
          </td>
        </tr>
      </tbody>
    </table>
    <br>
    <br>
_______________________________________________<br>
Testing mailing list<br>
    <a moz-do-not-send="true" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
    <a moz-do-not-send="true"
 href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
    <br>
  </blockquote>
  </div>
  <br>
  <pre wrap="">
<fieldset class="mimeAttachmentHeader"></fieldset>
_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
  </pre>
</blockquote>
<br>
Yes, please set to all to writable on this device and give it another
whirl. <br>
<br>
If it still fails, you may want to enable debugging output for cups, so
you can see if there is anything else possibly going on. To do so, edit
/usr/local/etc/cups/cupsd.conf and change "LogLevel info" to "LogLevel
debug", then restart cups. <br>
<br>
<pre class="moz-signature" cols="72">-- 
Kris Moore
PC-BSD Software
iXsystems</pre>
</body>
</html>