Re:  Follow-up on screen corruption with PCBSD 8.0-RC2-x86 &amp; Nvidia Legacy Driver 96.43.13.<br><br>Ian Robinson&#39;s original post said:<br><br>&gt;&gt; -RC2 x64 with Nvidia 192.22 is behaving very nicely for me, but -RC2 and<br>
&gt;&gt; legacy drivers caused grief when I did a fresh install of -RC2-x86 on an<br>&gt;&gt; older computer.  The older computer uses an Nvidia GeoForce 4 card (a Ti<br>&gt;&gt; 4200) and the legacy driver installed is 96.43.13 . . . .<br>
&gt;&gt; The 96.43.xx driver worked well under PCBSD 7.1.1.  Under PCBSD 8.0-Alpha,<br>&gt;&gt; it worked but not without some screen corruption such as random speckled<br>&gt;&gt; dots across the display and an occasional but not major horizontal line or<br>
&gt;&gt; two distorting the text or graphic which would go away if you scrolled the<br>&gt;&gt; item beneath them up or down off the screen and brought it back.  I have not<br>&gt;&gt; tested this computer with 8.0-BETA or 8.0-RC.  The behavior in -RC2 is worse<br>
&gt;&gt; that the Alpha series. . . . <br>&gt;&gt; After the passage of some minutes, the screen corrupts badly with thick<br>&gt;&gt; black horizontal bands across the display.  Ultimately, the system will<br>&gt;&gt; freeze.<br>
&gt;&gt;<br>&gt;&gt; I wonder if that is part of the problem?  We all know that FreeBSD is at<br>&gt;&gt; RELEASE stage.  Given that Nvidia 96.43.16 is newer than 96.43.13, are they<br>&gt;&gt; both living in a FreeBSD 7.x world rather than FreeBSD 8.0?  That would<br>
&gt;&gt; explain why the drivers worked great with FreeBSD 7.x and did not work with<br>&gt;&gt; FreeBSD 8.0.  There could be other reasons, though.  Is PCBSD 8.0-RC2<br>&gt;&gt; breaking something because of its recent upgrade to xorg-server 1.6.1?<br>
<br>Kris Moore said:<br><br>&gt;Ian,<br>&gt;<br>&gt;Since the driver actually installs and starts to work at first, I&#39;m<br>&gt;guessing its a compat issue with the FreeBSD 8.0 base, or the new<br>&gt;xorg-server 1.6.5. If you want, you can grab a copy of 8.0-RC, which has<br>
&gt;the older Xorg-server, that way we can narrow it down to the system itself.<br><br>================= Follow-up==========================<br><br>I grabbed PCBSD 8.0-RC-x86, put the nVidia card back in and installed the -RC with a fresh install using the nVidia 96.43.13.<br>
<br>I have had no problems, so it may well be that the new xorg-server 1.6.5 is involved to some degree in causing conflict with 96.43.13.<br><br>Ian Robinson<br>Salem,  Ohio<br>