<br><br><div class="gmail_quote">On Tue, Feb 2, 2010 at 9:50 AM, Mike Bybee <span dir="ltr"><<a href="mailto:mbybee@dometrilogy.com">mbybee@dometrilogy.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div><div></div><div class="h5"><br><br><div class="gmail_quote">On Tue, Feb 2, 2010 at 9:05 AM, Kris Moore <span dir="ltr"><<a href="mailto:kris@pcbsd.com" target="_blank">kris@pcbsd.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

<div>On 01/29/2010 16:30, Ian Robinson wrote:<br>
> Installing from PCBSD 8.0-RC-x64 "Boot Only" CD Image failed.<br>
><br>
> ==================<br>
> TRY #1 Installling from "Boot Only" CD Image<br>
> ==================<br>
><br>
> Upgrade -- Via Internet -- AUTO-DHCP<br>
><br>
> Defect #1 -- You cannot select "Internet"<br>
<br>
<br>
</div>Fixed in SVN<br>
<div><br>
> Defect #2 -- You can click inside and blacken the select-circle as if to<br>
> indicate that a selection has been made.  It has not.  You must also click<br>
> the label "Install from Specificed Server" to make it work.<br>
<br>
</div>Fixed in SVN<br>
<div><br>
> Defect #3 -- User Error through typing a leading "/" in the "Select<br>
> Directory" box<br>
><br>
> The target was <a href="ftp://mirrors.isc.org/pub/pcbsd/8.0-RC/amd64/" target="_blank">ftp://mirrors.isc.org/pub/pcbsd/8.0-RC/amd64/</a><br>
><br>
> Selected FTP<br>
> Selected URL:    <a href="http://mirrors.isc.org" target="_blank">mirrors.isc.org</a><br>
> Selected Directory:     /pub/pcbsd/8.0-RC/amd64<br>
><br>
> Continued with the install configuration, and then noticed the double slash<br>
> ("//") in the middle of the reported path (i.e.,<br>
> <a href="ftp://mirrors.isc.org//pub/pcbsd/8.0-RC/amd64/" target="_blank">ftp://mirrors.isc.org//pub/pcbsd/8.0-RC/amd64/</a> ),<br>
<br>
</div>Good catch, fixed in SVN.<br>
<div><br>
> Defect #4 Going Back Problems. -- I tried to go back.  While the installer<br>
> does let you go back a couple of steps, but it did not let me reset the<br>
> directory path.  That could have been, as I discovered later, that it is<br>
> sometimes the case that the  selection window hides behind the main<br>
> installer window.<br>
<br>
</div>I think in this case it was "hiding" behind the main window, I've added<br>
an extra call in QT which should force it to the top :P<br>
<div><br>
> I could go forward again.  However, when you go forward again, the installer<br>
> routine no longer reports the ftp path.<br>
><br>
> Well, after going forward, the outcome was not pretty because:<br>
><br>
> * The installer "cleans up" (i.e. removes the old installation)<br>
> * The installer begins the installation<br>
> * The installer cannot find the install source directories (over ftp)<br>
> * The installer immediately reports "The installer encountered an error and<br>
> has been halted."<br>
><br>
> * The data in /home/<User_Name>  only appeared to be intact, since you could<br>
> open an Xterm window, mount the /home directory at /mnt/home and list the<br>
> files.<br>
> * A reboot to the "original" installation fails as no kernel will load (no<br>
> surprise).<br>
> * But I could start PCBSD in the console mode, mount /home/<user_name>  and<br>
> see all my data files.<br>
><br>
> Defect # 5  -- The steps to send an installation error report to my email<br>
> failed to deliver it to my email, altlhough it reported that it had sent it.<br>
<br>
</div>I've reworked that script, we can't reliably e-mail since we don't know<br>
about users net connection, smtp settings, etc.<br>
<div><br>
<br>
> ==================<br>
> Try #2 -- Attempted to do an Upgrade Install from "Boot Only" CD after the<br>
> previous failure.<br>
> ==================<br>
><br>
> I correctly named the directory by omitting the leading "/"<br>
> Began the upgrade but it failed, probably because it does not see a system<br>
> to upgrade.<br>
<br>
</div>When it fails, can you click "details" on the error dialog and send me<br>
the last few lines?<br>
<div><br>
> ==================<br>
> Try #3 -- Fresh Install from "Boot Only" CD<br>
> ==================<br>
><br>
> Started the install routine OK, reached the point where it began to download<br>
> from <a href="http://mirrors.isc.org" target="_blank">mirrors.isc.org</a> website, and then failed.  Likewise, the attempt to<br>
> send an email message failed as before.<br>
><br>
> ==================<br>
> Instructions Needed for Network Install Using "Boot Only" CD<br>
> ==================<br>
><br>
> The PCBSD Guide does not have instructions for using the Boot Only CD.<br>
><br>
> There is good picture-based installation advice for "Boot Only" at<br>
> <a href="http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_24389832.htm" target="_blank">http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_24389832.htm</a>   (Note<br>
> -- you have to scroll almost all the way down past the advertising crap to<br>
> see the pictures)  The pictures are from a previous installer (PCBSD 7.x),<br>
> but clearly illustrate the steps.  Something like this would be a great<br>
> addition to the PCBSD User Guide<br>
><br>
> Ian Robinson<br>
<br>
</div>We'll need to get the wiki updated to show this soon :) Hopefully I've<br>
been able to fix your actual installation bugs now though!<br>
<br>
--<br>
<font color="#888888"><br>
Kris Moore<br>
PC-BSD Software<br>
<a href="http://www.pcbsd.com" target="_blank">http://www.pcbsd.com</a><br>
_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br>
</font></blockquote></div><br><br></div></div>Noticed this one this morning - during an install that completed "successfully", I saw dozens of 'write failure, filesystem full" errors when it performed the shutdown.<br>

<br clear="all"><br>-- <br>Thanks,<br><font color="#888888">Mike Bybee<br>
</font></blockquote></div><br><br>Oh, just as a follow up - only 8GB of the 12GB allocated was used.<br clear="all"><br>-- <br>Thanks,<br>Mike Bybee<br>