<br><br><div class="gmail_quote">On Tue, Feb 2, 2010 at 9:05 AM, Kris Moore <span dir="ltr">&lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="im">On 01/29/2010 16:30, Ian Robinson wrote:<br>
&gt; Installing from PCBSD 8.0-RC-x64 &quot;Boot Only&quot; CD Image failed.<br>
&gt;<br>
&gt; ==================<br>
&gt; TRY #1 Installling from &quot;Boot Only&quot; CD Image<br>
&gt; ==================<br>
&gt;<br>
&gt; Upgrade -- Via Internet -- AUTO-DHCP<br>
&gt;<br>
&gt; Defect #1 -- You cannot select &quot;Internet&quot;<br>
<br>
<br>
</div>Fixed in SVN<br>
<div class="im"><br>
&gt; Defect #2 -- You can click inside and blacken the select-circle as if to<br>
&gt; indicate that a selection has been made.  It has not.  You must also click<br>
&gt; the label &quot;Install from Specificed Server&quot; to make it work.<br>
<br>
</div>Fixed in SVN<br>
<div class="im"><br>
&gt; Defect #3 -- User Error through typing a leading &quot;/&quot; in the &quot;Select<br>
&gt; Directory&quot; box<br>
&gt;<br>
&gt; The target was <a href="ftp://mirrors.isc.org/pub/pcbsd/8.0-RC/amd64/" target="_blank">ftp://mirrors.isc.org/pub/pcbsd/8.0-RC/amd64/</a><br>
&gt;<br>
&gt; Selected FTP<br>
&gt; Selected URL:    <a href="http://mirrors.isc.org" target="_blank">mirrors.isc.org</a><br>
&gt; Selected Directory:     /pub/pcbsd/8.0-RC/amd64<br>
&gt;<br>
&gt; Continued with the install configuration, and then noticed the double slash<br>
&gt; (&quot;//&quot;) in the middle of the reported path (i.e.,<br>
&gt; <a href="ftp://mirrors.isc.org//pub/pcbsd/8.0-RC/amd64/" target="_blank">ftp://mirrors.isc.org//pub/pcbsd/8.0-RC/amd64/</a> ),<br>
<br>
</div>Good catch, fixed in SVN.<br>
<div class="im"><br>
&gt; Defect #4 Going Back Problems. -- I tried to go back.  While the installer<br>
&gt; does let you go back a couple of steps, but it did not let me reset the<br>
&gt; directory path.  That could have been, as I discovered later, that it is<br>
&gt; sometimes the case that the  selection window hides behind the main<br>
&gt; installer window.<br>
<br>
</div>I think in this case it was &quot;hiding&quot; behind the main window, I&#39;ve added<br>
an extra call in QT which should force it to the top :P<br>
<div class="im"><br>
&gt; I could go forward again.  However, when you go forward again, the installer<br>
&gt; routine no longer reports the ftp path.<br>
&gt;<br>
&gt; Well, after going forward, the outcome was not pretty because:<br>
&gt;<br>
&gt; * The installer &quot;cleans up&quot; (i.e. removes the old installation)<br>
&gt; * The installer begins the installation<br>
&gt; * The installer cannot find the install source directories (over ftp)<br>
&gt; * The installer immediately reports &quot;The installer encountered an error and<br>
&gt; has been halted.&quot;<br>
&gt;<br>
&gt; * The data in /home/&lt;User_Name&gt;  only appeared to be intact, since you could<br>
&gt; open an Xterm window, mount the /home directory at /mnt/home and list the<br>
&gt; files.<br>
&gt; * A reboot to the &quot;original&quot; installation fails as no kernel will load (no<br>
&gt; surprise).<br>
&gt; * But I could start PCBSD in the console mode, mount /home/&lt;user_name&gt;  and<br>
&gt; see all my data files.<br>
&gt;<br>
&gt; Defect # 5  -- The steps to send an installation error report to my email<br>
&gt; failed to deliver it to my email, altlhough it reported that it had sent it.<br>
<br>
</div>I&#39;ve reworked that script, we can&#39;t reliably e-mail since we don&#39;t know<br>
about users net connection, smtp settings, etc.<br>
<div class="im"><br>
<br>
&gt; ==================<br>
&gt; Try #2 -- Attempted to do an Upgrade Install from &quot;Boot Only&quot; CD after the<br>
&gt; previous failure.<br>
&gt; ==================<br>
&gt;<br>
&gt; I correctly named the directory by omitting the leading &quot;/&quot;<br>
&gt; Began the upgrade but it failed, probably because it does not see a system<br>
&gt; to upgrade.<br>
<br>
</div>When it fails, can you click &quot;details&quot; on the error dialog and send me<br>
the last few lines?<br>
<div class="im"><br>
&gt; ==================<br>
&gt; Try #3 -- Fresh Install from &quot;Boot Only&quot; CD<br>
&gt; ==================<br>
&gt;<br>
&gt; Started the install routine OK, reached the point where it began to download<br>
&gt; from <a href="http://mirrors.isc.org" target="_blank">mirrors.isc.org</a> website, and then failed.  Likewise, the attempt to<br>
&gt; send an email message failed as before.<br>
&gt;<br>
&gt; ==================<br>
&gt; Instructions Needed for Network Install Using &quot;Boot Only&quot; CD<br>
&gt; ==================<br>
&gt;<br>
&gt; The PCBSD Guide does not have instructions for using the Boot Only CD.<br>
&gt;<br>
&gt; There is good picture-based installation advice for &quot;Boot Only&quot; at<br>
&gt; <a href="http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_24389832.htm" target="_blank">http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_24389832.htm</a>   (Note<br>
&gt; -- you have to scroll almost all the way down past the advertising crap to<br>
&gt; see the pictures)  The pictures are from a previous installer (PCBSD 7.x),<br>
&gt; but clearly illustrate the steps.  Something like this would be a great<br>
&gt; addition to the PCBSD User Guide<br>
&gt;<br>
&gt; Ian Robinson<br>
<br>
</div>We&#39;ll need to get the wiki updated to show this soon :) Hopefully I&#39;ve<br>
been able to fix your actual installation bugs now though!<br>
<br>
--<br>
<font color="#888888"><br>
Kris Moore<br>
PC-BSD Software<br>
<a href="http://www.pcbsd.com" target="_blank">http://www.pcbsd.com</a><br>
_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br>
</font></blockquote></div><br><br>Noticed this one this morning - during an install that completed &quot;successfully&quot;, I saw dozens of &#39;write failure, filesystem full&quot; errors when it performed the shutdown.<br>
<br clear="all"><br>-- <br>Thanks,<br>Mike Bybee<br>