<br>ISSUE #1 Disabling compositing fixes issues with nvidia x64 driver version 195.22<br><br>&gt;&gt; The following problems have appeared in my system since the BETA version:<br>&gt;&gt;<br>&gt;&gt; 1.  Screen Rendering Delay:  Screen rendering is generally slow. . . .<br>
&gt;&gt;<br>&gt;&gt; 2. Screen color contamination:  The menu background (white) is often<br>&gt;&gt; contaminated with 1/2&quot; stripes the same color as the desktop screen.  <br>&gt;&gt;<br>&gt;&gt; 4.  Web Pages Slow to Load:  Delay in getting web pages to load and in<br>
&gt;&gt; saving images to disk (i.e., waiting for save dialog window to appear).<br>&gt;&gt;<br><br>&gt;Do these issues also occur with &quot;nv&quot; driver, or with compositing disabled?<br><br><br>ANSWER:  These issues disappear with compositing disabled.<br>
<br>ISSUE #2.  No sound in 8.0-BETA or RC w/ ICH5<br>&gt;&gt; 10.  Sound card -- No sound.  The sound card is an Intel ICH5 (AC&#39;97).<br>&gt;&gt; Sound support is enabled in /boot/loader.conf and /etc/rc.conf.  I&#39;ve<br>
&gt;&gt; confirmed that the sound card is recognized by the system, that the speakers<br>&gt;&gt; are on, that the speaker inputs/computer outputs are connected, that the<br>&gt;&gt; mixer volumes are &quot;up&quot; and not muted.  I&#39;ve tried different sets of speakers<br>
&gt;&gt; known to work.  The sound card&amp;  speakers worked under PCBSD 7.1.1.<br>&gt;&gt;<br>&gt;&gt;<br>&gt;I&#39;m at a loss on this one. I don&#39;t know enough about sound-driver<br>&gt;internals to help debug it properly. I would recommend posting the<br>
&gt;output of &quot;dmesg&quot;, &quot;cat /dev/sndstat&quot; and &quot;pciconf -lv&quot; to the freebsd<br>&gt;multimedia list:<br>&gt;<br>&gt;<a href="http://lists.freebsd.org/mailman/listinfo/freebsd-multimedia">http://lists.freebsd.org/mailman/listinfo/freebsd-multimedia</a><br>
&gt;<br>&gt;Hopefully one of the driver devs knows why this got broken in the 8.0<br>&gt;driver, and maybe has a configuration workaround we can incorporate :)<br>&gt;<br>&gt;--<br>&gt;<br>&gt;Kris Moore<br>&gt;PC-BSD Software<br>
<br><br>FOLLOW-UP:<br><br>The following FreeBSD wiki was very helpful in troubleshooting sound problems and identifying what information to report: <br><br><a href="http://wiki.freebsd.org/Sound">http://wiki.freebsd.org/Sound</a>   <br>
<br>Unfortunately I did not find a solution. <br><br>I submitted a bug report to FreeBSD.org via the web-based &quot;Submit a Bug Report&quot; @ <a href="http://www.freebsd.org/send-pr.html">http://www.freebsd.org/send-pr.html</a>.  <br>
<br>I provided the following information that was suggested and some of my own resulting from research on troubleshooting sound issues:<br><br>=========== BEGIN BUG REPORT =====================<br><br>In FreeBSD 8.0-RELEASE (x64), the Intel ICH5 82801EB sound chip makes no sound.  <br>
On same computer using FreeBSD 7.2-RELEASE (x86), the sound worked.<br><br>===========================<br>Output of uname -a<br>===========================<br>%uname -a<br>FreeBSD pcbsd-5301 8.0-RELEASE-p2 FreeBSD 8.0-RELEASE-p2 #10: Thu Jan  7 14:50:53 EST 2010     root@build8x64.pcbsd.org:/usr/obj/usr/pcbsd-build80/fbsd-source/8.0-src/sys/PCBSD  amd64<br>
%<br><br>===========================<br>Output of cat /dev/sndstat<br>===========================<br>% cat /dev/sndstat<br>FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)<br>Installed devices:<br>pcm0: &lt;Intel ICH5 (82801EB)&gt; at io 0xf2600400, 0xf2600600 irq 17 bufsz 16384 kld snd_ich [MPSAFE] (1p:4v/1r:4v channels duplex default)<br>
%<br>===========================<br>Output of mixer values<br>===========================<br>%mixer<br>Mixer vol      is currently set to  75:75<br>Mixer pcm      is currently set to  78:78<br>Mixer line     is currently set to  77:77<br>
Mixer mic      is currently set to  75:75<br>Mixer cd       is currently set to  78:78<br>Mixer rec      is currently set to  75:75<br>Mixer igain    is currently set to  20:20<br>Mixer ogain    is currently set to  20:20<br>
Mixer line1    is currently set to  20:20<br>Mixer phin     is currently set to   0:0<br>Mixer phout    is currently set to   0:0<br>Recording source: mic<br>%<br><br>===========================<br>Output of cat sysctl hw.snd<br>
===========================<br>% sysctl hw.snd<br>hw.snd.feeder_rate_quality: 1<br>hw.snd.feeder_rate_round: 25<br>hw.snd.feeder_rate_max: 2016000<br>hw.snd.feeder_rate_min: 1<br>hw.snd.feeder_rate_polyphase_max: 183040<br>
hw.snd.feeder_rate_presets: 100:8:0.85 100:36:0.92 100:164:0.97<br>hw.snd.feeder_eq_exact_rate: 0<br>hw.snd.feeder_eq_presets: PEQ:16000,0.2500,62,0.2500:-9,9,1.0:44100,48000,88200,96000,176400,192000<br>hw.snd.vpc_reset: 0<br>
hw.snd.vpc_0db: 45<br>hw.snd.vpc_autoreset: 1<br>hw.snd.latency_profile: 1<br>hw.snd.latency: 5<br>hw.snd.report_soft_matrix: 1<br>hw.snd.report_soft_formats: 1<br>hw.snd.compat_linux_mmap: 0<br>hw.snd.vpc_mixer_bypass: 1<br>
hw.snd.verbose: 1<br>hw.snd.maxautovchans: 16<br>hw.snd.default_unit: 0<br>hw.snd.version: 2009061500/amd64<br>hw.snd.default_auto: 0<br>%<br><br>===========================<br>Output of cat sysctl dev.pcm<br>===========================<br>
% sysctl dev.pcm<br>dev.pcm.0.%desc: Intel ICH5 (82801EB)<br>dev.pcm.0.%driver: pcm<br>dev.pcm.0.%location: slot=31 function=5<br>dev.pcm.0.%pnpinfo: vendor=0x8086 device=0x24d5 subvendor=0x103c subdevice=0x12f1 class=0x040100<br>
dev.pcm.0.%parent: pci0<br>dev.pcm.0.eapd: 1<br>dev.pcm.0.play.vchans: 4<br>dev.pcm.0.play.vchanmode: fixed<br>dev.pcm.0.play.vchanrate: 48000<br>dev.pcm.0.play.vchanformat: s16le:2.0<br>dev.pcm.0.rec.vchans: 4<br>dev.pcm.0.rec.vchanmode: fixed<br>
dev.pcm.0.rec.vchanrate: 48000<br>dev.pcm.0.rec.vchanformat: s16le:2.0<br>dev.pcm.0.buffersize: 16384<br>dev.pcm.0.bitperfect: 0<br>dev.pcm.0.ac97rate: 48000<br>[IR@pcbsd-5301]/home/IR(23)%<br><br>===========================<br>
Sound-Related Device Output of dmesg<br>===========================<br><br>pcm0: &lt;Intel ICH5 (82801EB)&gt; port 0x5000-0x50ff,0x5400-0x543f mem 0xf2600400-0xf26005ff,0xf2600600-0xf26006ff irq 17 at device 31.5 on pci0<br>
pcm0: [ITHREAD]<br>pcm0: &lt;Analog Devices AD1981B AC97 Codec&gt;<br><br>===========================<br>Output of kldload snd_ich<br>===========================<br><br># kldload snd_ich<br>kldload: can&#39;t load snd_ich: File exists<br>
#<br><br>===========================<br>Output of kldstat<br>===========================<br>% kldstat<br>Id Refs Address            Size     Name<br> 1   97 0xffffffff80100000 d6b7c0   kernel<br> 2    2 0xffffffff80e6c000 ee88     ntfs.ko<br>
 3    1 0xffffffff80e7b000 190250   zfs.ko<br> 4    2 0xffffffff8100c000 3858     opensolaris.ko<br> 5    1 0xffffffff81010000 19738    geom_eli.ko<br> 6    2 0xffffffff8102a000 2a7d0    crypto.ko<br> 7    3 0xffffffff81055000 dc40     zlib.ko<br>
 8    1 0xffffffff81063000 1e6e8    geom_journal.ko<br> 9    1 0xffffffff81082000 20b20    geom_mirror.ko<br>10    1 0xffffffff810a3000 3248     geom_uzip.ko<br>11    1 0xffffffff810a7000 e690     if_ipw.ko<br>12    1 0xffffffff810b6000 12628    if_wpi.ko<br>
13    4 0xffffffff810c9000 757f0    sound.ko  &lt;-----------<br>14    1 0xffffffff8113f000 13e38    snd_uaudio.ko<br>15    1 0xffffffff81153000 19aa8    if_iwn.ko<br>16    1 0xffffffff8116d000 ae08     mmc.ko<br>17    1 0xffffffff81178000 4090     mmcsd.ko<br>
18    1 0xffffffff8117d000 8178     sdhci.ko<br>19    1 0xffffffff81186000 5298     scd.ko<br>20    5 0xffffffff8118c000 6cb8     libiconv.ko<br>21    1 0xffffffff81193000 2020     libmchain.ko<br>22    1 0xffffffff81196000 1058     cd9660_iconv.ko<br>
23    1 0xffffffff81198000 1070     msdosfs_iconv.ko<br>24    1 0xffffffff8119a000 1020     ntfs_iconv.ko<br>25    2 0xffffffff8119c000 98c0     udf.ko<br>26    1 0xffffffff811a6000 1008     udf_iconv.ko<br>27    1 0xffffffff811a8000 b280     tmpfs.ko<br>
28    1 0xffffffff811b4000 d3cac8   nvidia.ko<br>29    3 0xffffffff81ef1000 414b8    linux.ko<br>30    1 0xffffffff82022000 3a1e     linprocfs.ko<br>31    1 0xffffffff82026000 a237     ipfw.ko<br>32    1 0xffffffff82031000 2d3e     snd_ich.ko  &lt;--------<br>
33    1 0xffffffff82034000 1fbe     nullfs.ko<br>%<br><br>===========================<br>Selected Output of pciconf -lv<br>===========================<br>% pciconf -lv                                                                                              <br>
                                                                                                                                                                                                                                 <br>
pcm0@pci0:0:31:5:       class=0x040100 card=0x12f1103c chip=0x24d58086 rev=0x02 hdr=0x00<br>    vendor     = &#39;Intel Corporation&#39;<br>    device     = &#39;multimedia audio device (codec AC97) SoundMAX or VIA (8086)&#39;<br>
    class      = multimedia<br>    subclass   = audio<br>%<br><br>===========================<br>Contents of /boot/loader.conf:<br>===========================<br># Load sound-support<br>sound_load=&quot;YES&quot;<br>snd_uaudio_load=&quot;YES&quot;<br>
<br>===========================<br>Contents of /etc/rc.conf:<br>===========================<br># Enable sound-support<br>snddetect_enable=&quot;YES&quot;<br>mixer_enable=&quot;YES&quot;<br><br>=============== END BUG REPORT =========================<br>
<br><br><br><br>ISSUE 3:  @ Mike Bybee:<br><br>&gt;Noticed this one this morning - during an install that completed<br>&gt;&quot;successfully&quot;, I saw dozens of &#39;write failure, filesystem full&quot; errors when<br>
&gt;it performed the shutdown.<br>&gt;<br>&gt;--<br>&gt;Thanks,<br>&gt;Mike Bybee<br><br>Mike -- your &quot;write failure, filesystem full&quot; might be because the installation routine did not mount the target.  <br><br>
You can go to a terminal and check the pcbsd installation log (Install logging and failure reporting is a new feature Kris put into the installer).  That log should tell you exactly why you are getting the errors.<br><br>
Ian Robinson<br>Salem, Ohio<br><br><br>