<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
yes, those are apache configuration errors.<br>
<br>
you must configure your virtual host to create the logs in the correct
folder, depending on the OS it can be defaulting in different places,
some of those are:<br>
&nbsp;- /var/log/<br>
&nbsp;- /var/log/http/<br>
&nbsp;- [default doc dir]/logs<br>
<br>
plus you may want to do an hostname to configure your hostname
correctly.<br>
<br>
best way to do it if you do not have much experience with apache, is to
install webmin, configure the apache module to look into the correct
folder and use webmin to configure apache as you wish.<br>
<br>
Fabry<br>
<br>
Brodey Dover wrote:
<blockquote
 cite="mid:283c23cd0908201004y221acf24g14fc64d58f9d8bb9@mail.gmail.com"
 type="cite">
  <pre wrap="">On 8/11/09, Kris Moore <a class="moz-txt-link-rfc2396E" href="mailto:kris@pcbsd.org">&lt;kris@pcbsd.org&gt;</a> wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap="">Brodey,

Give this PBI a shot:

<a class="moz-txt-link-freetext" href="ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/7/outgoing/servers/apache22/Apache2.2.11_7-PV0.pbi">ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/7/outgoing/servers/apache22/Apache2.2.11_7-PV0.pbi</a>

On my system here, it does install + run just fine, but it still needs some
more cleanup before I'm ready
to commit it to pbidir. I'm trying to fix it up now, but please try the
existing one, to confirm it starts / runs
for you :)

--
Kris Moore
PC-BSD Software

On Tue, 11 Aug 2009, Brodey Dover wrote:

    </pre>
    <blockquote type="cite">
      <pre wrap="">Hi Kris,
I installed this bad boy from PBI site and I swear I didn't touch anything
;). Oddly enough, the /usr/Programs/rc.d stuff doesn't respond in
the same way that I figured /usr/local/etc/rc.d stuff doesn't. The good
thing is that I only need apache to run for my OS testing so it
isn't critical, but I wonder if the localbase for the PBI was never
updated??

Anyway, this is for i386.

On Mon, Aug 10, 2009 at 8:04 PM, Kris Moore <a class="moz-txt-link-rfc2396E" href="mailto:kris@pcbsd.org">&lt;kris@pcbsd.org&gt;</a> wrote:

      Brodey,

      I'll test this out further in the morning and see if I can figure
out
      whats going on with it. You just installed this PBI
      fresh from pbidir.com right? Also, the rc scripts are under
      /usr/Programs/rc.d/apache22, and /Programs/Apache*/

      Oh, this is on amd64 or i386?


      --
      Kris Moore
      PC-BSD Software

On Mon, 10 Aug 2009, Brodey Dover wrote:

      </pre>
      <blockquote type="cite">
        <pre wrap="">On 8/10/09, Brodey Dover <a class="moz-txt-link-rfc2396E" href="mailto:doverosx@gmail.com">&lt;doverosx@gmail.com&gt;</a> wrote:
        </pre>
        <blockquote type="cite">
          <pre wrap="">Sooo, I've got the PBI installed and I've got nothing of the sort
running are capable of running. So, out-of-the-box the PBI fails
outright.

[root@pcbsd]/home/brodey(42)# /usr/Programs/rc.d/apache22 status
[root@pcbsd]/home/brodey(43)# /usr/Programs/rc.d/apache22 restart
[root@pcbsd]/home/brodey(44)# /usr/Programs/rc.d/apache22 status
[root@pcbsd]/home/brodey(45)# /usr/Programs/rc.d/apache22 start

As you can see there is no output, is this a lack of HTTP_ACCEPT??

[root@pcbsd]/home/brodey(52)# kldstat
Id Refs Address    Size     Name
 1   22 0xc0400000 b1ad40   kernel
 2    2 0xc0f1b000 29b5c    linux.ko
 3    1 0xc0f45000 3818     ulpt.ko
 4    1 0xc0f49000 2354     accf_http.ko
 5    1 0xc0f4c000 6a48c    acpi.ko
 6    1 0xc33ff000 7000     linprocfs.ko
 7    1 0xc3636000 6000     snd_ich.ko
 8    1 0xc37ed000 9000     i915.ko
 9    1 0xc37f6000 13000    drm.ko

Nope, there is accf_http.ko in all of its glory.

Am I using the wrong installed instance of apache?

[root@pcbsd]/home/brodey(54)# find / -name 'apache22'
/usr/PCBSD/Services/apache22
/usr/Programs/rc.d/apache22
/usr/Programs/Apache2.2.11_7/services/apache22
/usr/Programs/Apache2.2.11_7/etc/rc.d/apache22
/usr/Programs/Apache2.2.11_7/etc/apache22
/usr/Programs/Apache2.2.11_7/www/apache22
/usr/Programs/Apache2.2.11_7/libexec/apache22
/usr/local/etc/apache22
/usr/local/libexec/apache22
/usr/local/www/apache22
[root@pcbsd]/home/brodey(55)#
/usr/Programs/Apache2.2.11_7/etc/rc.d/apache22 status
[root@pcbsd]/home/brodey(56)#
/usr/Programs/Apache2.2.11_7/etc/rc.d/apache22 restart
[root@pcbsd]/home/brodey(57)# cd /usr/PCBSD/Services/
[root@pcbsd]/usr/PCBSD/Services(58)# ls -l
total 16
drwxr-xr-x  2 root  wheel  512 May 29 09:44 acpinotebook
lrwxr-xr-x  1 root  wheel   42 Aug  9 23:10 apache22 -&gt;
/Programs/Apache2.2.11_7/services/apache22
drwxr-xr-x  2 root  wheel  512 May 29 09:44 cpufreq
drwxr-xr-x  2 root  wheel  512 May 29 09:44 cups
drwxr-xr-x  2 root  wheel  512 May 29 09:44 denyhosts
drwxr-xr-x  2 root  wheel  512 May 29 09:44 hplip
drwxr-xr-x  2 root  wheel  512 May 29 09:44 oss
drwxr-xr-x  2 root  wheel  512 May 29 09:44 pf
drwxr-xr-x  2 root  wheel  512 May 29 09:44 ssh

I'm not sure where apachectl is, but I usually use that when I can't
get any verbose output from apache22 buuut:

[root@pcbsd]/usr/PCBSD/local/sbin(70)# find / -name apachectl
[root@pcbsd]/usr/PCBSD/local/sbin(71)#

so find recovers nothing. ls doesn't list any apachectls either.
/usr/local/sbin has httpd, but that isn't apache..or is it?

[root@pcbsd]/usr/local/sbin(74)# ./httpd
httpd: Could not reliably determine the server's fully qualified
domain name, using 127.0.0.1 for ServerName

Interesting, 127.0.0.1 "It works!". Hrmm, so there must be a script
looking for apache22 instead of httpd?? Worse!

apache start, stop, restart are all not working!! Yikes!

/PCBSD/Services/apache22/start.sh
/PCBSD/Services/apache22/stop.sh
/PCBSD/Services/apache22/restart.sh

should check for directory...
/usr/local/sbin/httpd -k start

and not /usr/local/etc/rc.d/.... as this doesn't seem to be the
standard Apache install.

I have it working, even with reboots, but of course you guys know your
scripts/services better than I do ;).

          </pre>
        </blockquote>
        <pre wrap="">Or not...I can't find any of the scripts that launch because my
/usr/local/etc/rc.d is wiped clean, what is going on?
_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>





        </pre>
      </blockquote>
      <pre wrap="">_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>


!DSPAM:1,4a819ed514801338211154!

      </pre>
    </blockquote>
  </blockquote>
  <pre wrap=""><!---->

Sorry for the delay, but I really tried to get this one going. To
complete the install I first removed the old version from PBI manager
and decided to reboot, not that it should be necessary. After booting
to the desktop, I launched the PBI executable and proceed to test as
there were no errors.

I presume that after the install that the Apachi service should be
working, but 127.0.0.1 does not respond. Restarting the computer does
not fix this. There is nothing in /usr/local/etc/rc.d so I couldn't
boot it the "old" way. I can see that there are some results from your
work here though:

[root@pcbsd]/usr(110)# /usr/Programs/rc.d/apache22 status
apache22 is not running.
[root@pcbsd]/usr(111)# /usr/Programs/rc.d/apache22 start
Performing sanity check on apache22 configuration:
httpd: Could not reliably determine the server's fully qualified
domain name, using 127.0.0.1 for ServerName
Syntax OK
Starting apache22.
httpd: Could not reliably determine the server's fully qualified
domain name, using 127.0.0.1 for ServerName
no listening sockets available, shutting down
Unable to open logs

I think this has something to do with the httpd.conf file.

Regards,
Brodey Dover
_______________________________________________
Testing mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a>
  </pre>
</blockquote>
</body>
</html>