<html><body bgcolor="#FFFFFF"><div>If u use only 1024x768 on both monitors, set the virtual space to be (1024x2) x 768. : 2048x768</div><div><br></div><div>I would then restart.  My way to use dual monitor with my laptop was to let PCBSD create the config file, I added the virtual size , the I run a script at start up that sets my two monitors only if both are attached.</div><div><br></div><div>Fabry<br><br>My iPhone helped me send this email from around the world!!</div><div><br>On Aug 3, 2009, at 23:05, Jeff <<a href="mailto:dejamuse@yahoo.com">dejamuse@yahoo.com</a>> wrote:<br><br></div><div></div><blockquote type="cite"><div><table cellspacing="0" cellpadding="0" border="0"><tbody><tr><td valign="top" style="font: inherit;">Well, I tried lots of things but nothing worked.  X crashes at start.<br><br>Here's one xorg.conf that I tried:<br>---------------------------------------------------------------------<br><br># Xorg.conf file generated for PC-BSD<br><br>Section "ServerLayout"<br>    Identifier     "Multihead layout"<br>    Screen       0 "Screen0" 0 0<br>    Screen     1 "Screen1" Rightof "Screen0"<br>    InputDevice    "Mouse0" "CorePointer"<br>    InputDevice    "Keyboard0" "CoreKeyboard"<br>    Option       "Clone" "off"<br>EndSection<br><br>Section "ServerFlags"<br>    Option "AutoAddDevices"
 "False"<br>        Option "AllowEmptyInput" "Off"<br>    Option "Xinerama" "On"<br>EndSection<br><br>Section "Files"<br>    ModulePath      "/usr/PCBSD/local/lib/xorg/modules"<br>    FontPath        "/Programs/fonts/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/cyrillic/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/TrueType/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/webfonts/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/misc/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/TTF/"<br>   
 FontPath        "/usr/PCBSD/local/lib/X11/fonts/Type1/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/CID/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/75dpi/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/100dpi/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/dejavu/"<br>    FontPath        "/usr/PCBSD/local/lib/X11/fonts/local/"<br>EndSection<br><br>Section "Module"<br>    Load           "ddc"<br>    Load           "dbe"<br>    Load       "dri"<br>   
 Load           "extmod"<br>    Load       "glx"<br>    Load           "xtrap"<br>    Load           "freetype"<br>EndSection<br><br>Section "InputDevice"<br>    Identifier     "Keyboard0"<br>    Driver         "keyboard"<br>    Option         "XkbModel" "pc105"<br>    Option         "XkbLayout" "us"<br>    Option         "XkbVariant" ""<br>EndSection<br><br>Section "InputDevice"<br>    Identifier     "Mouse0"<br>   
 Driver         "mouse"<br>    Option         "Protocol" "auto"<br>    Option         "Device" "/dev/sysmouse"<br>    Option         "Buttons" "6"<br>    Option         "ZAxisMapping" "4 5"<br>    Option         "Emulate3Buttons"<br>EndSection<br><br><br>Section "Monitor"<br>    Identifier     "Monitor0"<br>    VendorName     "ACR"<br>    ModelName      "AL1716"<br>    HorizSync    31.0 - 81.0<br>    VertRefresh  56.0 - 75.0<br><br>SubSection
 "Display"<br>           Depth        24<br>           Modes        "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"<br>           # ADD A VIRTUAL LINE TO PROVIDE FOR THE LARGEST SCREENS YOU WILL HOTPLUG <br>           Virtual              2048 2048 <br>       EndSubSection<br><br>EndSection<br><br>Section "Monitor"<br>    Identifier     "Monitor1"<br>    VendorName     "ACR"<br>    ModelName      "AL1716"<br>    HorizSync    31.0 - 81.0<br>   
 VertRefresh  56.0 - 75.0<br>EndSection<br><br><br>Section "Device"<br>    Identifier      "Card0"<br>    Screen           0<br>    Driver         "ati"<br>    VendorName     "ATI Video Driver"<br>    Option         "CPPIOMode" "yes" <br>    BusID      "PCI:2:0:0"<br>EndSection<br><br>Section "Device"<br>    Identifier      "Card1"<br>    Screen           1<br>    Driver         "ati"<br>    VendorName     "ATI Video Driver"<br>   
 Option         "CPPIOMode" "yes" <br>    BusID      "PCI:2:0:0"<br>EndSection<br><br><br>Section "Screen"<br>    Identifier     "Screen0"<br>    Device         "Card0"<br>    Monitor        "Monitor0"<br>    DefaultDepth   24<br>    SubSection     "Display"<br>        Depth      24 <br>        Modes      "1024x768"<br>    EndSubSection<br>EndSection<br><br>Section "Screen"<br>    Identifier     "Screen1"<br>    Device         "Card1"<br>   
 Monitor        "Monitor1"<br>    DefaultDepth   24<br>    SubSection     "Display"<br>        Depth      24 <br>        Modes      "1024x768"<br>    EndSubSection<br>EndSection<br>==============================<br><br>--- On <b>Thu, 7/30/09, Kris Moore <i><<a href="mailto:kris@pcbsd.org">kris@pcbsd.org</a>></i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Kris Moore <<a href="mailto:kris@pcbsd.org">kris@pcbsd.org</a>><br>Subject: Re: [PC-BSD Testing] Dual monitor mode not working<br>To: "PC-BSD Testing list" <<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>><br>Date: Thursday, July 30, 2009, 9:04 AM<br><br><div class="plainMail"><br>Jeff,<br><br>The dual-monitor stuff in the wizard really only works with nvidia for now. I need to
 get<br>a new card to test ATI out with, and figure out how the heck it works :P<br><br>Basically, you'll need to setup xorg correctly, before trying anything within KDE. Take a look here at<br>the first section, specifically the xorg configuration:<br><br><a href="http://en.gentoo-wiki.com/wiki/X.Org/Dual_Monitors/ATI" target="_blank"><a href="http://en.gentoo-wiki.com/wiki/X.Org/Dual_Monitors/ATI">http://en.gentoo-wiki.com/wiki/X.Org/Dual_Monitors/ATI</a></a><br><br>I'm guessing you'll need something like this setup: (Make sure you get BusID set right)<br><br><br>Section "ServerFlags"<br>    Option "Xinerama" "On" EndSection<br><br>Section "Module"<br>    Load "dbe" # Double-Buffering Extension<br>    Load "v4l" # Video for Linux<br>    Load "extmod"<br>    Load "type1"<br>    Load "freetype"<br>    Load "glx"<br>    Load "dri" EndSection<br><br>... Section "Device"<br>    Identifier "device0"<br>    VendorName
 "ATI"<br>    BoardName "ATI Radeon"<br>    Driver "radeon"<br>    BusID "PCI:1:0:0"<br>    Screen 0 EndSection<br><br>Section "Device"<br>    Identifier "device1"<br>    BoardName "ATI Radeon"<br>    Driver "radeon"<br>    BusID "PCI:1:0:0"<br>    Screen 1<br>EndSection<br><br>Section "Monitor"<br>    Identifier "monitor0"<br>    Option "DPMS"<br>EndSection<br><br>Section "Monitor"<br>    Identifier "monitor1"<br>    Option "DPMS"<br>EndSection<br><br>Section "Screen"<br>    Identifier "Screen0"<br>    Device "device0"<br>    Monitor "monitor0"<br>    DefaultColorDepth 24<br>    Subsection "Display"<br>        Depth 24<br>        Virtual 1280 1024<br>        Modes    "1280x1024"<br>   
 EndSubsection<br>EndSection<br><br>Section "Screen"<br>    Identifier "Screen1"<br>    Device "device1"<br>    Monitor "monitor1"<br>    DefaultColorDepth 24<br>    Subsection "Display"<br>        Depth 24<br>        Virtual 1280 1024<br>        Modes    "1280x1024"<br>    EndSubsection<br>EndSection<br><br>Section "ServerLayout"<br>    Identifier "Multihead layout"<br>    InputDevice "Keyboard1" "CoreKeyboard"<br>    InputDevice "Mouse0" "CorePointer"<br>    Screen  "Screen0" 0 0<br>    Screen  "Screen1" RightOf "Screen0"<br>EndSection<br><br><br>If you can modify this and get a true dual-head working, send me your valid xorg conf, so I can figure out how to get the display wizard to generate it for you :)<br><br>--<br>Kris Moore<br>PC-BSD Software<br><br>On Wed, 29
 Jul 2009, Jeff wrote:<br><br>> Ok, well the VESA driver sucked - scrolling was really slow in FF3.  Switched back to the ATI driver and fixed that; then<br>> the 2nd monitor lit up, AND the monitor utility was now working - not sure what I was doing wrong before.<br>> <br>> But both monitors are still cloned.  Reading the KDE handbook, it says there's supposed to be a button to split the<br>> monitors or clone them, but it's not there.<br>> <br>> <br>> <br>> --- On Wed, 7/29/09, Jeff <<a ymailto="mailto:dejamuse@yahoo.com" href="/mc/compose?to=dejamuse@yahoo.com"><a href="mailto:dejamuse@yahoo.com">dejamuse@yahoo.com</a></a>> wrote:<br>> <br>>       From: Jeff <<a ymailto="mailto:dejamuse@yahoo.com" href="/mc/compose?to=dejamuse@yahoo.com"><a href="mailto:dejamuse@yahoo.com">dejamuse@yahoo.com</a></a>><br>>       Subject: [PC-BSD Testing] Dual monitor mode not working<br>>       To: <a ymailto="mailto:testing@lists.pcbsd.org" href="/mc/compose?to=testing@lists.pcbsd.org"><a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a></a><br>>       Date: Wednesday, July 29, 2009, 4:33 PM<br>> <br>>       I have a dual DVI video card (XFX HD-4850) ATI HD4850 and wanted to set up dual monitors. <br>> <br>>       First I selected "re-run the X setup display wizard" (amd64 system) but it displays a black screen with cursor<br>>       and nothing happens.  Have to power down the machine to get out and suffer the long delay of HD checking.<br>> <br>>       I tried configuring with the ATI, HDRadeon, and VESA drivers and only the VESA driver allows the 2nd monitor<br>>       to come on but it just clones the other display.  There doesn't seem to be any utility for managing the
 two<br>>       monitors. Something was mentioned about xrandr.  Krandr says my X server does not support that utility.<br>> <br>>       Here's a thread on the same subject where the guy ended up submitting a KDE bug report.  He managed to get<br>>       dual monitors working by manually editing the xorg.conf file.  Running:<br>> <br>>       # xrandr -q<br>> <br>>       Results in:<br>> <br>>       Xlib:  extension "RANDR" missing on display ":0.0".<br>>       RandR extension missing<br>> <br>>       My xorg.conf shows two monitors but both have the same monitor brand and I have two different monitors.  Is<br>>       KDE/PCBSD supposed to recognize the two different
 monitors and set them up separately?<br>> <br>>       What I want is to have one program, say OpenOffice on one monitor, and FF3 on another.  Is that possible?<br>> <br>>       ...Jeff<br>> <br>> <br>> -----Inline Attachment Follows-----<br>> <br>> _______________________________________________<br>> Testing mailing list<br>> <a ymailto="mailto:Testing@lists.pcbsd.org" href="/mc/compose?to=Testing@lists.pcbsd.org"><a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a></a><br>> <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank"><a href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a></a><br>> <br>> <br>> !DSPAM:1,4a70df6015166305310327!<br>> �</div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a ymailto="mailto:Testing@lists.pcbsd.org" href="/mc/compose?to=Testing@lists.pcbsd.org"><a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a></a><br><a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank"><a href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a></a><br></div></blockquote></td></tr></tbody></table><br>

      </div></blockquote><blockquote type="cite"><div><span>_______________________________________________</span><br><span>Testing mailing list</span><br><span><a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a></span><br><span><a href="http://lists.pcbsd.org/mailman/listinfo/testing">http://lists.pcbsd.org/mailman/listinfo/testing</a></span><br></div></blockquote></body></html>