<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;">Awesome! Thanks for the fix.<br><br>Wasn't trying to bug you - just thought others should see the fix too as I doubt too many others monitor that list.<br><br>...Jeff<br><br>--- On <b>Mon, 7/13/09, Kris Moore <i>&lt;kris@pcbsd.org&gt;</i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"><br>From: Kris Moore &lt;kris@pcbsd.org&gt;<br>Subject: Re: [PC-BSD Testing] Open Office template errors<br>To: "PC-BSD Testing list" &lt;testing@lists.pcbsd.org&gt;<br>Date: Monday, July 13, 2009, 5:19 PM<br><br><div class="plainMail"><br>Jeff,<br><br>It takes a bit for me to get around to testing various things :) OpenOffice is a beast, so bear with us.<br><br>I did some digging, and I've found a workaround, not sure of a real bugfix yet though. Take a look at your<br>error you
 posted:<br><br>/usr/home/Jeff/.openoffice.org/3r/uno_packages/cache/uno_packages/yTznki_/OOOP-templates-separated-en-US-2.6.0.2.oxt/template/en-US/forms/Confidentiality_Agreement.ott does not exist<br><br>I installed a template package, and had the exact same error. So I delved into the .openoffice.org directory, and found the<br>directory "openoffice.org/3r/" doesn't exist. I created a symlink from openoffice.org/3 -&gt; openoffice.org/3r. Then I cd to 3r, and noticed that "uno_packages" doesn't exist, its under user/uno_packages. I went ahead and made another sym-link in /home/kris/.openoffice.org/3r/:<br><br> # ln -s `pwd`/user/uno_packages uno_packages<br><br>Then I booted up openoffice, and viola! I can see all the templates and use them just fine. So for some reason in the OpenOffice<br>extension manager, when it extracts / installs, it uses a weird path, which doesn't exist in the home profile.<br><br>We'll have to dig into OO source (shudder) to
 figure out why this is bugged.<br><br>In the meantime, you can use this workaround, and your templates should magically begin working again.<br><br><br>--<br>Kris Moore<br>PC-BSD Software<br><br>On Mon, 13 Jul 2009, Jeff wrote:<br><br>&gt; Nobody monitoring pbi-bugs?<br>&gt; <br>&gt; Reposting here as others may want to test this.<br>&gt; -------------------------<br>&gt; I was successful at importing some template pack extensions in the new Open Office release, but trying to access the templates results in<br>&gt; this error:<br>&gt; <br>&gt; Error creating a new document:<br>&gt; /usr/home/Jeff/.openoffice.org/3/user/template&nbsp; does not exist.<br>&gt; <br>&gt; So I created that directory but then received another error when trying to open a template:<br>&gt; <br>&gt; Error creating a new document:<br>&gt;
 /usr/home/Jeff/.openoffice.org/3r/uno_packages/cache/uno_packages/yTznki_/OOOP-templates-separated-en-US-2.6.0.2.oxt/template/en-US/forms/C<br>&gt; onfidentiality_Agreement.ott does not exist.<br>&gt; <br>&gt; Ditto for all templates - the error persists, indexing through all the available templates.<br>&gt; <br>&gt; !DSPAM:1,4a5b9499825691367518398!<br>&gt; �</div><br>-----Inline Attachment Follows-----<br><br><div class="plainMail">_______________________________________________<br>Testing mailing list<br><a ymailto="mailto:Testing@lists.pcbsd.org" href="/mc/compose?to=Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br><a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></div></blockquote></td></tr></table><br>