<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;"><div id="yiv938539985">Well, it now runs, sort of...<br><br>BTW, just received a system update notice that GE version 4.xxx was available which is the same as the one I had already, but the file I just got from you was version 5.xxx.<br><br>GE used to work in KDE3, eons ago but I think Google Earth is more demanding of the video card and drivers nowadays.&nbsp; Got this message from X:<br><br><div style="margin-left: 40px;">Google Earth could not access your video card.<br></div><br><div style="margin-left: 40px;">1) "The graphics card isn't powerful enough - you need 16MB VRAM"<br>2) "The machine does not have the graphics card drivers installed correctly"<br></div><br>From Google Earth Help:<br><br><p style="margin-left: 40px;">Regarding Linux, Google Earth has been tested on Ubuntu version
6.06, but certainly works on others. Hardware requirements include: </p>
  <ul style="margin-left: 40px;"><li>CPU: 500Mhz, Pentium 3 </li><li>System Memory (RAM): 256MB RAM </li><li>Hard Disk: 500MB free space </li><li>Network Speed: 128 Kbits/sec </li><li>Graphics Card: 3D-capable with 16MB of VRAM </li><li>Screen: 1024x768, "16-bit High Color" screen"</li></ul>
    
  <p style="margin-left: 40px;">Please
make sure your system has properly-configured OpenGL drivers. If Google
Earth appears to be slow and unresponsive, it is likely that your
system needs different video drivers. <br></p><p style="margin-left: 40px;"><br></p><p>Video card is an ATI Radeo 9000-64M (RV250).&nbsp; I chose the generic ATI driver I believe.&nbsp; I have seen various posts from people with this card having to tinker with driver settings to get 3D to work.</p><p><br></p><p>From xorg.conf:</p><p><br></p><p style="margin-left: 40px;">Section "Device"<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "Card0"<br>&nbsp;&nbsp;&nbsp; Screen&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 0<br>&nbsp;&nbsp;&nbsp; Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "ati"<br>&nbsp;&nbsp;&nbsp; VendorName&nbsp;&nbsp;&nbsp;&nbsp; "ATI Video Driver"<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "CPPIOMode" "yes" <br>&nbsp;&nbsp;&nbsp; BusID&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "PCI:1:0:0"<br>EndSection</p><p style="margin-left: 40px;"><br></p><p style="margin-left:
 40px;">Section "Module"<br>&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "ddc"<br>&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "dbe"<br>#&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; "dri"<br>&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "extmod"<br>#&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; "glx"<br>&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "xtrap"<br>&nbsp;&nbsp;&nbsp; Load&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "freetype"<br>EndSection</p><p style="margin-left: 40px;"><br></p><p>----------------------</p><p>GE spit out this error message too:</p><p>------------------------</p><p><br></p><p><br></p><p style="margin-left: 40px;">Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension"
 missing on display ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension" missing on display
 ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".<br>terminate called after throwing an instance of 'QString'<br>Google Earth has caught signal 6.<br><br>Stacktrace from glibc:<br>&nbsp; ./googleearth-bin [0x806c3a3]<br>&nbsp; ./googleearth-bin [0x806c916]<br>&nbsp; /Programs/GoogleEarth5.0.11337.1968_1/lib/libpthread.so.0 [0x294c8706]<br>&nbsp; [0xbfbfffbb]<br>&nbsp; /Programs/GoogleEarth5.0.11337.1968_1/lib/libpthread.so.0(raise+0x1f) [0x294c4f03]<br>&nbsp; /Programs/GoogleEarth5.0.11337.1968_1/lib/libc.so.6(gsignal+0x36) [0x293c3cae]<br>&nbsp; /Programs/GoogleEarth5.0.11337.1968_1/lib/libc.so.6(abort+0xdd) [0x293c4fe1]<br>&nbsp; ./libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x179) [0x28168019]<br>&nbsp; ./libstdc++.so.6 [0x281659a5]<br>&nbsp;
 ./libstdc++.so.6 [0x281659e2]<br>&nbsp; ./libstdc++.so.6 [0x28165b4a]<br>&nbsp; ./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evll3APIE+0x34e) [0x29ed257e]<br>&nbsp; ./librender.so(_ZN5earth6render12RenderWindow12createWidgetEv+0xb2) [0x29eb3f62]<br>&nbsp; ./libgoogleearth_lib.so(_ZN5earth6client12ModuleWidget9showEventEP10QShowEvent+0x8e) [0x29318f6e]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x7cf) [0x2851515f]<br>&nbsp; ./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xa8) [0x284d3130]<br>&nbsp; ./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x122) [0x284da916]<br>&nbsp; ./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x9a) [0x282a62f2]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x11f) [0x28517fc3]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7b) [0x28517d0f]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x15c)
 [0x28517e98]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x146) [0x28517e82]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7b) [0x28517d0f]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x15c) [0x28517e98]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x146) [0x28517e82]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x146)
 [0x28517e82]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x146) [0x28517e82]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x146) [0x28517e82]<br>&nbsp; ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x42) [0x28517ee6]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x285184bb]<br>&nbsp; ./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x4a) [0x2850d80e]<br>&nbsp; ./libgoogleearth_lib.so(_ZN10MainWindow18readScreensizeInfoEv+0xbfa) [0x292ea6ca]<br>&nbsp; ./libgoogleearth_lib.so(_ZN5earth6client11Application12SetupMainWinERK7QStringb+0x1f0) [0x293527d0]<br>&nbsp;
 ./libgoogleearth_lib.so(_ZN5earth6client11Application3runEv+0x300) [0x29355140]<br>&nbsp; ./googleearth-bin(main+0x2ba) [0x806da3a]<br>&nbsp; /Programs/GoogleEarth5.0.11337.1968_1/lib/libc.so.6(__libc_start_main+0x8f) [0x293b12e7]<br>&nbsp; ./googleearth-bin [0x806bb31]<br><br><br><br><br>We apologize for the inconvenience, but Google Earth has crashed.<br>&nbsp;This is a bug in the program, and should never happen under normal<br>&nbsp;circumstances. A bug report and debugging data are now being written<br>&nbsp;to this text file:<br><br>&nbsp;&nbsp;&nbsp; /home/Jeff/.googleearth/crashlogs/crashlog-82A85C5D.txt<br><br>This bug report will be sent to Google automatically next time you run<br>&nbsp;Google Earth. Its data, which contains no personal information, will help<br>&nbsp;us correct problems without bothering you further. If you would rather<br>&nbsp;this info not be transmitted, please delete the above file before running<br>&nbsp;the program
 again. If you want bug reports to NEVER be sent, remove the<br>&nbsp;above 'crashlogs' directory's read/write permissions.<br><br>Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".<br>Xlib:&nbsp; extension "Generic Event Extension" missing on display ":0.0".</p><p>-----------------------------------------------------</p><p><br></p>I un-commented the load lines in etc/xorg.conf:<br><br>Load&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; "dri"<br>Load&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; "glx"<br><br>But that didn't help (after reboot).<br><br>Found this from a Linux user with the same card:<br><br>http://www.linuxquestions.org/questions/debian-26/finally-got-3d-in-debian-lenny-with-a-radeon-9000-639869/?highlight=ati+radeon+lenny<br><br>Looks like a different driver.<br><br>I can update the <a href="http://www.freshports.org/x11-drivers/xf86-video-ati/">ATI Xorg driver from ports</a> (is this the latest?)<br>I doubt this is the problem
 though.<br><br>How do I do it for the PCBSD system?<br><br>Looks like the driver is here: /PCBSD/local/lib/xorg/modules/drivers (dated 3/31/09)<br><br>...Jeff<br><br><br><br>--- On <b>Wed, 4/29/09, Kris Moore <i>&lt;kris@pcbsd.com&gt;</i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;">From: Kris Moore &lt;kris@pcbsd.com&gt;<br>Subject: Re: [PC-BSD Testing] Runports stopped working<br>To: dejamuse@yahoo.com, "PC-BSD Testing list" &lt;testing@lists.pcbsd.org&gt;<br>Date: Wednesday, April 29, 2009, 9:41 AM<br><br><pre>Jeff wrote:<br>&gt; For some unknown reason, I can no longer use Runports either as root or<br>user.  It tries to start and then nothing.<br>&gt; <br>&gt; Can no longer start the PBI launcher by<br> clicking on the file while in<br>Konqueror (as root) either.<br>&gt; <br>&gt; I may inadvertently have used the regular konsole to install a port, but<br>that shouldn't affect
 anything, right?  I think I installed pgcalc2 from<br>package on the regular konsole, and as a matter of fact it's acting up too.<br>&gt; <br>&gt; Can you briefly explain just exactly what Runports.sh does?<br>&gt; <br>&gt; What happens if I build the portsnap ports tree and not use Runports?<br>&gt; <br>&gt; What's up with Konqueror and PBIs?<br>&gt; <br>&gt; Tnx, Jeff<br><br><br>Jeff,<br><br>Do you get any sort of error when you try to use runports? If you look at it,<br>its just a simple shell script which sets / unsets a few variables and calls<br>tcsh.<br><br>/PCBSD/Scripts/runports.sh<br><br>Also, is konq installing PBIs when running as user, or still failing? What<br>about dolphin?<br><br><br>-- <br>Kris Moore<br>PC-BSD<br> Software<br>http://www.pcbsd.com<br></pre></blockquote></div></td></tr></table><br>