<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
</head>
<body bgcolor="#ffffff" text="#000000">
Hello everybody!<br>
Seems we have a problem either with kde(dolphin) or with pcbsd scripts.<br>
<br>
ntfs-3g dropped parameter -C=UTF-8, in 2009.1.1 version;<br>
dolphin on non-eng systems still tries to mount with this option;<br>
ntfs-3g will not mount when this specified.<br>
I see solution to make a wrapper for ntfs-3g script, which simply drops
-C=UTF-8 and translates all other params to ntfs-3g.real<br>
Kris?<br>
Could you a bit experimenting with non-eng system?<br>
<br>
About mounting cd - there probably different thing, I'll dig into this
a bit later.<br>
<br>
<br>
-------- Original Message --------
<table class="moz-email-headers-table" border="0" cellpadding="0"
 cellspacing="0">
  <tbody>
    <tr>
      <th align="RIGHT" nowrap="nowrap" valign="BASELINE">Subject: </th>
      <td>Re: HAL issue</td>
    </tr>
    <tr>
      <th align="RIGHT" nowrap="nowrap" valign="BASELINE">Date: </th>
      <td>Wed, 08 Apr 2009 03:08:33 -0400</td>
    </tr>
    <tr>
      <th align="RIGHT" nowrap="nowrap" valign="BASELINE">From: </th>
      <td>Joe Marcus Clarke <a class="moz-txt-link-rfc2396E" href="mailto:marcus@FreeBSD.org">&lt;marcus@FreeBSD.org&gt;</a></td>
    </tr>
    <tr>
      <th align="RIGHT" nowrap="nowrap" valign="BASELINE">Organization:
      </th>
      <td>FreeBSD, Inc.</td>
    </tr>
    <tr>
      <th align="RIGHT" nowrap="nowrap" valign="BASELINE">To: </th>
      <td><a class="moz-txt-link-abbreviated" href="mailto:yerenkow@uct.ua">yerenkow@uct.ua</a> <a class="moz-txt-link-rfc2396E" href="mailto:yerenkow@uct.ua">&lt;yerenkow@uct.ua&gt;</a></td>
    </tr>
  </tbody>
</table>
<br>
<br>
<pre>On Wed, 2009-04-08 at 09:58 +0300, <a class="moz-txt-link-abbreviated" href="mailto:yerenkow@uct.ua">yerenkow@uct.ua</a> wrote:
&gt; Joe Marcus Clarke wrote:
&gt; &gt; On Wed, 2009-04-08 at 09:22 +0300, <a class="moz-txt-link-abbreviated" href="mailto:yerenkow@uct.ua">yerenkow@uct.ua</a> wrote:
&gt; &gt;   
&gt; &gt;&gt; On 08.04.2009 1:18, Joe Marcus Clarke wrote:
&gt; &gt;&gt;     
&gt; &gt;&gt;&gt; On Tue, 2009-04-07 at 22:49 +0300, <a class="moz-txt-link-abbreviated" href="mailto:yerenkow@uct.ua">yerenkow@uct.ua</a> wrote:
&gt; &gt;&gt;&gt;   
&gt; &gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt; Joe Marcus Clarke wrote:
&gt; &gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt; A.Yerenkow wrote:
&gt; &gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt; On 07.04.2009 22:00, Joe Marcus Clarke wrote:
&gt; &gt;&gt;&gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; <a class="moz-txt-link-abbreviated" href="mailto:yerenkow@uct.ua">yerenkow@uct.ua</a> wrote:
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;               
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; Hello guys!
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; I'm not in list, so, please reply to me too.
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; I've issues with hald on pc-bsd.
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; It's regular when have russian language, and labeled ntfs/cd drive.
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; when I click to mount in dolphin, nothing happens, only such records
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; added to /media/.hal-mtb:
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /dev/ad0s5s1    1001    0       ntfs    nosuid,-u=1001,-C=UTF-8
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /media/disk-2
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /dev/ad0s5s1    1001    0       ntfs    nosuid,-u=1001,-C=UTF-8
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /media/disk-3
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /dev/ad0s5s1    1001    0       ntfs    nosuid,-u=1001,-C=UTF-8
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /media/disk-4
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /dev/ad0s5s1    1001    0       ntfs    nosuid,-u=1001,-C=UTF-8
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /media/disk-5
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /dev/ad0s5s1    1001    0       ntfs    nosuid,-u=1001,-C=UTF-8
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; /media/disk-6
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;      
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;                 
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; I don't see any /dev/ad0s5s1 device in lshal or in GEOM.  This looks
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; like a problem with whatever KDE is using to mount the device.  If KDE
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; were to try and mount /dev/ntfs/stuff, it should work.  In fact, you
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; could test that using gnome-mount which will do the mount via hald:
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; gnome-mount -b -n -v --device /dev/ntfs/stuff
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt; Joe
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;    
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt;&gt;               
&gt; &gt;&gt;&gt;&gt;&gt;&gt; Thanks Joe, I tried this command and it mounts OK.
&gt; &gt;&gt;&gt;&gt;&gt;&gt; but! In /media/.hal-mtab in records no parameter for encoding, only for
&gt; &gt;&gt;&gt;&gt;&gt;&gt; nosuid.
&gt; &gt;&gt;&gt;&gt;&gt;&gt; And one more thing, if dolphin from KDE tries to mount with something
&gt; &gt;&gt;&gt;&gt;&gt;&gt; different from hald, why is these records
&gt; &gt;&gt;&gt;&gt;&gt;&gt; in /media/.hal-mtab appears?
&gt; &gt;&gt;&gt;&gt;&gt;&gt; which command place it there?
&gt; &gt;&gt;&gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt; I don't know.  I don't know what dolphin is or what it is doing to try
&gt; &gt;&gt;&gt;&gt;&gt; and mount volumes.
&gt; &gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt; Joe, I'm not quite familiar with hal, is there somewhere described
&gt; &gt;&gt;&gt;&gt;&gt;&gt; life-cycle of hal-mounted disks?
&gt; &gt;&gt;&gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt; The only document we have produced is the hal FAQ at
&gt; &gt;&gt;&gt;&gt;&gt; <a class="moz-txt-link-freetext" href="http://www.freebsd.org/gnome/docs/halfaq.html">http://www.freebsd.org/gnome/docs/halfaq.html</a> .
&gt; &gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt; If this really KDE-related issue, could you help me to make a report for
&gt; &gt;&gt;&gt;&gt;&gt;&gt; kde maintainers@ freebsd?
&gt; &gt;&gt;&gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt; <a class="moz-txt-link-abbreviated" href="mailto:kde@freebsd.org">kde@freebsd.org</a>
&gt; &gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt;&gt;&gt; Wha info I should provide them?
&gt; &gt;&gt;&gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt;&gt;&gt;&gt;             
&gt; &gt;&gt;&gt;&gt;&gt; Probably the same info provided here.  Since gnome-mount works, it looks
&gt; &gt;&gt;&gt;&gt;&gt; like PolicyKit and hald are working properly.  I would imagine the
&gt; &gt;&gt;&gt;&gt;&gt; problem revolves around that bogus device node.  I've not sure how KDE
&gt; &gt;&gt;&gt;&gt;&gt; is arriving at that.
&gt; &gt;&gt;&gt;&gt;&gt;
&gt; &gt;&gt;&gt;&gt;&gt; Joe
&gt; &gt;&gt;&gt;&gt;&gt;   
&gt; &gt;&gt;&gt;&gt;&gt;       
&gt; &gt;&gt;&gt;&gt;&gt;           
&gt; &gt;&gt;&gt;&gt; One more thing, if I run this command :
&gt; &gt;&gt;&gt;&gt; gnome-mount -b -n -v -o C=UTF-8 --device /dev/ntfs/stuff
&gt; &gt;&gt;&gt;&gt;     
&gt; &gt;&gt;&gt;&gt;         
&gt; &gt;&gt;&gt; This option is not allowed for NTFS file systems.  The option needs to
&gt; &gt;&gt;&gt; be -C=UTF-8.
&gt; &gt;&gt;&gt;
&gt; &gt;&gt;&gt;   
&gt; &gt;&gt;&gt;       
&gt; &gt;&gt; Ok then, I think that's the case.
&gt; &gt;&gt; If I provide option "-C=UTF-8", the record appears in /media/.hal-mtab 
&gt; &gt;&gt; file,
&gt; &gt;&gt; but nothing mounts - behaviour just like dolphin have.
&gt; &gt;&gt;     
&gt; &gt;
&gt; &gt; What happens if you manually run:
&gt; &gt;
&gt; &gt; /sbin/mount -t ntfs -o nosuid,-u=1001,-C=UTF-8 /dev/ntfs/stuff /mnt
&gt; &gt;
&gt; &gt; Joe
&gt; &gt;   
&gt; root@pcbsd# /sbin/mount -t ntfs -o nosuid,-u=1001,-C=UTF-8 /dev/ntfs/stuff /mnt
&gt; 
&gt; ntfs-3g: Unknown option '-C'.
&gt; Please type 'ntfs-3g --help' for more information.
&gt; 
&gt; help and man didn't say a word about -C
&gt; I think it's related to
&gt; <a class="moz-txt-link-freetext" href="http://ntfs-3g.org/releases.html">http://ntfs-3g.org/releases.html</a>
&gt; TABLE Version 2009.1.1 (January 22, 2009) -- Release Notes
&gt; Change: The 'locale=' mount option is not used anymore for filename 
&gt; characterset conversion. Instead filenames are always converted to UTF-8.

Okay, so PC-BSD replaced mount with a shell script which calls the fuse
mount.  It looks like you should just leave -C out, but you might want
to ask on a PC-BSD list/forum.  I worked with Kris Moore to better
integrate ntfs-3g with hal, and I know it was working.  But I don't use
NTFS, so I can't really say what if anything you should be doing in
PC-BSD to make it work.

Joe

&gt; 
&gt; 
&gt; &gt;&gt; debug output of manually runned hald provided in attachment.
&gt; &gt;&gt;     
&gt; &gt;&gt;&gt; Joe
&gt; &gt;&gt;&gt;
&gt; &gt;&gt;&gt;   
&gt; &gt;&gt;&gt;       
&gt; &gt;&gt; plain text document attachment (hald2.txt)
&gt; &gt;&gt; 09:16:34.829 [I] hald.c:864: Device probing completed
&gt; &gt;&gt; 09:16:34.829 [I] hald_dbus.c:5834: entering
&gt; &gt;&gt; hald-addon-storage info: Checking whether device /dev/da0 is locked by HAL
&gt; &gt;&gt; hald-addon-storage info: ... device /dev/da0 is not locked by HAL
&gt; &gt;&gt; 09:16:41.216 [I] hald_dbus.c:5127: OK for method 'Mount' with signature 'ssas' on interface 'org.freedesktop.Hal.Device.Volume' for UDI '/org/freedesktop/Hal/devices/volume_uuid_866067FC6067F17B' andexecpath 'hal-storage-mount'
&gt; &gt;&gt; 09:16:41.216 [I] hald_dbus.c:4018: no need to enqueue
&gt; &gt;&gt; 09:16:41.461 [I] device.c:1894: Removing locks from ':1.89'
&gt; &gt;&gt; 09:16:41.921 [I] device.c:1894: Removing locks from ':1.88'
&gt; &gt;&gt; 09:16:41.923 [I] hald_dbus.c:4042: No more methods in queue
&gt; &gt;&gt; 09:16:41.953 [I] ci-tracker.c:212: Removing CICallerInfo object for :1.86
&gt; &gt;&gt; 09:16:41.953 [I] device.c:1894: Removing locks from ':1.86'
&gt; &gt;&gt; 09:16:56.232 [W] util_pm.c:116: chargeRate, chargeLevel or chargeLastFull &lt; 0, returning -1
&gt; &gt;&gt;     
&gt; 
&gt; 
-- 
Joe Marcus Clarke
FreeBSD GNOME Team      ::      <a class="moz-txt-link-abbreviated" href="mailto:gnome@FreeBSD.org">gnome@FreeBSD.org</a>
FreeNode / #freebsd-gnome
<a class="moz-txt-link-freetext" href="http://www.FreeBSD.org/gnome">http://www.FreeBSD.org/gnome</a>

</pre>
</body>
</html>