KenD said, "Perhaps I am expecting too much coming from OpenBSD, but a number of ports do not seem to properly fetch prerequisites [e.g. see below].<br><br>autom4te: need GNU m4 1.4 or later: /usr/local/bin/gm4<br>gmake[2]: *** [<a href="http://autoconf.in">autoconf.in</a>] Error 1<br>
gmake[2]: Leaving directory<br>`/usr/ports/devel/autoconf262/work/autoconf-2.62/bin'<br>gmake[1]: *** [all-recursive] Error 1<br>gmake[1]: Leaving directory `/usr/ports/devel/autoconf262/work/autoconf-2.62'<br>gmake: *** [all] Error 2<br>
*** Error code 2<br>Stop in /usr/ports/devel/autoconf262.<br>*** Error code 1<br>Stop in /usr/ports/lang/guile.<br><br><br>Can some kind soul help me out here?<br><br>Thanks much, -KenD<br><br>and Brian said, "Ports are broken completely for me with this beta."<br>
=========================================================================<br><br>Ken - Yes.  Brian - Not true.<br><br>Ken, I had the same problem, especially w/ autoconf262 spawning an error, until Kris Moore provided this solution that sets some environmental variables in order to ensure ports build properly.<br>
<br>1.  Run the "runports" command [Kmenu -> System -> RunPorts (root)]<br>2.  At the root prompt, type make and hit Enter<br>3.  Kris also advised that the make command runs through the many installed packages and will pause on almost every one and presents a blue screen reminiscent of sysinstall in order to let you customize the settings and components.  That makes the process a lengthy one.  You can avoid this e blue options screen with an edit (as root) to /etc/make.conf.  Uncomment BATCH=yes, this makes it take all the defaults. Also through the "makeports" option, you can use pkg_add if you like at the same time. You'll want to refer to the FreeBSD docs for usage on this.<br>
<br>After running this commands, you will find that ports installs fine.<br><br>Ian Robinson<br>Salem, Ohio<br><br>