<pre>Re: 7.1Alpha_x to install ports because of &quot;need GNU m4 1.4 or later: /usr/local/bin/gm4&quot;, it was said:<br><br>&quot;The problem installing ports in 7.1 should be fixed for 7.1-BETA1 and later. We had to write a small feature for FreeBSD  in order for it to work with two LOCALBASE variables properly, it was issues with ldconfig and ld-elf.so causing it to fail usually. That fix will be in the next ISO :)&quot;<br>
<br><br>The problem still exists:<br><br>root@pcbsd# cd /usr/ports/multimedia/kaffeine &amp;&amp; make install clean<br>===&gt;   kaffeine-0.8.7_2 depends on file: /usr/local/bin/moc - not found<br>===&gt;    Verifying install for /usr/local/bin/moc in /usr/ports/x11-toolkits/qt33<br>
===&gt;   qt-3.3.8_9 depends on executable: qmake - found                          <br>===&gt;   qt-3.3.8_9 depends on file: /usr/local/libdata/pkgconfig/inputproto.pc - found<br>===&gt;   qt-3.3.8_9 depends on file: /usr/local/libdata/pkgconfig/xinerama.pc - found  <br>
===&gt;   qt-3.3.8_9 depends on file: /usr/local/libdata/pkgconfig/sm.pc - not found<br>===&gt;    Verifying install for /usr/local/libdata/pkgconfig/sm.pc in /usr/ports/x11/libSM<br>===&gt;   libSM-1.1.0_1,1 depends on file: /usr/local/share/aclocal/xorg-macros.m4 - found<br>
===&gt;   libSM-1.1.0_1,1 depends on file: /usr/local/libdata/pkgconfig/xtrans.pc - found<br>===&gt;   libSM-1.1.0_1,1 depends on file: /usr/local/libdata/pkgconfig/ice.pc - found<br>===&gt;   libSM-1.1.0_1,1 depends on file: /usr/local/libdata/pkgconfig/xproto.pc - found<br>
===&gt;   libSM-1.1.0_1,1 depends on file: /usr/local/bin/automake-1.10 - not found<br>===&gt;    Verifying install for /usr/local/bin/automake-1.10 in /usr/ports/devel/automake110<br>===&gt;   automake-1.10.1 depends on file: /usr/local/bin/perl5.8.9 - found<br>
===&gt;   automake-1.10.1 depends on file: /usr/local/bin/autoconf-2.62 - not found<br>===&gt;    Verifying install for /usr/local/bin/autoconf-2.62 in /usr/ports/devel/autoconf262<br>===&gt;  Building for autoconf-2.62<br>
gmake  all-recursive<br>gmake[1]: Entering directory `/usr/ports/devel/autoconf262/work/autoconf-2.62&#39;<br>Making all in bin<br>gmake[2]: Entering directory `/usr/ports/devel/autoconf262/work/autoconf-2.62/bin&#39;<br>
autom4te_perllibdir=&#39;..&#39;/lib AUTOM4TE_CFG=&#39;../lib/autom4te.cfg&#39;         ../bin/autom4te -B &#39;..&#39;/lib -B &#39;..&#39;/lib         --language M4sh --cache &#39;&#39; --melt ./<a href="http://autoconf.as">autoconf.as</a> -o <a href="http://autoconf.in">autoconf.in</a><br>
autom4te: need GNU m4 1.4 or later: /usr/local/bin/gm4<br>gmake[2]: *** [<a href="http://autoconf.in">autoconf.in</a>] Error 1<br>gmake[2]: Leaving directory `/usr/ports/devel/autoconf262/work/autoconf-2.62/bin&#39;<br>gmake[1]: *** [all-recursive] Error 1<br>
gmake[1]: Leaving directory `/usr/ports/devel/autoconf262/work/autoconf-2.62&#39;<br>gmake: *** [all] Error 2<br>*** Error code 2<br><br>Stop in /usr/ports/devel/autoconf262.<br>*** Error code 1<br><br>Stop in /usr/ports/devel/automake110.<br>
*** Error code 1<br><br><br>However, I am very happy to report that except in the few instances reported in the testing lists -- and it seems there is very little being reported -- 7.1 Beta is a very reliable and smooth system.<br>
<br><br>Ian Robinson<br>Salem, Ohio<br><br><br></pre><br><br>