<div dir="ltr">*upd*<br>After mounting my media with fat32 filesystem I&#39;ve got it at <b>/media/XPOD</b>; with FAT it was <b>/media/da0s1</b>.<br><br>*trying `<b>umount -f /media/XPOD</b>`*<br>The device folder in Dolphin is shown as empty now, no objects, no info. In Plasma quick-device-access there&#39;s still my XPOD displayed as a mounted device (can&#39;t see the <u>unmount</u> button tho). The player is still being chargin&#39; from the usb and it still shows that the player is connected to my laptop.<br>
<br>*created folder on the desktop called <b>xPod</b>, trying `<b>mount -t msdosfs /dev/da0s1 ~/Desktop/xPod</b>` now*<br>Eureka! It&#39;s alive! I&#39;m in <b>desktop:/xPod</b> atm, gonna transfer one song to it. I&#39;ll pick Shirley Mansons&#39; Samson and Delilah :)<br>
It&#39;s a 6.6mb mp3 file; transferring files using dolphin. It took about 8 seconds to transfer it to <b>desktop:/xPod/MUSIC</b> dir.<br><br>*and now*<br>I&#39;m clicking on dolphin&#39;s... oh no wait, there&#39;s no `safe remove` button anymore - it&#39;s on desktop so there&#39;re a list for places instead of it and folder&#39;s icon. Changing directory to <b>/media/XPOD/</b> (the link is in the bottom of my &#39;places&#39; list in dolphin).<br>
<br>*2 seconds later*<br>The location didn&#39;t change, it has shown me an error:<br><blockquote style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;" class="gmail_quote">An error ocurred while accessing &#39;XPOD&#39;, the system responded:<br>
org.freedesktop.Hal.Device.Volume.UnknownFailure: mount_msdosfs: /dev/msdosfs/XPOD: : No such file or directory</blockquote><div>(And actually there were a file with exact that name exact in that dir. <br></div><div><br>*trying to unmount the device manually as Brodey taught me*<br>
<b>[root@pcbsd ~]# umount -f /dev/da0s1</b></div><br>After doing this, I&#39;ve got my device unlinked from a desktop folder but now I can access to it through dolphin at <b>/media/XPOD-1</b><br>Now I&#39;m unmounting it throught dolphin&#39;s `<b>Unmount &#39;XPOD&#39;</b>` thingy.<br>
Player is still receiving power from my laptop and don&#39;t want to accept my actions like a disconnect.<br><br>*pluggin-off my usb wire from laptop, then from device*<br>Device is being rebooted now, I&#39;m gonna check the song.<br>
...<br>Same old thing - the track is lagging in the worst way, about til&#39; the first minute. Then there were a little &#39;clean part&#39; and then it has stopped playing so it&#39;s at 00:00 now.<br>Other songs are playing in the good way, they were transferred from windows machine after I&#39;ve formatted it with fat32 filesystem.<br>
<br>*Uh oh, Huh...*<br><br><div class="gmail_quote">On Wed, Oct 1, 2008 at 7:47 PM,  <span dir="ltr">&lt;<a href="mailto:pcfxer@rogers.com">pcfxer@rogers.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<table border="0" cellpadding="0" cellspacing="0"><tbody><tr><td style="font-family: inherit; font-style: inherit; font-variant: inherit; font-weight: inherit; font-size: inherit; line-height: inherit; font-size-adjust: inherit; font-stretch: inherit;" valign="top">
<br>I forget which sizes are affected, but it is important to mount that mount_msdosfs must have the &quot;-o large&quot; switch enabled. Most automounters will disregard a device plugged in that is too large, but this may be an issue with the Kauto mount.<br>
<br>Try -o large if mount -t... returns nothing. <br><br>Rgds,<br>Brodey<br><br>--- On <b>Wed, 10/1/08, Arthur Koziol <i>&lt;<a href="mailto:A-Koziol@neiu.edu" target="_blank">A-Koziol@neiu.edu</a>&gt;</i></b> wrote:<br><blockquote style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;">
From: Arthur Koziol &lt;<a href="mailto:A-Koziol@neiu.edu" target="_blank">A-Koziol@neiu.edu</a>&gt;<br>Subject: Re: [PC-BSD Testing] Removable media<br>To: &quot;PC-BSD Testing list&quot; &lt;<a href="mailto:testing@lists.pcbsd.org" target="_blank">testing@lists.pcbsd.org</a>&gt;<br>
Received: Wednesday, October 1, 2008, 1:25 PM<div><div></div><div class="Wj3C7c"><br><br><pre>&gt; &gt; Yesterday I&#39;ve mounted (only mounted - nothing more) my player<br>with FAT fs<br>&gt; &gt; to my laptop with PC-BSD and today, about
 15 mins ago I&#39;ve got<br>nullified<br>&gt; &gt; player. So it&#39;s not only working wrong, it even cracks my<br>flash-memory each<br>&gt; &gt; time I mount it. I&#39;m still gonna try that stuff u told me,<br>Brodey, but it&#39;s<br>
&gt; &gt; gonna be done at late night when I don&#39;t need to rush anywhere.<br>=\ And I&#39;m<br>&gt; &gt; an optimist too yeah.<br>&gt; &gt;<br>&gt;<br>&gt;<br>&gt;I&#39;ve been using some FAT formatted USB sticks here, and no problem so<br>
&gt;far. You are un-mounting them before unplugging it right? If you can<br>&gt;test it via the command-line as suggested, and confirm that it still<br>&gt;corrupts the FAT tables, we&#39;ll need to report this bug with details to<br>
&gt;the FreeBSD team right away:<br>&gt;<br>&gt;<a href="http://www.freebsd.org/send-pr.html" target="_blank">http://www.freebsd.org/send-pr.html</a><br>&gt;<br>&gt;Its possible that mount_msdosfs is buggy in this case?<br>
<br>Kris,<br><br>I&#39;ve been sort of loosely watching this thread. Is there any easy <br>test this to see if this is isolated
 perhaps to certain chipsets on <br>certain mothers boards (AMD chipset v. Intel v. NForce v. VIA, etc.) <br>that the rest of us can test and confirm? Typically, USB flash drives <br>UNDER 2GB will come out of the factory formatted to 2GB. Anything <br>
OVER 2GB has ot be FAT32 or some other size due to FATs 2GB ceiling. <br>I&#39;ve tried my 4GB and 8GB Sandisk drives with no loss or data error <br>but they are formatted FAT32. I have plenty of time to run some tests <br>
with USB drivers ranging from 128 FAT or FAT32 to 8GB FAT32 to play with.<br><br>Arthur <br><br>_______________________________________________<br>Testing mailing list<br><a href="mailto:Testing@lists.pcbsd.org" target="_blank">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br></pre></div></div></blockquote></td></tr></tbody></table><br>_______________________________________________<br>

Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br></blockquote></div><br></div>