Report on PCBSD 1.5 PBI Upgrade:<br><br>1.&nbsp; The PBI update from <a href="http://1.4.1.2">1.4.1.2</a> to 1.5 took 1 hour + 15 minutes on an HP Vectra VL420, 1.6 GHz, 1 Gb RAM.&nbsp; <br><br>The screen feedback is not very informative.&nbsp; While the accumlation of dots on the screen shows progress, you do not know that it will take seven+ (&gt;7) rows of dots to complete the &quot;Cleaning old packages&quot; section (30 minutes) and seven (7) rows of dots to complete &quot;Installing new packages&quot; (30 minutes).&nbsp; The &quot;Extracting new files,&quot; &quot;Installing new world environment,&quot; and &quot;Installing new kernel&quot; functions complete quickly after that.<br>
<br>In comparison to the PBI update method, a fresh install of all PBI&#39;s, ports, and source code on a Vectra VL400, 800 GHz, 512 Gb RAM took less than 30 minutes.&nbsp; However, restoring /usr/home/username from backup would take five to ten minutes and PBI installation of several PBI&#39;s would take longer. In conclusion, I think the time involved to reach the same point is about the same whether one does a fresh install of 1.5 or a 1.5 PBI upgrade.&nbsp; I can&#39;t say how much time it would take to reinstall the user&#39;s choice of ports, but they have to be reinstalled whether one does a fresh install or a PBI upgrade.<br>
<br>If I had to choose between the two, I think the fresh install offers more feedback, certainty, and comfort.&nbsp; Either way, it is necessary to backup critical data based upon your experience, common sense, and the adequate warnings PCBSD puts in the installation routines.<br>
<br><br>2.&nbsp; I had no video configuration problems.&nbsp; I had no mouse problems with an HP ps2 -- all buttons functioning normally. I had no problems with desktop icons.&nbsp; Audio (snd_ich) worked great.&nbsp; Video playback worked fine.<br>
<br>3.&nbsp; All packages and my pbi&#39;s were replaced successfully or survived the upgrade except Win4BSD.&nbsp; Although Win4BSD is installed via a PBI, and although it creates a directory in /Programs, Win4BSD puts its startup script in a non-standard directory -- /usr/local/lib/win4bsd/bin/ -- which does not survive the upgrade.&nbsp; Sterr output is:<br>
&nbsp;<br>/Programs/Win4BSD4.0-63936/winpro.sh: /usr/local/lib/win4bsd/bin/winpro-desktop.sh: not found<br><br>I had a backup of the Win4BSD virtual disk so I have lost nothing of consequence, and I believe a pbi reinstall is all that will be required.<br>
<br>4.&nbsp; PCBSD Update Manager updated part of the system ok.&nbsp; However, when it came to PBI updates, the Sylpheed PBI started to fetch the update, but stopped with an error message that the 2.4.8 version did not pass an integrity check.&nbsp; (This is probably a source code problem unrelated to the upgrade.)&nbsp; I skipped Sylpheed and continued to download the updates for Opera 9.26 &amp; K3B 1.0.4 which reported as successful.&nbsp; I could not find where the Opera &amp; K3B updates were downloaded or stored, and I did not see them perform an update to the programs.&nbsp; Opera and K3B still report the &quot;old&quot; version numbers in their &quot;About&quot; screens.&nbsp; Perhaps a reboot is required, which I have not done.<br>
<br>Because the PBI upgrades are not installed, the icon remains in its blue triangle state and reports that PBI updates are available.<br><br>5.&nbsp; Macs.&nbsp; PCBSD Developer support is responsive and responsible, even though the staff and resources are very thin compared to M$ or Apple.&nbsp; Whenever there are wide choices and combinations of hardware and software like in the PC world, there are bound to be hardware compatibility issues and software configuration problems.&nbsp; Macs have a great operating system, but they do not have a better operating system.&nbsp; I think Macs appear to work &quot;better&quot; only because Apple has restricted a user&#39;s choice of hardware and software, thereby eliminating the likelihood of compatibility and configuration.&nbsp; However, a Mac is a wonderful choice for those who can afford them.&nbsp; <br>
<br><br>Ian Robinson<br>Salem, Ohio<br><br><br><div class="gmail_quote">On Fri, Mar 14, 2008 at 1:24 PM,  &lt;<a href="mailto:testing-request@lists.pcbsd.org">testing-request@lists.pcbsd.org</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Send Testing mailing list submissions to<br>
 &nbsp; &nbsp; &nbsp; &nbsp;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a><br>
<br>
To subscribe or unsubscribe via the World Wide Web, visit<br>
 &nbsp; &nbsp; &nbsp; &nbsp;<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
or, via email, send a message with subject or body &#39;help&#39; to<br>
 &nbsp; &nbsp; &nbsp; &nbsp;<a href="mailto:testing-request@lists.pcbsd.org">testing-request@lists.pcbsd.org</a><br>
<br>
You can reach the person managing the list at<br>
 &nbsp; &nbsp; &nbsp; &nbsp;<a href="mailto:testing-owner@lists.pcbsd.org">testing-owner@lists.pcbsd.org</a><br>
<br>
When replying, please edit your Subject line so it is more specific<br>
than &quot;Re: Contents of Testing digest...&quot;<br>
<br>
<br>
Today&#39;s Topics:<br>
<br>
 &nbsp; 1. 1.5 update (mouse bug, etc) (Rod Clark)<br>
 &nbsp; 2. Broken GTK engine (Qt) message (Rod Clark)<br>
 &nbsp; 3. Re: Broken GTK engine (Qt) message (Rod Clark)<br>
 &nbsp; 4. Re: 1.5 update (mouse bug, etc) (Kris Moore)<br>
 &nbsp; 5. Re: Broken GTK engine (Qt) message (Kris Moore)<br>
 &nbsp; 6. Video drivers settings problems (Rod Clark)<br>
 &nbsp; 7. Checking ports a la portsnap (Rod Clark)<br>
 &nbsp; 8. Re: Broken GTK engine (Qt) message (Terry Poulin)<br>
<br>
<br>
----------------------------------------------------------------------<br>
<br>
Message: 1<br>
Date: Fri, 14 Mar 2008 08:01:33 +0000 (UTC)<br>
From: Rod Clark &lt;<a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a>&gt;<br>
Subject: [PC-BSD Testing] 1.5 update (mouse bug, etc)<br>
To: <a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a><br>
Message-ID: &lt;<a href="mailto:Pine.NEB.4.64.0803140640150.15796@faeroes.freeshell.org">Pine.NEB.4.64.0803140640150.15796@faeroes.freeshell.org</a>&gt;<br>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed<br>
<br>
Kris,<br>
<br>
Mouse bug:<br>
After I installed the 1.5 update PBI today, my mouse<br>
involuntarily changed from left handed to right handed, and I<br>
can&#39;t set it back again. KDE Peripherals/Mouse still showed left<br>
hand settings, but it operated as a right hand mouse. I set it<br>
to right hand operation, and then back back to left hand again,<br>
with no effect. I can use the mouse equally well with either<br>
hand, but this appears to be a bug. The mouse is a commonplace<br>
Logitech M-SBF90 optical mouse. I was running <a href="http://1.4.1.2" target="_blank">1.4.1.2</a> before the<br>
upgrade.<br>
<br>
<br>
PBI updates (icon updating, minor):<br>
The Filezilla update PBI that I ran from the new Installer icon<br>
on the panel deleted my Filezilla desktop icon. When I picked<br>
Copy to Desktop from Filezilla on the K start menu, the icon<br>
reappeared in the same spot as the old Filezilla icon on the<br>
desktop.<br>
<br>
The Wine update PBI deleted my Wine Config desktop icon, but<br>
when I copied the icon to the desktop again, it bypassed its old<br>
location and went to a new spot, at the far left of a new row<br>
below all the other icons on the desktop.<br>
<br>
The Firefox <a href="http://2.0.0.12" target="_blank">2.0.0.12</a> update PBI replaced Firefox <a href="http://2.0.0.11" target="_blank">2.0.0.11</a>, but<br>
afterwards my Firefox panel icon (which it didn&#39;t delete) didn&#39;t<br>
work. It still pointed to the old <a href="http://2.0.0.11" target="_blank">2.0.0.11</a> PBI location. I<br>
manually updated the path in the Properties section of the panel<br>
icon.<br>
<br>
<br>
Time taken to update:<br>
60 minutes, on an Athlon 2200+ system with 2 GB memory and a<br>
200GB SATA drive.<br>
<br>
<br>
Port updates:<br>
As far as I know, the ports in 1.5 are the same (FreeBSD 6.3) as<br>
I was using with <a href="http://1.4.1.2" target="_blank">1.4.1.2</a>. My ports tree was up to date with<br>
portsnap. The update nevertheless erased my editor, my Web<br>
server (lighttpd, php, mysql and other things), gimpshop and a<br>
laundry list of installed ports that it will take many hours to<br>
reinstall.<br>
<br>
This is one of the two reasons (the other is limited hardware<br>
compatibility) that I have given up recommending PC-BSD to<br>
anyone who isn&#39;t a serious techie any more, even though I&#39;m<br>
happy to use it myself. Many users will still need to install<br>
software from ports with the inevitable minor glitches and<br>
hassles that entails. After they&#39;ve puzzled out how to install<br>
some ports, or gotten help from a techie family member to do<br>
that, along comes a friendly GUI update and this happens to<br>
them. I&#39;m willing to put in the hours to clean up after this PBI<br>
update, but believe me, I won&#39;t wish PC-BSD on my family or<br>
friends who use Macs.<br>
<br>
-rsc<br>
<br>
<br>
------------------------------<br>
<br>
Message: 2<br>
Date: Fri, 14 Mar 2008 13:03:38 +0000 (UTC)<br>
From: Rod Clark &lt;<a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a>&gt;<br>
Subject: [PC-BSD Testing] Broken GTK engine (Qt) message<br>
To: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID: &lt;<a href="mailto:Pine.NEB.4.64.0803141254100.24943@faeroes.freeshell.org">Pine.NEB.4.64.0803141254100.24943@faeroes.freeshell.org</a>&gt;<br>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed<br>
<br>
Kris,<br>
<br>
Another small note on 1.5:<br>
<br>
After installing Audacious (an audio player) from ports using<br>
the defaults (well, except that I enabled FLAC), I see the<br>
following message when it starts:<br>
<br>
&quot;Broken GTK engine in use<br>
Audacious has detected that you are using a broken GTK engine.<br>
The theme engine you are using, Qt is incompatible with some of<br>
the features used by modern skins. The incompatible features<br>
have been disabled for this session.<br>
To use these features, please consider using a different GTK<br>
theme engine.<br>
( ) Do not display this warning again<br>
[Close]&quot;<br>
<br>
<br>
Overall, things are mostly going well with it.<br>
Thanks,<br>
<br>
-rsc<br>
<br>
<br>
------------------------------<br>
<br>
Message: 3<br>
Date: Fri, 14 Mar 2008 13:35:55 +0000 (UTC)<br>
From: Rod Clark &lt;<a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a>&gt;<br>
Subject: Re: [PC-BSD Testing] Broken GTK engine (Qt) message<br>
To: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID: &lt;<a href="mailto:Pine.NEB.4.64.0803141329480.1387@faeroes.freeshell.org">Pine.NEB.4.64.0803141329480.1387@faeroes.freeshell.org</a>&gt;<br>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed<br>
<br>
&gt; &quot;Broken GTK engine in use<br>
<br>
Kris,<br>
<br>
There&#39;s more to this than I thought. When I ran it, Audacious<br>
played sound choppily, playing for about 4/5 second and then<br>
blanking for 1/5 second. That&#39;s with nothing else running - I<br>
turned off Folding at Home, which normally has no effect on it<br>
anyway. Kplayer and Kaffeine play videos that sound normal. OK,<br>
I&#39;m baffled.<br>
<br>
-rsc<br>
<br>
<br>
------------------------------<br>
<br>
Message: 4<br>
Date: Fri, 14 Mar 2008 09:55:13 -0400<br>
From: Kris Moore &lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt;<br>
Subject: Re: [PC-BSD Testing] 1.5 update (mouse bug, etc)<br>
To: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;, <a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a><br>
Message-ID: &lt;<a href="mailto:47DA83C1.9080306@pcbsd.com">47DA83C1.9080306@pcbsd.com</a>&gt;<br>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed<br>
<br>
<br>
Rod,<br>
<br>
<br>
Answers below!<br>
<br>
<br>
<br>
Rod Clark wrote:<br>
&gt; Kris,<br>
&gt;<br>
&gt; Mouse bug:<br>
&gt; After I installed the 1.5 update PBI today, my mouse<br>
&gt; involuntarily changed from left handed to right handed, and I<br>
&gt; can&#39;t set it back again. KDE Peripherals/Mouse still showed left<br>
&gt; hand settings, but it operated as a right hand mouse. I set it<br>
&gt; to right hand operation, and then back back to left hand again,<br>
&gt; with no effect. I can use the mouse equally well with either<br>
&gt; hand, but this appears to be a bug. The mouse is a commonplace<br>
&gt; Logitech M-SBF90 optical mouse. I was running <a href="http://1.4.1.2" target="_blank">1.4.1.2</a> before the<br>
&gt; upgrade.<br>
&gt;<br>
<br>
<br>
The mouse problem appears to be common in KDE 3.5.8, and effected other<br>
linux distros as well:<br>
<br>
<a href="http://www.linuxquestions.org/questions/slackware-14/unable-to-configure-left-hand-mouse-with-kde-3.5.8-in-current-607171/" target="_blank">http://www.linuxquestions.org/questions/slackware-14/unable-to-configure-left-hand-mouse-with-kde-3.5.8-in-current-607171/</a><br>

<br>
Once 3.5.9 hits the ports, I&#39;ll see if we can get an update to that ASAP.<br>
<br>
<br>
<br>
<br>
&gt; PBI updates (icon updating, minor):<br>
&gt; The Filezilla update PBI that I ran from the new Installer icon<br>
&gt; on the panel deleted my Filezilla desktop icon. When I picked<br>
&gt; Copy to Desktop from Filezilla on the K start menu, the icon<br>
&gt; reappeared in the same spot as the old Filezilla icon on the<br>
&gt; desktop.<br>
&gt;<br>
&gt; The Wine update PBI deleted my Wine Config desktop icon, but<br>
&gt; when I copied the icon to the desktop again, it bypassed its old<br>
&gt; location and went to a new spot, at the far left of a new row<br>
&gt; below all the other icons on the desktop.<br>
&gt;<br>
&gt; The Firefox <a href="http://2.0.0.12" target="_blank">2.0.0.12</a> update PBI replaced Firefox <a href="http://2.0.0.11" target="_blank">2.0.0.11</a>, but<br>
&gt; afterwards my Firefox panel icon (which it didn&#39;t delete) didn&#39;t<br>
&gt; work. It still pointed to the old <a href="http://2.0.0.11" target="_blank">2.0.0.11</a> PBI location. I<br>
&gt; manually updated the path in the Properties section of the panel<br>
&gt; icon.<br>
<br>
The desktop icons are indeed removed by the PBI updater, and only<br>
&quot;kmenu&quot; icons are installed. This was done for multi-user support,<br>
otherwise if I defaulted to creating a ton of icons, every time you<br>
would upgrade, a new icon would show up on the desktop, and you&#39;d have<br>
to delete it if you didn&#39;t want it :(<br>
<br>
That being said, I&#39;ll look into a solution for this, to see if we can<br>
find a compromise, where it detects and preserves existing kicker /<br>
desktop icons, and updates them to point to the new locations.<br>
<br>
In the meantime, One thing you can do, is simple create a new desktop<br>
icon for your application, and point it to /usr/local/bin/&lt;progname&gt;,<br>
such as /usr/local/bin/firefox. This icon would not be effected by the<br>
upgrade, and since most PBIs make a /usr/local/bin link, the icon<br>
wouldn&#39;t need to be tweaked each time an upgrade was performed.<br>
<br>
&gt;<br>
&gt; Time taken to update:<br>
&gt; 60 minutes, on an Athlon 2200+ system with 2 GB memory and a<br>
&gt; 200GB SATA drive.<br>
&gt;<br>
&gt;<br>
&gt; Port updates:<br>
&gt; As far as I know, the ports in 1.5 are the same (FreeBSD 6.3) as<br>
&gt; I was using with <a href="http://1.4.1.2" target="_blank">1.4.1.2</a>. My ports tree was up to date with<br>
&gt; portsnap. The update nevertheless erased my editor, my Web<br>
&gt; server (lighttpd, php, mysql and other things), gimpshop and a<br>
&gt; laundry list of installed ports that it will take many hours to<br>
&gt; reinstall.<br>
<br>
&gt; This is one of the two reasons (the other is limited hardware<br>
&gt; compatibility) that I have given up recommending PC-BSD to<br>
&gt; anyone who isn&#39;t a serious techie any more, even though I&#39;m<br>
&gt; happy to use it myself. Many users will still need to install<br>
&gt; software from ports with the inevitable minor glitches and<br>
&gt; hassles that entails. After they&#39;ve puzzled out how to install<br>
&gt; some ports, or gotten help from a techie family member to do<br>
&gt; that, along comes a friendly GUI update and this happens to<br>
&gt; them. I&#39;m willing to put in the hours to clean up after this PBI<br>
&gt; update, but believe me, I won&#39;t wish PC-BSD on my family or<br>
&gt; friends who use Macs.<br>
&gt;<br>
&gt; -rsc<br>
&gt; _______________________________________________<br>
&gt; Testing mailing list<br>
&gt; <a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
&gt; <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
&gt;<br>
&gt; !DSPAM:1,47da31c9588511121611996!<br>
&gt;<br>
&gt;<br>
<br>
<br>
To be fair, the update DID warn you about this, no less than twice :)<br>
Once on the download page, and one again before the actual update<br>
install. Power users who are customizing the base system, and installing<br>
/ updating ports should backup their additions, before installing any<br>
updates. Since we roll out binary updates, I can&#39;t include all 14k<br>
binary ports in a package, and try to figure out which ones a user has<br>
installed, so we &quot;upgrade&quot; it at the same time.<br>
<br>
That being said, this patch upgraded a wide range of systems, from 1.3<br>
which was based on 6.1 and higher. And to be truly &quot;feature&quot; complete<br>
with 1.5, it needed to install just the default set of packages. I do<br>
have on my list to get a PBI version of the ports you mentioned, such as<br>
php, mysql, etc. Once users are running those, then they shouldn&#39;t be<br>
effected by an update such as this. Once we get to the point where we<br>
have 14k PBIs available then, hopefully, we&#39;ll users wont need to be<br>
adding / removing ports as frequently.<br>
<br>
--<br>
<br>
Kris Moore<br>
PC-BSD Software<br>
<a href="http://www.pcbsd.com" target="_blank">http://www.pcbsd.com</a><br>
<br>
<br>
------------------------------<br>
<br>
Message: 5<br>
Date: Fri, 14 Mar 2008 10:01:33 -0400<br>
From: Kris Moore &lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt;<br>
Subject: Re: [PC-BSD Testing] Broken GTK engine (Qt) message<br>
To: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID: &lt;<a href="mailto:47DA853D.2040904@pcbsd.com">47DA853D.2040904@pcbsd.com</a>&gt;<br>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed<br>
<br>
<br>
I haven&#39;t yet played with Audacious, so I&#39;m not sure what the stuttering<br>
bug is all about. Is it maxing out your CPU if you look with &quot;top&quot;? Does<br>
it have any sound configuration settings that can be tweaked to run the<br>
same way as Kplayer &nbsp;/ Kaffeine?<br>
<br>
<br>
As for GTK - QT Theme engine, the version in ports is getting pretty old:<br>
<br>
<a href="http://www.freshports.org/x11-themes/gtk-qt-engine/" target="_blank">http://www.freshports.org/x11-themes/gtk-qt-engine/</a><br>
<br>
We are running 0.7 still, when 1.1! is already out :(<br>
<br>
We&#39;ll have to see about bugging the port maintainer to find out if this<br>
can be updated. There&#39;s quite a few fixes / enhancements listed for the<br>
versions after 0.7, and its possible that one of those will fix the<br>
theme engine problem Audacious is having.<br>
<br>
<br>
--<br>
<br>
Kris Moore<br>
PC-BSD Software<br>
<a href="http://www.pcbsd.com" target="_blank">http://www.pcbsd.com</a><br>
<br>
<br>
Rod Clark wrote:<br>
&gt;&gt; &quot;Broken GTK engine in use<br>
&gt;<br>
&gt; Kris,<br>
&gt;<br>
&gt; There&#39;s more to this than I thought. When I ran it, Audacious<br>
&gt; played sound choppily, playing for about 4/5 second and then<br>
&gt; blanking for 1/5 second. That&#39;s with nothing else running - I<br>
&gt; turned off Folding at Home, which normally has no effect on it<br>
&gt; anyway. Kplayer and Kaffeine play videos that sound normal. OK,<br>
&gt; I&#39;m baffled.<br>
&gt;<br>
&gt; -rsc<br>
&gt; _______________________________________________<br>
&gt; Testing mailing list<br>
&gt; <a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
&gt; <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
&gt;<br>
&gt; !DSPAM:1,47da7e19588511021411401!<br>
&gt;<br>
&gt;<br>
<br>
<br>
------------------------------<br>
<br>
Message: 6<br>
Date: Fri, 14 Mar 2008 14:52:04 +0000 (UTC)<br>
From: Rod Clark &lt;<a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a>&gt;<br>
Subject: [PC-BSD Testing] Video drivers settings problems<br>
To: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID: &lt;<a href="mailto:Pine.NEB.4.64.0803141405001.5555@faeroes.freeshell.org">Pine.NEB.4.64.0803141405001.5555@faeroes.freeshell.org</a>&gt;<br>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed<br>
<br>
Kris,<br>
<br>
There&#39;s something odd happening now when setting the video<br>
driver in 1.5. Initially I had set it up with Nvidia 169.12. But<br>
when the audio bug came up, I set the X driver back to nv, which<br>
I&#39;d been using on <a href="http://1.4.1.2" target="_blank">1.4.1.2</a>, just to be paranoid. Changing it<br>
didn&#39;t affect the sound problem, so I went to set it back to<br>
Nvidia. Using the graphical K dialog box, the changeover hung up<br>
mid-process for several minutes with a black screen with a white<br>
outline X cursor in the middle. I could move the mouse cursor<br>
but nothing else responded. I manually rebooted the machine and<br>
picked 6 from the bootup menu.<br>
<br>
After checking my display&#39;s (Planar PL2010M) resolution, it<br>
incorrectly presented 1024x768 in the dialog. (But it also did<br>
that the first time when everything else worked right).<br>
<br>
In any case, it wouldn&#39;t return to the Nvidia driver. When I<br>
picked 1600x1200 24-bit, it instead showed a 1024x768 preview<br>
screen. And even if I clicked OK a that point, it wouldn&#39;t<br>
install the 1024x768 Nvidia driver, exiting with an error<br>
message. When I picked the nv driver instead, it proceeded<br>
normally from there, and so now I&#39;m back to 1600x1200. Unlike<br>
with 1.4.x, there&#39;s very little if any speed advantage with teh<br>
new Nvidia 169.12 driver over nv, at least on my 3-year old FX<br>
5200. The nv driver is the same speed as before.<br>
<br>
Later it occurred to me that a green checkmark like the one for<br>
the panel tray update status had appeared for a while in the<br>
upper left corner of the black screen when it was salled there,<br>
though the check mark also disappeared from the black screen<br>
after a few minutes. I wonder whether that might have been<br>
because of the new system update checking routines.<br>
<br>
Just now, the system/PBI update icon on the panel took a very<br>
long time to switch from the green broadcast wave icon to the<br>
green check mark, so much so that I quit watching it continually<br>
display its little red lettered message about waiting to to<br>
check Scribus. Now it reports everything is updated. But that<br>
took forever. If it&#39;s somehow running during the X setup, maybe<br>
it could be separated out and done later.<br>
<br>
-rsc<br>
<br>
<br>
------------------------------<br>
<br>
Message: 7<br>
Date: Fri, 14 Mar 2008 15:11:06 +0000 (UTC)<br>
From: Rod Clark &lt;<a href="mailto:sc@sdf.lonestar.org">sc@sdf.lonestar.org</a>&gt;<br>
Subject: [PC-BSD Testing] Checking ports a la portsnap<br>
To: Kris Moore &lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt;<br>
Cc: PC-BSD Testing list &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID: &lt;<a href="mailto:Pine.NEB.4.64.0803141458570.5555@faeroes.freeshell.org">Pine.NEB.4.64.0803141458570.5555@faeroes.freeshell.org</a>&gt;<br>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed<br>
<br>
Kris Moore wrote:<br>
&gt; I can&#39;t include all 14k binary ports in a package, and try to<br>
&gt; figure out which ones a user has installed, ...<br>
<br>
Kris,<br>
<br>
Portsnap takes just a minute to scan the entire ports tree. It&#39;s<br>
very fast, and does check each individual port that the user has<br>
added. Maybe there&#39;s a way to do something similar to that. In<br>
an update process that already takes an hour, a few more minutes<br>
spent checking which additional ports are in use (certainly a<br>
comparative few of the 17,000) would be very welcome.<br>
<br>
Maybe it would be OK to first complete the basic installation as<br>
normal, and then to start quietly adding the additional ports<br>
found during the scan, in the background of the otherwise<br>
upgraded and functioning system. Show the user a nice GIU<br>
message explaining that it&#39;s doing that. Write out a scan result<br>
file, and then write a progress file based on that (e.g. line by<br>
line, &quot;blah-port - updating... completed&quot;).<br>
<br>
-rsc<br>
<br>
<br>
------------------------------<br>
<br>
Message: 8<br>
Date: Fri, 14 Mar 2008 13:24:02 -0400<br>
From: &quot;Terry Poulin&quot; &lt;<a href="mailto:bigboss1964@gmail.com">bigboss1964@gmail.com</a>&gt;<br>
Subject: Re: [PC-BSD Testing] Broken GTK engine (Qt) message<br>
To: &quot;PC-BSD Testing list&quot; &lt;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&gt;<br>
Message-ID:<br>
 &nbsp; &nbsp; &nbsp; &nbsp;&lt;<a href="mailto:6cd75f040803141024q63a0f699ked49a4324fd28faa@mail.gmail.com">6cd75f040803141024q63a0f699ked49a4324fd28faa@mail.gmail.com</a>&gt;<br>
Content-Type: text/plain; charset=&quot;iso-8859-1&quot;<br>
<br>
Most port-maintainers I&#39;ve encountered are very nice if you send them a<br>
reminder to update a port.<br>
<br>
<br>
The gtk-qt-engine as included back in PC-BSD v1.4.x I know was a major<br>
problem causer -- no kde, no gtk apps. I don&#39;t know about the stuttering<br>
problem but any visual errors would deffo be caused by it..<br>
<br>
Hopefully gtk-qt-engine 1.x is a lot better then 7.x :-)<br>
<br>
On Fri, Mar 14, 2008 at 10:01 AM, Kris Moore &lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt; wrote:<br>
<br>
&gt;<br>
&gt; I haven&#39;t yet played with Audacious, so I&#39;m not sure what the stuttering<br>
&gt; bug is all about. Is it maxing out your CPU if you look with &quot;top&quot;? Does<br>
&gt; it have any sound configuration settings that can be tweaked to run the<br>
&gt; same way as Kplayer &nbsp;/ Kaffeine?<br>
&gt;<br>
&gt;<br>
&gt; As for GTK - QT Theme engine, the version in ports is getting pretty old:<br>
&gt;<br>
&gt; <a href="http://www.freshports.org/x11-themes/gtk-qt-engine/" target="_blank">http://www.freshports.org/x11-themes/gtk-qt-engine/</a><br>
&gt;<br>
&gt; We are running 0.7 still, when 1.1! is already out :(<br>
&gt;<br>
&gt; We&#39;ll have to see about bugging the port maintainer to find out if this<br>
&gt; can be updated. There&#39;s quite a few fixes / enhancements listed for the<br>
&gt; versions after 0.7, and its possible that one of those will fix the<br>
&gt; theme engine problem Audacious is having.<br>
&gt;<br>
&gt;<br>
&gt; --<br>
&gt;<br>
&gt; Kris Moore<br>
&gt; PC-BSD Software<br>
&gt; <a href="http://www.pcbsd.com" target="_blank">http://www.pcbsd.com</a><br>
&gt;<br>
&gt;<br>
&gt; Rod Clark wrote:<br>
&gt; &gt;&gt; &quot;Broken GTK engine in use<br>
&gt; &gt;<br>
&gt; &gt; Kris,<br>
&gt; &gt;<br>
&gt; &gt; There&#39;s more to this than I thought. When I ran it, Audacious<br>
&gt; &gt; played sound choppily, playing for about 4/5 second and then<br>
&gt; &gt; blanking for 1/5 second. That&#39;s with nothing else running - I<br>
&gt; &gt; turned off Folding at Home, which normally has no effect on it<br>
&gt; &gt; anyway. Kplayer and Kaffeine play videos that sound normal. OK,<br>
&gt; &gt; I&#39;m baffled.<br>
&gt; &gt;<br>
&gt; &gt; -rsc<br>
&gt; &gt; _______________________________________________<br>
&gt; &gt; Testing mailing list<br>
&gt; &gt; <a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
&gt; &gt; <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
&gt; &gt;<br>
&gt; &gt; !DSPAM:1,47da7e19588511021411401!<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; _______________________________________________<br>
&gt; Testing mailing list<br>
&gt; <a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
&gt; <a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
&gt;<br>
<br>
<br>
<br>
--<br>
[SAS]_Spidey01<br>
Regimental Sergeant Major<br>
22nd Special Air service EVR<br>
-------------- next part --------------<br>
An HTML attachment was scrubbed...<br>
URL: <a href="http://lists.pcbsd.org/pipermail/testing/attachments/20080314/f27b5962/attachment.html" target="_blank">http://lists.pcbsd.org/pipermail/testing/attachments/20080314/f27b5962/attachment.html</a><br>
<br>
------------------------------<br>
<br>
_______________________________________________<br>
Testing mailing list<br>
<a href="mailto:Testing@lists.pcbsd.org">Testing@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/testing" target="_blank">http://lists.pcbsd.org/mailman/listinfo/testing</a><br>
<br>
<br>
End of Testing Digest, Vol 14, Issue 11<br>
***************************************<br>
</blockquote></div><br>