I keep getting this error:<br>mount_msdosfs: /dev/da0: Invalid argument<br><br>The same with:<br>mount_msdosfs: /dev/da0s1: Invalid argument<br><br>The strange thing is that I _don&#39;t_ have this problem with 1.3.4. I plug in the same HD and it gets mounted automatically. 
<br><br><br><br><br><div><span class="gmail_quote">On 9/15/07, <b class="gmail_sendername">Kris Moore</b> &lt;<a href="mailto:kris@pcbsd.com">kris@pcbsd.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Gerard van Essen wrote:<br>&gt; Kris, my email to Testing (too big) is getting blocked, so I send it to you<br>&gt; directly<br>&gt;<br>&gt; ---------- Forwarded message ----------<br>&gt; From: Gerard van Essen &lt;<a href="mailto:gvanessen@gmail.com">
gvanessen@gmail.com</a>&gt;<br>&gt; Date: Sep 14, 2007 10:42 PM<br>&gt; Subject: PC-BSD 1.4 14/09 snapshot - USB HD prob<br>&gt; To: &quot;<a href="mailto:testing@lists.pcbsd.org">testing@lists.pcbsd.org</a>&quot; &lt;<a href="mailto:testing@lists.pcbsd.org">
testing@lists.pcbsd.org</a>&gt;<br>&gt;<br>&gt; When i attach my USB external HD (/dev/da0s1 - FAT-32 formatted) I receive<br>&gt; an error &quot;an unexpected error occured&quot;.<br>&gt;<br>&gt; I have no problems accessing this HD with 
v1.3.4!<br>&gt;<br>&gt; Dmesg is showing some errors (see below)<br><br>Gerard,<br><br>Looks like this is the problem:<br><br>Disk too big, try &#39;-o large&#39; mount option<br><br>Can you try mounting the disk from the command-prompt? Does it work
<br>there, or need the &quot;-o large&quot; option as well? If it works there, we may<br>need to find a way to add that option to HAL, or send it over to the<br>maintainer to get it added.<br><br>Try:<br># mount_msdosfs /dev/da0 /mnt
<br><br>Then Try:<br># mount_msdosfs -o large /dev/da0 /mnt<br><br><br>--<br><br>Kris Moore<br>PC-BSD Software<br><a href="http://www.pcbsd.com">http://www.pcbsd.com</a><br></blockquote></div><br>