[PC-BSD Testing] Additional log files for bug reports 909, 910 and 911

Kris Moore kris at pcbsd.org
Fri Jan 24 09:14:12 PST 2014


On 01/24/2014 12:09, kesa at himalia.fi wrote:
> Kris Moore kirjoitti 2014-01-24 18:37:
>> On 01/24/2014 11:30, kesa at himalia.fi wrote:
>>> kesa at himalia.fi kirjoitti 2014-01-23 20:09:
>>>> Kris Moore kirjoitti 2014-01-23 17:51:
>>>>> On 01/23/2014 11:27, kesa at himalia.fi wrote:
>>>>>> Kris Moore kirjoitti 2014-01-23 16:56:
>>>>>>> On 01/23/2014 09:55, Kris Moore wrote:
>>>>>>>> On 01/22/2014 05:37, kesa at himalia.fi wrote:
>>>>>>>>> These bugs seem to be fixed now with
>>>>>>>>> PCBSD10.0-RELEASE-p4-01-17-2014.
>>>>>>>>> However, there is a bug in the first boot. I made a new ticket
>>>>>>>>> 948,
>>>>>>>>> but I can't access the tracker right now. So I'm posting in this
>>>>>>>>> thread to link the hardware details.
>>>>>>>>>
>>>>>>>>> After first stage install and booting the first time. The X
>>>>>>>>> server
>>>>>>>>> goes to self configuration. At the end, it will try to launch
>>>>>>>>> the X
>>>>>>>>> server. But this hangs in a black screen. I was able to launch
>>>>>>>>> the X
>>>>>>>>> server and complete the second stage install after adding Driver
>>>>>>>>> "intel" to the Device section in /etc/X11/xorg.conf while in a
>>>>>>>>> single
>>>>>>>>> user mode.
>>>>>>>>>
>>>>>>>>> _______________________________________________
>>>>>>>>> Testing mailing list
>>>>>>>>> Testing at lists.pcbsd.org
>>>>>>>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>>>>>>> So, does the X configuration work and let you do all the first-run
>>>>>>>> wizard stuff, but the login manager fails to start?
>>>>>>>>
>>>>>>>> This may be a bug in in the Intel driver I've seen, where it can
>>>>>>>> only
>>>>>>>> run once, then it fails to start a second time. It may be that the
>>>>>>>> reboot you did fixed the issue, before even adding "intel" to the
>>>>>>>> xorg.conf section. Did you let it try and reboot first before
>>>>>>>> going to
>>>>>>>> single-user mode?
>>>>>>>>
>>>>>>>> Also, whats your "pciconf -lv" again?
>>>>>>>>
>>>>>>>
>>>>>>> Nevermind on the pciconf, found your old post about it :)
>>>>>>
>>>>>> No it doesn't start the X server at all on the first boot. It
>>>>>> hangs to
>>>>>> the first boot graphical part where initial users get created etc. I
>>>>>> did several reboot attempts that did all hang. I.e. I saw the login
>>>>>> manager only once after adding the entry to the xorg.conf and
>>>>>> completing the second stage of the install.
>>>>>>
>>>>>> Also, I made several installs as I'm not homing to the system before
>>>>>> the final release and therefore I try to make a lot of testing. For
>>>>>> some reason, I managed to fix it by adding the "intel" only on my
>>>>>> first install. On the following reinstalls, it was always starting X
>>>>>> server configuration which ended to the blank screen and when
>>>>>> rebooting in single user mode, the Driver "intel" was missing again.
>>>>>> I'm not sure what I did differently. If "# mount -o rw tank1/*/*
>>>>>> /" (I
>>>>>> looked the tank name with "mount -p") was not enough to make
>>>>>> persistent changes to the files. Or if there was something else I
>>>>>> did
>>>>>> differently, since I didn't pay full attention on my first
>>>>>> install. My
>>>>>> experience is mostly from Windows so finding my way around is
>>>>>> still a
>>>>>> little experimental.
>>>>>> _______________________________________________
>>>>>> Testing mailing list
>>>>>> Testing at lists.pcbsd.org
>>>>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>>>>
>>>>> That is odd. When it booted the installer it "just worked"? When you
>>>>> first boot the installed system, did the "Accept this resolution"
>>>>> screen
>>>>> ever come up?
>>>>>
>>>>> I'm adding some more verbosity to the video wizard, so hopefully
>>>>> we can
>>>>> nail this down :)
>>>>
>>>> The first part of the install, the system booted from the DVD, worked
>>>> without any problems. The second part, after rebooting, nothing showed
>>>> up in X. It just blinked the text "Configuring X " and couple other
>>>> similar texts and then it changed to black screen with a slight
>>>> intensity change (or my imagination).
>>>> _______________________________________________
>>>> Testing mailing list
>>>> Testing at lists.pcbsd.org
>>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>>
>>> I noticed that the announced RC5 is the same version as what I was
>>> already using with the latest issue. And it states that it is likely
>>> going to be the final one. So my question is, how does the process of
>>> resolving the issue continue? I mean, do I start testing with the
>>> STABLE images? I would really like this to get resolved because the X
>>> server has already been working and therefore solution to the issue
>>> should be within reach.
>>>
>>
>> I'm still investigating the issue. Since it works from install, there
>> has to be something different happening in the X detection routine at
>> the first-bootup that isn't via the installer. I'm going to go through
>> that today and see if we can get a fix in for the final release.
>>
>> If you could boot the installer, and check the /etc/X11/xorg.conf file
>> it uses, can you send me the very bottom "Device" section? Is it
>> automatically using "intel" with a BusID of 0:2:0?
>
> This is from the xorg.conf of the installer. Taken with xterm launched
> from the disk partitioning expert mode.
> Section "Device"
>         Identifier      "Card0"
>         Driver          "intel"
>         BusID           "0:2:0"
> EndSection
>
> I remember that the xorg.conf of the booted system had the BusID set
> to 0:2:0. The only difference was that the Driver "intel" was not there.
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing


One last question. During the install, did you happen to pick, or notice
if the NVIDIA driver was installed?

-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Testing mailing list