[PC-BSD Testing] 10.0 on MacBook Pro

Cory Smelosky b4 at gewt.net
Wed Jan 22 23:03:13 PST 2014


On Thu, 23 Jan 2014, Cory Smelosky wrote:

> Hello all!
>
> I copied said image to a USB stick to try on my MacBook Pro (Mid-2012 I 
> think?  13" pre-Retina).  I need to use 10.0 as 9.2 has ACPI and SYSCONS 
> issues with i915kms. (NEWCONS, as provided in HEAD should fix this to allow 
> me to have an actual console until X is properly configured.) Said point 
> seems moot as the installer came up graphically without issue at all. 
> Currently trying an install now to an external disk for testing until all 
> issues are worked out to the point I can install it to the main boot disk.
>
> However, when I got to the graphical installer...it found a disk. However, I 
> didn't want to wipe the internal disk.  I went to "Customise" to choose a 
> different disk...but it wasn't showing any.  Is this a known issue of sorts, 
> should I prod further, or was it likely just a bizarre fluke?  It works 
> perfectly fine in the text-mode installer.  I can choose a separate disk.  I 
> would however like to be given the option to rename the zpool in the 
> text-mode installer, though. (Thanks for adding the text-mode 
> installer...unless it was there before and I'm just blind...)
>
> Will keep you posted with my progress on getting PC-BSD working comfortably 
> on my MBP.  I am VERY determined to succeed.  It'll also give me a chance to 
> work on documenting my procedures so others can repeat them...;)
>
>

Very relevant update: I cannot change the brightness...even if I modify 
the LCD brightness manually via sysctl...it does not change.  There's 
likely a workaround for that I can stumble upon.

-- 
Cory Smelosky
http://gewt.net/me Personal stuff
http://gimme-sympathy.org Projects


More information about the Testing mailing list