[PC-BSD Testing] problem with PBIs requiring aspell

Gour gour at atmarama.net
Wed Feb 26 04:08:35 PST 2014


Hello,

I notice some problems with missing aspell and PBIs..

Here is pbi.conf for my weechat plugin:

#!/bin/sh
# 10.x (12/5/13) PBI Build Configuration
# Generated using EasyPBI

PBI_PROGNAME="weechat"
PBI_PROGICON="defaulticon.png"
PBI_MAKEPORT="irc/weechat"
PBI_MAKEOPTS="weechat_SET=GNUTLS ASPELL CHARSET NLS PERL PYTHON 
weechat_UNSET=DOCUMENTATION"
PBI_AB_NOPKGBUILD="YES"

export PBI_PROGNAME PBI_PROGICON PBI_MAKEPORT PBI_MAKEOPTS
PBI_AB_NOPKGBUILD


but after lauching weechat I notice it's not loaded and attempt to load
it results in:

Error: unable to load plugin
"/usr/local/lib/weechat/plugins/aspell.so": Shared object
│                      | "libaspell.so.16" not found, required by
"aspell.so"


Moreover, I notice that Claws-mail is also having problem with spell
checking - it can't locate spell dicts.

Finally, LyX PBI also can't find dicts...

So, I wonder what is correct procedure to build PBI which requires
aspell checker and associated dicts?

Shall I use PBI_MKPORTBEFORE= with aspell and required dicts?


Sincerely,
Gour


-- 
The senses are so strong and impetuous, O Arjuna, 
that they forcibly carry away the mind even of a man 
of discrimination who is endeavoring to control them.

http://www.atmarama.net | Hlapicina (Croatia) | GPG: 52B5C810




More information about the Testing mailing list