[PC-BSD Testing] Perl 5.16 conflicts with 5.14 during upgrade

Kris Moore kris at pcbsd.org
Wed Oct 30 10:52:22 PDT 2013


On 10/30/2013 09:51, Ken Moore wrote:
> On 10/30/2013 09:28, Joe Maloney wrote:
>> I also had this issue on two systems.  Had to pkg delete -f perl5 to
>> get the upgrade to work.
>> On 10/29/2013 18:33, Jacob . D wrote:
>>> Hi,
>>> upgraded one of my boxes and had this issue.
>>>
>>> used pc-updatemanager pkgupdate using command line terminal
>>>
>>> Compiling from ports fixed this problem
>>>
>>>
>>> _______________________________________________
>>> Testing mailing list
>>> Testing at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>
>> _______________________________________________
>> Testing mailing list
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
>
> Indeed, running "pkg delete -f <conflicting pkg>" before proceeding
> with the "pkg upgrade" is the standard method for resolving these type
> of conflicts. In fact, this is exactly what the graphical package
> manager does when it runs into these types of situations (after first
> asking whether it is ok to remove the offending package).
>

There is also a bug in PKGNG right now, causing it to not display the
list of conflicts up front. Once this is fixed, our tools / utilities
will begin prompting to "fix" these again.

-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Testing mailing list