[PC-BSD Testing] Perl 5.16 conflicts with 5.14 during upgrade

Claudio L. claudio at hpgcc3.org
Tue Oct 29 16:55:47 PDT 2013


On 10/29/2013 7:33 PM, Jacob . D wrote:> Hi,
 > upgraded one of my boxes and had this issue.
 >
 > used pc-updatemanager pkgupdate using command line terminal
 >
 > Compiling from ports fixed this problem

Hello,
Same issue here, but I resolved by executing the update multiple times.
The first time it complained about the conflict and stopped, the second 
time it removed the offending package and then gave an error, and the 
third time the update went through.
If there's a conflict, it should be able to remove the offending package 
in one shot, not three runs but... it works at the end.

Also I noticed the update sometimes starts "resuming downloads" of some 
packages and takes forever to do that. I delete all files in 
/usr/local/tmp/All and then it re-download all the files from scratch, 
but at least it does it much faster than the "resume" function.

Claudio



More information about the Testing mailing list