[PC-BSD Testing] pkg-ng fails to install ibus

Kris Moore kris at pcbsd.org
Tue Oct 15 06:22:07 PDT 2013


On 10/14/2013 20:30, Curt Dox wrote:
> I'm not sure how this issue has slipped by so many hands/faces, but
> for me gtk20 has not successfully built in the last few weeks due to
> this exact same issue.
>
> I have tried removing/deinstalling ALL ports and starting fresh (on
> basically a FreeBSD system) and retrieved ports via svn or via
> portsnap fetch extract.  Any port that needs gtk20 will not build
> because gtk20 will not itself build, due to the lack of
> "libpixman-1.so.9" needed by "im-ibus.so" and there is no exposed
> option to omit the im-ibus module in gtk20.
>
> IMHO the ports tree should not ever have to depend upon hidden options
> or secret commandline flags in order for any port in the tree to
> build, simply go to that place and type 'make install clean' and all
> depends should be drawn in.  It is frankly assinine to ever suggest
> that a port might be "lighter" simply due to dependencies not being
> included by the port's makefile- if it needs something, it will surely
> find it on the system but this does not obviate the requirement, it
> does break the automagical nature of the ports tree system.
>
> The serious and unfortunate thing about gtk20 not building, is that it
> affects a wide swath of ports which may not even use gtk20 directly.
>  One may notice that multiple desktops cannot build.
>
> I continue to look forward to when gtk20 actually builds successfully
> again.  I do not depend upon pkg/pkgng, and this is likely why the
> issue occurs for me and not the devs/maintainers.  The ports system is
> broken in regard to gtk20-dependent ports and that is a shame.
>

:(

I'm struggling to keep our PKGNG repo updated right now, so many ports
are in a broken state at the moment.

Is this on a 9.2 system, or 10? Whats the specific error you get when
you try to compile?

>
> On Fri, Oct 11, 2013 at 6:26 AM, Jacob . D <frag-artists at cox.net
> <mailto:frag-artists at cox.net>> wrote:
>
>     Hi, just upgraded this morning and got this error from "pc-update
>     manager pkg update" via terminal :
>
>     Upgrading ibus from 1.4.1 to 1.4.2...Cannot load module
>     /usr/local/lib/gtk-3.0/3.0.0/immodules/im-ibus.so: Shared object
>     "libibus-1.0.so.401" not found, required by "im-ibus.so"
>     /usr/local/lib/gtk-3.0/3.0.0/immodules/im-ibus.so does not export
>     GTK+ IM module API: Shared object "libibus-1.0.so.401" not found,
>     required by "im-ibus.so"
>     Cannot load module
>     /usr/local/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: Shared object
>     "libibus-1.0.so.401" not found, required by "im-ibus.so"
>
>
>     everything else seems to have been upgraded without issue.
>
>     Just thought I would report this.
>
>     Thanks!
>
>     _______________________________________________
>     Testing mailing list
>     Testing at lists.pcbsd.org <mailto:Testing at lists.pcbsd.org>
>     http://lists.pcbsd.org/mailman/listinfo/testing
>
>
>
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing


-- 
Kris Moore
PC-BSD Software
iXsystems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20131015/9a3af60d/attachment.html>


More information about the Testing mailing list