[PC-BSD Testing] 9.2 ssh error

Bridger Dyson-Smith bdysonsmith at gmail.com
Wed Oct 9 06:24:38 PDT 2013


Hi all,
I'm having a strange ssh problem with 9.2 and I'm not having any luck
fixing it. I've posted to the PC-BSD and FreeBSD forums [1,2], but no one
on either forum has been able to help. This may be a user/operator error,
but I'm stumped.

I'm running 9.2 on my laptop:
> uname -a
FreeBSD rook 9.2-RELEASE-p8 FreeBSD 9.2-RELEASE-p8 #0: Mon Sep 23 16:26:45
UTC 2013     root at amd64-builder.pcbsd.org:/usr/obj/usr/src/sys/GENERIC
 amd64

and I am unable to ssh from the laptop to my workstation (currently running
9.1). When I run ssh...
ssh workstation.at.my.office
ssh_exchange_identification: Connection closed by remote host
I can ssh from my workstation into the laptop without any problems, and I
can ssh from the laptop to any of our servers and from there to my
workstation. If I'm on our wireless network, I can ssh into the workstation
but I tend to avoid that (old wireless card in the laptop and spotty
connectivity to the network). I have lagg0 enabled.

I've checked sshd, /etc/hosts.allow, /etc/hosts.deniedssh, and
/etc/ssh/sshd_config for Match Address (based on a response on the FreeBSD
forum).

Any thoughts or suggestions for getting this working? Could this be caused
by some configuration setting in lagg0? ifconfig follows at [3].
Thanks,
Bridger

[1] http://forums.pcbsd.org/showthread.php?t=20920
[2] http://forums.freebsd.org/showthread.php?t=42200
[3] ifconfig:
> ifconfig
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=4219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC,VLAN_HWTSO>
ether 00:1d:72:98:56:41
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
ether 00:1d:72:98:56:41
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
status: associated
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:1d:72:98:56:41
inet6 fe80::21d:72ff:fe98:5641%lagg0 prefixlen 64 scopeid 0xa
inet 160.36.193.175 netmask 0xfffffc00 broadcast 160.36.195.255
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: active
laggproto failover lagghash l2,l3,l4
laggport: wlan0 flags=0<>
laggport: em0 flags=5<MASTER,ACTIVE>
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:1d:72:98:56:41
inet6 fe80::21d:72ff:fe98:5641%wlan0 prefixlen 64 scopeid 0xb
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet OFDM/36Mbps mode 11ng
status: associated
ssid ut-open channel 11 (2462 MHz 11g ht/20) bssid 6c:f3:7f:ad:ea:61
country US authmode OPEN privacy OFF txpower 14 bmiss 10
scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7
roam:rate 64 protmode CTS ampdulimit 64k ampdudensity 8
-amsdutx amsdurx shortgi wme roaming MANUAL
ipfw0: flags=8801<UP,SIMPLEX,MULTICAST> metric 0 mtu 65536
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20131009/a0c3830e/attachment.html>


More information about the Testing mailing list