[PC-BSD Testing] Issues after installing latest iso

Priyadarshan testing-pcbsd at bontempi.net
Fri Nov 8 14:52:16 PST 2013


On 08/11/2013 16:39, Priyadarshan wrote:
> Hi,
>
> I am meeting three issue after having installed (three times now) the
> latest ISO:
>
> http://iso.cdn.pcbsd.org/9.2-RELEASE/amd64/PCBSD9.2-RELEASE-p9-11-03-2013-x64-DVD-USB.iso
>
>
>
> 1. Setting ZFS set name at install time
>
> Note: I have two disks which I set up as as a mirror a while back, with:
> zpool create -o ashift=12 tank mirror ada0 ada1
>
> The option to give a name different from the default "tank" seem not
> work. If I check the button and input some name, the "next" button does
> not highlight.
>
> If I leave the button unchecked, the set name given at install time is
> "tank1", not "tank", which seem logical, since I already have a "tank"
> setup.
>
>
> 2. At install time I selected the nvidia driver, since I have an NVIDIA
> NVS 310 card.
>
> At setup time, I can see the initial card choice is displayed correctly
> ("nv"), although the resolution is wrong (1024x768, I believe).
>
> When I try to adjust the resolution (1920x1200), X does not recognise my
> card. It almost seems that the driver is not there? I tried many
> different choices, with no success.
>
> In my previous install (FreeBSD 9-STABLE-p9 #0: Sat Sep 14 01:02:17 UTC
> 2013) the card and resolution were properly selected, automatically.
> Right now I am stuck with the generic driver, at 1024x728.
>
>
> 3. It seems that I can't see my old mirror ZFS set anymore. It does not
> shows up in zfs list, nor zpool status. Only the freshly install set
> shows up.
>
> Could it be that FreeBSD-RELEASE-p9's ZFS version is lower than FreeBSD
> 9-STABLE-p9?
>
> How do I go about getting that set back?
>
> At this point, unfortunately, I am unable to use my system.
>
>
> Priyadarshan
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
>


For issue #2 (not picking up the nvidia card), I opened the terminal, 
and from root I ran:
~# nvidia-config

Then logged out, logged back in and the proper resolution was finally 
automatically selected.

I guess the current installer has lost some bits along the way, since I 
did not have to do that with FreeBSD 9-STABLE-p9.


My main concern now is that I cannot figure it out how to mount my old 
mirrored ZFS set (tank). I verified that both ZFS (the boot volume and 
the two mirrored volumes) are using ZFS 5000, so it is not a version 
mismatch.

I would be very grateful on some pointers or links.


Thank you!


Priyadarshan






More information about the Testing mailing list