[PC-BSD Testing] Wrong ABI in pkgng repository for i386

Ilya Bakulin ilya at bakulin.de
Sun Jun 16 09:51:24 PDT 2013


Hi list,
I have tried to use a PC-BSD's pkgng repo for FreeBSD 9.1-RELEASE/i386.

My pkg.conf looks as follows:

root at fbsd-gs:/root # cat /usr/local/etc/pkg.conf
packagesite: ftp://ftp.pcbsd.org/pub/mirror/packages/9.1-RELEASE/i386
PUBKEY: /usr/local/etc/pkg-pubkey.cert
PKG_CACHEDIR: /home/pkg-cache

However, when trying 'pkg update', I get the following error:
root at fbsd-gs:/root # pkg update -f
Updating repository catalogue
repo.txz
                  100%   15MB 532.2KB/s 734.3KB/s   00:29
pkg: At least one of the packages provided by the repository is not
compatible with your ABI:
    Your ABI: freebsd:9:x86:32
    Incompatible ABIs found: freebsd:9:x86:64

So it seems that some packages are for amd64... pkgng refuses to use the
repository.

Please check.

-- Ilya

-- 
Regards,
Ilya Bakulin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 243 bytes
Desc: OpenPGP digital signature
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20130616/ce2f2d29/attachment.bin>


More information about the Testing mailing list