[PC-BSD Testing] [PC-BSD testing] - problem with postgresql9x-server in warden jail

nr10232 nr10232 at op.pl
Sat Jun 15 05:57:54 PDT 2013

Problem solved;
i have to add line to rc.conf
W dniu 2013-06-15 14:37:43 użytkownik nr10232 <nr10232 at op.pl> napisał:
Postgres is not working as it should; it initialize, but i have error with network in jail
when i tried to use portsnap, i get:
portsnap fetch extract update
Looking up portsnap.FreeBSD.org mirrors... host: isc_socket_bind: address not available
none found.
when  tried to start postgres server i get:
LOG:  could not create IPv6 socket: Protocol not supported
LOG:  could not bind IPv4 socket: Can't assign requested address
HINT:  Is another postmaster already running on port 5432? If not, wait a few seconds and retry.
WARNING:  could not create listen socket for "localhost"
FATAL:  could not create any TCP/IP sockets
So i have two options:
-use warden and have network in jail but not have shared memory
-use jail command, and have shared memory but not have any network
W dniu 2013-06-15 12:32:22 użytkownik nr10232 <nr10232 at op.pl> napisał:
I tried to install postgresql server in jail - unsuccessfully. No mater what i try, i have error:
"FATAL: could not create shared memory segment: Function not implemented"
Now jail with database is running - i have to use "service jail jailname start/stop" command.
I suppose warden is not working correctly when it tried to start jail with
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20130615/fc32232a/attachment.html>

More information about the Testing mailing list