[PC-BSD Testing] Virtual box can't import appliance because not root

Claudio L. claudio at hpgcc3.org
Fri Dec 20 04:55:20 PST 2013


On 12/18/2013 03:29, Jeff wrote:
> I'm running PCBSD 9.2 and tried to import a Bitnami VMware appliance 
> into Virtual Box (converts it to .OVF file) using this procedure: 
> http://wiki.bitnami.com/Virtual_Appliances_Quick_Start_Guide#Virtual_Box
>
> But it failed with an error that the file 
> (bitnami-alfresco-4.2.e-2-ubuntu-12.04.vmdk) wasn't owned by root.  I 
> changed the ownership but it still failed.
>
> I deleted the virtual machine and created it again but since VB is not 
> running as root it couldn't find the file in the "select existing hard 
> drive" dialog box.
>
>
> Anyway out of this conundrum? Can I run VB as root some how?
>
> ...Jeff

I got into a problem lately with VirtualBox. I was getting an error 
SUPLIB NOT OWNER BY ROOT.
Perhaps you have a similar problem.
For whatever reason, the folder /usr in my system was owned by 
user:user, and VirtualBox checks that it has to be owned by root for 
security reasons. So in my case I just did:

sudo chown root:wheel /usr

and that solved my VirtualBox problem.

Hope that helps.
Claudio

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20131220/39cc4f56/attachment.html>


More information about the Testing mailing list